Write protected flash disk

By ewan_ko_08 ยท 4 replies
Nov 20, 2007
  1. I have a 1gb flash disk and i cannot open it. I am able to use it before and i don't know what happened why it stopped working. Whenever i double click it from my computer, an error message appears saying that there is an i/o device error. I right-clicked it and tried formatting but it doesn't work. It says that the drive is write protected. I also tried reformatting it using the disk management in control panel but it also doesn't work. It also says that the drive is write protected. I don't need to recover my files, i just want to be able to use my flash disk again. Any solution?
  2. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    look carefully on the side of the card -- SOME have a r/o slide switch!
  3. Daveskater

    Daveskater Banned Posts: 1,687

    Hello, ewan_ko_08, and welcome to Techspot :wave:

    Please take a look at the following threads to make your experience here as enjoyable as possible :)

    Message for all newcomers

    SNGX1275's Guide to making a good post/thread

    The Techspot FAQ

    If you could take a minute to fill in some of your profile information that would be helpful to all members of the forum :)
    Knowing someone's location in the world can be extremely helpful, even if you just put a country.

    Also remember to post any problems or questions that you have in the appropriate forums

    With regards to your problem, i agree with jobeard, there's probably a write protection switch on the side somewhere that slipped across. Flip it back and you'll be good to go :)
  4. ewan_ko_08

    ewan_ko_08 Banned Topic Starter

    There is no slide switch. It is a USB flash drive and i think that most flash drives usually don't have lock switches or something.
  5. Daveskater

    Daveskater Banned Posts: 1,687

    it is possible that it has a switch because my old usb flash drive had a write protection switch on the side

    however if yours doesn't have one then that's fair enough, it could just be that the drive is broken in some way or another but someone else will probably have a better idea or be able to put it in better words ;)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...