ZoneAlarm conflicts TrendMicro online?

By abanerji ยท 7 replies
Aug 12, 2006
  1. I have just installed ZoneAlarm Free 6.5, switching from Windows Firewall. My System details are Compaq Presario P4, 256 MB RAM, XP-SP2, AVG Free 7, Ewido Anti-spyware 4.0, DiamondCS ProcessGuard Free 3.405.

    I had done TrendMicro onlinescan earlier without a hitch. But after installing ZoneAlarm, I am unable to do so. I even shutdown ZoneAlarm and switched on Windows Firewall, but now even Windows Firewall blocked TrendMicro traffic.

    Shall be grateful for advice please. Thanks,
  2. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    ensure the ports that trendmicro uses are open in zonealarm
  3. abanerji

    abanerji TS Rookie Topic Starter Posts: 43

    Thank you for your fast reply. Let me apologise for being such a novice, but how do I "ensure the ports that trendmicro uses are open in zonealarm"?

    Since I have done the TM online so many times in the past, I felt the only new change (ZA instead of earlier Windows firewall) was causing the block. TM site gets into data transfer mode, and after that there's no internet/harddisc activity ... TM site doesn't show any message.

    ZA shows one blocked entry : Rating medium, Protocol UDP, Program svchost.exe, Source, Destination (my ISP), Direction outgoing. Since I am new to non-Windows firewall, kindly let me know if this might represent the traffic going from my PC to Trendmicro Housecall through my ISP?

    I did not understand why, even after shutting down ZA, my old Windows firewall suddenly jumped into action.

    I also have SunJava enabled and I had tried the alternative Java-based scan of TrendMicro, but it too did not run.

    Would any other online scan (kaspersky / a-squared / bitdefender) work seamlessly with Zone Alarm? What if I go for AVG's paid AV-cum-firewall, since I am so comfortable with AVG (so far)?
  4. IBN

    IBN TS Guru Posts: 487

    I have Zonealarm and have ran Trends Housecall without a hitch.
  5. Peddant

    Peddant TS Rookie Posts: 1,446

    Try going into IE and deleting all cookies and temp files.Then try the scan again.

    I also use Zone Alarm for the Trend site and have no problems.

    It takes several minutes to download the file,and nothing appears to happen during that time.

    As for AVG Firewall,by all means give it a try.Most people around Techspot
    use ZA or Kerio,but we`d like to know if AVG is any good.:)
  6. abanerji

    abanerji TS Rookie Topic Starter Posts: 43

    Thank you IBN and Peddant for your posts. I have already expressed my apology for being such a novice on firewalls. But am eager to learn to the extent a non-techie can, from the gurus here :)

    Tedster had advised "ensure the ports that trendmicro uses are open in zonealarm". In my previous response, I had requested for guidance as to how to ensure that. If anybody could enlighten me, I shall be grateful. In my original post, I had mentioned that my ZA is FREE 6.5. I am surmising now that probably such advanced features like port synchronisation are available only in ZA Pro version. Would like to know whether my logic is right or not.

    Even if others are able to run TrendMicro online with ZA in their systems, it may not be so for everyone. Is it likely that settings in ZA Pro are tweakable, which IBN and Peddant have adjusted? I am wondering whether ZA Free can be so configured to enable TrendMicro compatibility. Any instruction would be highly appreciated.

    Peddant, I am responding to your advice about IE cache clearance. I am a bit paranoid about IE's cache, and clean up several times a day. In fact, yesterday, after installing ZA Free, I tried TrendMicro Housecall several times ... both in IE (after using CCleaner to wipe off all junk caches, with TrendMicro url in trusted zone, i.e., ActiveX and scripting enabled), and also in Firefox (using the alternative Java kernel).
    I have been also interacting in the ZoneLabs Forum ( and the Gurus there have instructed me to reset ZA database ... very kindly I have been given a set of step-by-step instructions, and when I am a bit free, am going to try it. Hope it works!

    Although my post has become a bit longish, I am trying to provide as much relevant info as possible. Here's a bit about my Java settings :-

    Just opened the "Applet Cache Viewer" from Java ControlPanel > Temp Files Settings ... "Enable caching" is checked. Yesterday, I tried TrendMicro scan from both their International site as well as European site. The Cache viewer clearly shows two sets of files (from both the sites) - Class & Jar both. In other words, prior to data transfer (from my PC to TrendMicro sites, which got blocked by both ZA and subsequently by Windows firewall when I had temporarily shut down ZA & re-activated Windows firewall for testing), the required Java applets did download and got initialised ... I had observed this in the status bar of my browsers. But thereafter, outward traffic to TrendMicro apparently got blocked, and since TrendMicro did not get a response from my PC, the scanning process froze. I am no techie, so all this may be wrong ... just a hypothesis.

    Java plugin ... today went to do some online banking, and my Bank's website is Java-coded. Was a breezy experience (as usual). My conclusion : Java plugin working fine in my PC.​

    Finally, "It takes several minutes to download the file,and nothing appears to happen during that time." Peddant, I have done TrendMicro online so many times in the past (prior to ZA install), I have carefully observed the process. I am on broadband, and this time I concluded nothing was happening after waiting for very long time ... in the past, the actual scan had started by then. Basically, TrendMicro just seemed to have frozen (no internet or harddisc activity whatsoever), whether in IE or Firefox.

    Thanks again to all for your patience,
  7. Peddant

    Peddant TS Rookie Posts: 1,446

    You referenced svchost.exe in your previous post.That is part of
    the Generic host processes for Windows 32 services.
    It should normally be allowed through,provided it`s the one in the System32 folder.
    It`s is DNS related.Unlikely to be causing your problem though.

    Do you have any other security programs that might be blocking it ?
    Bit defender,Spyware Doctor etc.

    We`re running out of ideas here.:)
  8. abanerji

    abanerji TS Rookie Topic Starter Posts: 43

    I didn't want to put too many protection programs in the background, to avoid issues. Like I said in my original post, only AVG / ewido / ProcessGuard, and now ZA.
    When I want to double-check what these apps are doing (and I am busy with non-computer work), I go online and do some malware scans.

    I got a response from TrendMicro Tech Support, with detailed instructions for a workaround. They have not given a probable reason for Housecall not working in my case. The workaround (downloading the engine and signature database from their site, and then running offline scan in Windows Safe Mode) worked fine ... the scan took a full six hours, and what a relief - no virus/trojan/malware.

    Thank you all for the help. I appreciate your time and effort.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...