1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

3d acceleration unable to start

By Guitaristpat ยท 59 replies
Dec 2, 2007
  1. ghrasko

    ghrasko TS Rookie Posts: 16

    CPU is AMD XP Athlon 2600/2 if it matters...
  2. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    Windows XP pro - 32 or 64 bit?
  3. ghrasko

    ghrasko TS Rookie Posts: 16

    AGP Spread spektrum: Disabled
    AGP 8x support: Enabled
    AGP Fast write support: Enabled
    Video RAm cacheable: Disabled
    AGP Apperture size: 512 MB

    These were set up now in the shop where I bought the card. Card video RAm is 512MB
  4. ghrasko

    ghrasko TS Rookie Posts: 16

    Win XP Pro 32 bit
  5. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

  6. ghrasko

    ghrasko TS Rookie Posts: 16

    OK, I try...
  7. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    If it doesn't work this time -> I am almost positive you need to update your chipset drivers for your motherboard before installing the drivers for your video card
  8. ghrasko

    ghrasko TS Rookie Posts: 16

    I removed all previous ATI drivers and even the Catalyst. I can not see any other video drivers.

    On my MSI motherboard I updated the Award BIOS and also the NVIDIA nForce System Drivers. There is a so called "Live VGA driver" on the live update application with a numerous updates "for all MSI VGA cards". I did not installed them - however their link is broken and most probably can not be reached.

    I set up the drivers from http://ati.amd.com/support/drivers/xp/radeonx-xp.html and it still can not install the drivers.

  9. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    Go to start -> run ->type dxdiag

    What version of directX do you have?

    and the link you posted is the wrong version drivers and will not work with your card -> even if they passed the install you still wouldn't be able to render 3d
  10. ghrasko

    ghrasko TS Rookie Posts: 16

    It works for me now...

    I reinstalled the Catalyst 7.10 that I received in the CD with the card. It at least could installed the drivers without error. It was the same with the newest Catalyst as well. The problem with these was that Direct3D did not work (error in step 8... in the dxdiag test, see above). It seems it was a wrong BIOS setting for me. AGP Apperture size was wrong. Now I set it to 256MB and it works. Tomorrow I will make some cross checks, as I made too many changes with drivers and parameters at the same time.
  11. ghrasko

    ghrasko TS Rookie Posts: 16

    Earlier I tried all drivers, also the one you recommended. That could not installed either. I might try the newest driver tomorrow for test, but now I am rather tired already.

    Thanks for the help
  12. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    and you passed the direct3d test now?
  13. ghrasko

    ghrasko TS Rookie Posts: 16

    yes, and also FS9 and FSX starts normally. TOmorrow I have to play with it again to be sure what was the problem. I do not want to destroy the install now, but I have to know the real cause.
  14. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    When you figure it out can you please post it here for when people find this page on google.

    This is the 3rd time I have seen exact problem in 3 days-> HD2600 won't accept the old drivers but direct 3d doesn't work on the newer drivers
  15. ghrasko

    ghrasko TS Rookie Posts: 16

    Sure, I will. And thanks for the support!
  16. ghrasko

    ghrasko TS Rookie Posts: 16


    In a fresh installed PC with ATI Radeon (Sapphire) HD 2600 PRO 512MB AGP card Flight Simulator 2004 and Flight Simulator X is not starting. FS9 silently quits before displaying the main menu screen, FSX displays a black window only. FS9 starts normally in safe mode: fs9.exe -SWREND (software rendering, i.e. not using the cards features).

    DirectX diagnostic tool dxdiag.exe Display tab/Direct3D test gives error: "Direct3D 7 test results: Failure at step 8 (Creating 3D Device): HRESULT = 0x80004005 (Generic failure)".


    Sapphire HD2600 PRO 512MB AGP
    MSI K7N2 Delta-ILRS AGP motherboard
    AMD XP Athlon (Palomino) 2600/2 CPU
    1GB 400MHz DDR RAM
    Win XP Prof SP2 HU
    .Net 1.1, 2.0, 3.0
    DirectX 9.0c


    The following drive versions are tested from http://ati.amd.com/support/drivers/xp/radeonxprevious-xp.html:

    6-12, 7-7, 7-10, 7-11 and the newest one 7-12

    Other pages like https://www.techspot.com/drivers/driver/file/information/9395/ seems to forward the same pages during download.

    Also the driver set from the card's own CD is tested. It is said to be Catalyst 7.10.

    Also latest driver from http://www.sapphiretech.com/us/support/drivers.php is tested.


    All driver sets from the ATI page fails. Earlier versionas fail with message:

    "Setup did not find a driver compatible with your current hardware or operating system. Setup will now exit."

    7-11 fails with:

    "Setup was unable to find components that can be installed on your current hardware or software configuration. Please make sure you have the required hardware or software."

    7-12 fails with no error message! Does not install any drivers.

    The so called 7-10 version on the card's CD detects the card and installs normally!

    The driver from Sapphire tech web page also installs normally.


    It seems that ATI leaves out the RADEON AGP cards from the installs. In the CX_*.inf files the following line is missing:

    "ATI RADEON HD 2600 PRO AGP" = ...

    This line exists both in the inf file of the CD of the card and in the package from Sapphire Tech.


    I can not recall what had caused the problem for me at the first place. Maybe I immediatelly skipped the CD as I saw it is 7.10 and started with the drivers from the ATI page (recent one 7.12). Or maybe I started with the CD, but it had failed for a reason I can not examine now. Meanwhile I had updated the rather old NVIDIA nForce chipset on my motherboard and I do not want to reverse for the previous one for testing.

    The most importatn thing is that for these video cards one should check the http://www.sapphiretech.com/us/support/drivers.php page for new drivers instead of the ATI page. However the driver package is some 234MB here and the Catalyst package is 197MB. This is 10 times bigger than that of the same packages on the ATI page. One should check the reason.

    Now I selected the version on the CD that includes all the ATI tools as well in a nice package.

  17. Brendino

    Brendino TS Rookie

    I recently bought a Radeon HD 2400 Pro AGP card, and now I am also having troubles getting 3d acceleration to work. When I run the dxdiag direct3d test, it fails at step 8. when I try to use the catalyst 7.7 drivers my settings are set to the lowest color and resolution and I can not change them. I have Directx 9.0c and I have adjusted my aperture to 128. If anyone can lead me to a fix, I would really appreciate it.

  18. ghrasko

    ghrasko TS Rookie Posts: 16


    Read my previous post! I solved the very same problem for myself. The driver (Catalyst) versions on the ATI page does not support the AGP cards. I finally used the 3 month old driver that came on a CD with my card and that is working OK. Also you may try the drivers on:


    During my problem solving I also increased the BIOS value "AGP Apperture Size" from 64MB to 128MB or 256MB. This work fine, but I think it was not the problem, but the wrong drive from the ATI page.

    Is this a new PC, or just a new card? What was your previous card? Did it work fine with 3D acceleration?

  19. Brendino

    Brendino TS Rookie

    This is just a new card. My old card was a Radeon 9250 and it worked just fine with the 3d accelerator. Ive tried a bunch of different driver versions, but ill try some again from that site and tell you what happens
  20. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    You also need to ensure that your chipset drivers on your motherboard are up to date.

    *The fix that I suggested seems to not work with the HD2400 and HD2600 series cards, they don't like the old drivers and the new drivers don't support AGP.

    The simple fix for this is for ATI to bring back 100% support for AGP on their next version drivers. Or put out 2 separate drivers, one for the pci-e cards and one for AGP cards. Why do they not see that. Guess that's why Nvidia is kicking their ***
  21. Brendino

    Brendino TS Rookie

    So basically what can we do if we have a HD 2400 or 2600 card? Is there no way to get 3d acceleration working. Also, where would one find up to date chipset drivers?
  22. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    What card do you have exactly. Who made it, i know its an ATI based gpu but is it something like Sapphire HD 2400 or Powercolor HD 2400. sometimes its works getting the driver from the other company
  23. Brendino

    Brendino TS Rookie

    It's a Visiontek Radeon HD 2400 Pro
    and I made sure my chipset was updated, and I tried literally every driver I could find (ATI, omega, visiontek, and the site that was posted earlier) all with no avail. I am just going to give up and find me a different card haha.
  24. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

  25. Brendino

    Brendino TS Rookie

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...