3G Usb modem causing bsod

By closertohabbit
Jun 10, 2008
  1. Hey all,

    I'm pretty sure that this is a driver issue, that's why I'm posting it here.

    I got a 3G Usb Modem last week, an iCon 225 model from the company Option. When I connect it to my laptop, it causes the dreaded BSOD.

    This is the error message it gives...


    *** STOP : 0x000000D1 (0x00000000, 0x00000002, 0x00000000, 0xF1C080DC)

    *** gt72ubus.sys - Address F1C080DC base at F1BFF000, Datestamp 470b6bab"

    Now, that gt72ubus.sys file is a driver for the Modem. But the thing is, I have the latest version, I have tried with an older version of the drivers and I still get the BSOD.

    I have an Acer Aspire 3000 laptop, with Windows XP Service Pack 3 freshly installed. I have all the latest updates and I'm pretty sure I have no malware. Bitdefender, Avast, Clamwin, Spybot and Ad-Aware all found nothing.

    My Bios is updated and I my ram (1 Gig) has passed memtest (I know the memory could still have problems)

    I have also increased my page file sizes, and these Blue Screens also keep happening when the laptop is idle.

    The modem works on my desktop with no problem, and it has worked on 3 other computers at work with no problem. (making me think that it's something specific with my laptop)

    Does anyone have an idea or suggestion??? (I have also tried other USB ports and still nothing)

  2. Spyder_1386

    Spyder_1386 TS Booster Posts: 498

    Hey Closertohabbit

    This might sound like a silly question but do your USB ports work with other devices - maybe a flash stick or an external hard drive? I'm just trying to figure out whether its actually your USB slots that are the problem as you have not mentioned the use of any other USB devices on your laptop.

    Spyder_1386 :)
  3. closertohabbit

    closertohabbit TS Rookie Topic Starter


    Yes, I have tried other devices on the USB Ports. My thumb drive works fine, external DVD-burner works fine...my iPhone connects fine and syncs without a problem.

    I put in the modem, it gets recognized...I connect...I get the speed I should be getting...everything seems to be fine, and then suddenly blue screen. It can take 5 minutes, it can take 3 hours...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...