1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Accessing an old IDE HDD in Windows 7 64bit OS

By Schmutz ยท 20 replies
Apr 10, 2010
  1. Hello, I am trying to access some files stored on an IDE hard drive in Windows 7. I recently found out about "drive management" function which I can use to assign a letter/path to the drive - however it now says:

    " you need to format this drive before you can use it "

    and then...

    "F:\ is not accessible.

    the volume does not contain a recognized file system.
    Please make sure that all required file system drivers are loaded and that the volume is not corrupted"

    I think it could be something to do with older file systems and compatibility (FAT32/NTFS...?) But I don't know really. Maybe I have set it up incorrectly

    The hard drive is not corrupted as far as I am aware. The last time I used it was around a year ago on an older computer which I no longer have access to and it has been safely stored ever since

    any ideas will be appreciated!

  2. mailpup

    mailpup TS Special Forces Posts: 7,309   +581

    Windows 7 should write and read to FAT32 formatted hard drives. Flash or thumb USB drives are FAT32.
  3. Schmutz

    Schmutz TS Rookie Topic Starter Posts: 124

    ok, thanks. Does that mean that my drive could well be corrupted or are you just ruling out any relation to "file system" compatibility?
  4. mailpup

    mailpup TS Special Forces Posts: 7,309   +581

    The former is a possibility and the later is correct. Are the jumpers configured correctly on the IDE drive or drives? I don't know what other drives you have connected.
  5. Schmutz

    Schmutz TS Rookie Topic Starter Posts: 124

    Ok. I haven't used any jumper pins I'm not really that clear on how they work but I have the following drives installed on my computer:

    500GB (Windows 7 Ultimate 64bit Operating system)
    1TB SATA (multimedia)
    1TB SATA (games/applications)
    40GB (IDE)

    I am trying to access the 40gb IDE drive so that I can copy the files onto one of the larger SATA drives and get rid of it :D

    I don't know if this is valid information, but the ribbon cable I have used to connect it to the motherboard is configured as so:

    Mother board --> ribbon cable --> 40GB IDE --> DVD drive

    Both the 40GB hard drive and the DVD drive do not have any "jumper" pins present
  6. captaincranky

    captaincranky TechSpot Addict Posts: 14,382   +3,602

    Drives formatted with XP Pro are not accessible with Windows Home. I understand that that is not quite the situation you're dealing with, but I wonder if something like this could be part of the problem. As I recall, the error message was similar.

    What you could do is download a copy of "Ubuntu" Linux, and run it directly off your DVD drive. Ubuntu will read and write NTFS, so you might be able to back copy your files from the IDE drive to the SATA.
  7. mailpup

    mailpup TS Special Forces Posts: 7,309   +581

    Look at the back of the IDE drives. They both should have jumpers already installed. Look for a little plastic/metal bridge that "jumps" two pins. Ordinarily you set the hard drive as master and the second drive to slave. The drives should have a guide stamped or printed on them to show which sets of pins to bridge as master, slave or cable select. If your motherboard supports it, you can use cable select but both devices must be set as CS.
  8. captaincranky

    captaincranky TechSpot Addict Posts: 14,382   +3,602

    As Mailpup suggested; Motherboard ----> ribbon cable----> (THEN) DVD------Hard Drive.
    The center plug on the ribbon cable is the slave. The HDD is always used as master, so when you reverse then, that might solve your problem.

    Every IDE HDD I've seen has had a jumper, if that's missing, that could be the problem also.
  9. tipstir

    tipstir TS Ambassador Posts: 2,839   +193

    Keep all SATA drives connected via SATA serial cables
    DVD is that IDE or SATA?
    IDE should be not connected to the DVD ribbon. DVD if on ribbon should be the Secondary Master and the IDE would be Secondary Slave. Best to use C-S instead of using P-M or P-S or S-M or S-S. Note only do this if the DVD is IDE. If the DVD is SATA then that would be on it's own serial cable.
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Ooops. Captain: Where'd you hear that? To my knowledge, i don't know any reason why an XP Pro formatted drive can't be read by XP Home (or vice versa) /* Please see edit2 below */

    It sounds like the computer is seeing the drive but not recognizing a filesystem.
    I'm asking so correct me if i'm wrong but Does the computer detect and see a drive when the cabling is wrong? Based on the error messages.. i'm thinking Windows sees the drive with a "raw" filesystem (i.e. the filesystem is corrupt and windows doesn't recognize it as ANY filesystem). In which case, OP should try running TestDisk to check for corruption, and see if it can rebuild filesystem and partitons and do data recovery.

    /* edit */
    Windows recognizes a disk and assigned a drive letter

    /* edit 2 */
    Ooops to myself... I may have read your sentence wrong.. tho i think same is still true: no reason an XP formatted drive can't be read by Win 7 Home? (is win 7 what you meant?)
  11. captaincranky

    captaincranky TechSpot Addict Posts: 14,382   +3,602

    Actually that happened to me. I pulled a drive from a computer running XP Media Center, (which starts out as XP Pro). and stuffed it in a machine running XP Home, and that's the error I got. Basically, either format it or put it back in a machine with XP pro. Who knows, maybe it was malware.
  12. Archean

    Archean TechSpot Paladin Posts: 5,633   +97

    Probability is that it was the case captain.

    I think probability is either partition is damaged or file system is corrupted, therefore, Looking's suggestion of using TestDisk is very appropriate/helpful. Rgards
  13. hughva

    hughva TS Rookie Posts: 53

    Confusion reigns.
    Both SATA and PATA are IDE. SATA uses the thin cable, PATA uses the ribbon cable.
    I don't know of any reason a drive formatted NTFS by one windows version can't be accessed by another.
    It doesn't matter where the hard drive or DVD is located on the ribbon cable as long as the jumpers are set correctly.
    If the drive still can't be read after setting the jumper correctly, the suggestion to use Ubuntu or Test disk sounds like the correct next step.
  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Follow the "logical" road....

    To best of my knowledge and current understanding of that "road"
    (Device Manager) -> (Disk Management) -> (Explorer and My Computer)​

    1. Is Device Manager happy?
    Hardware detected-> PlugnPlay handshake completes OK (implies cabling and base level connectivity OK) -> Drivers loaded and running OK (Driver Status= Working Properly)

    2. If Device Manager's not happy the drive won't appear in Disk Management (which helps map the drive to logical volumes) Disk Management also depends on two services to run correctly:
    > Logical Disk Manager and Logical Disk Manager Administrative Service
    > When Disk Management is running both of these services should show their Status=Started

    So... since the drive is noticed in Disk Management... My first guess is: cabling is OK. It's a filesystem related issue

    /* edit */
    Corrected: LDM services should show their Status= Started
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    On the one hand, sometimes the only thing 100% for sure about computers is sometimes there "ain't nothin' " 100% for sure about computers :D

    That said and while i have no doubt that's the symptom you saw... i have to think you had some other anomaly involved as well (e.g. perhaps the case as Archean suggests, flaky connector, malware, disk filter, etc.)
  16. tipstir

    tipstir TS Ambassador Posts: 2,839   +193

    PATA Ultra 133 is IDE uses pin ribbon connector. SATA serial uses different power and connector to connect to the system. No ribbon cable is use. More of snap connect with L shape also the same is for the power connector which is larger. I just installed Blue-Ray player into one of the Q4-64 I have here. It's SATA I have 7 snap on connections on the MOBO.
  17. Schmutz

    Schmutz TS Rookie Topic Starter Posts: 124

    Thank you for the suggestions I shall now run through them starting with test disk and report back

    To let you know I have tried installing as so:

    Motherboard --> ribbon cable---> 40GB IDE

    = no DVD drive in the equation (to eliminate any purpose for jumper pins...) and I still received the same error message in Windows

    I do not actually own any "jumper pins" (or I have lost them) so I hope that this means we are past the idea that bad jumper configuration is the cause

    Please note also that by "jumper pins" I am referring the small (plastic?) component used to cover two of the pins on the back of IDE drives - I am quite sure it has a name but I do not know what that is hehe :blush:
  18. tipstir

    tipstir TS Ambassador Posts: 2,839   +193

    Does the BIOS see the 40GB IDE? Start there first. If the BIOS doesn't see it then you can forget Windows seeing it. You know the best thing to do it get one of those USB en closers for your IDE and then pull off the info you need that way. If you still can't get it to work.
  19. mailpup

    mailpup TS Special Forces Posts: 7,309   +581

    Its name is jumper. Also, I don't know how you can ignore no jumpers since without them the IDE drives won't be recognized and isn't that one of your problems?
  20. tipstir

    tipstir TS Ambassador Posts: 2,839   +193

    Some IDE don't need to use the jumper if they're set to CS. Depends who makes the HDD. Make sure you select the correct one for the correct ribbon cable or just play it safe and use CS (cable select) Let the system decide.
  21. mailpup

    mailpup TS Special Forces Posts: 7,309   +581

    But don't you set it to CS using a jumper?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...