Acer 3690 Touchpad

By austinbyrnes
Jul 8, 2010
  1. a friend of mine asked me to take Vista off his system an d put xp on it so i did.

    he negeclted to tell me that his touchpad had stop working before i did it.

    so off went vista on went xp home edition Sp2 and thought i could solve the problem later on down the line with a driver.

    so i used an usb mouse to continue with the xp installation.

    as we know with installing a new operating system there is alot of work to be done afterwards,go to device manager and see how many yellow ? you have to update drivers. 1st thing i noticed is the device manager did not pick up the touchpad only the usb mouse when i plugged out the usb mouse. the mouse and other pointing devices was gone from device manager.

    so i am at a stage now where everything in the laptop works grand.. got his web cam working,wireless card working,bluetooth card...etc...etc..etc..

    in device manager no yellow ?. so all drivers updated.

    as for touchpad i know from previous experiance the FN + F7 will disable/enable the touch pad. and when i do it it comes up on the screen touchpad disable/enabled i do it several times. still no reaction from the touchpad. i go to acer support website and download the Synaptics driver for the tochpad. do a reboot and still nothing from touchpad i try the fn +f7 again. no respone again.

    what is bugging me is this

    1.Device Manager reads no tochpad installed under mouse and other pointing devices which would suggest to me that its hardware. that if its not read in device manager than its not connected to the board.

    2.but if i press Fn + F7 it reads touchpad disable/enable so the laptop does read the toucpad in some way.

    3. i install a program called everest. you may know it. its basically a program that reads your hardware. tells you your ram make and model,speed. hard drive make and model, size of it.. motherboard name, bios details.. etc..etc..etc..

    the thing is when i go to input devices through everest my P/s 2 touchpad mouse comes up with my external usb one.

    yet still in device manager nothing..

    i cant figure out how one reads it and other doesnt.

    Any help Please. sugestions anything.......


    i have gone into IRQ settings and it is IRQ 12 and it reads:

    this device is not present, is not working properly, or does not have all its drivers installed. (code 24)
  2. williams2329

    williams2329 TS Rookie

    I have the same problem but I was moving from Windows XP to Vista on my laptop. I had recovered all drivers but my touchpad and USB mouse were not working. Then I download drivers of both from Microsoft site but only once they worked than after all things are same. If you get the solution for touchpad than share it with me.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...