Adobe PhotoDeluxe Home Edition 4.0

By B00kWyrm
Nov 27, 2014
Post New Reply
  1. Please note, this is not a question about replacement software packages.
    This is a question about tweaking system settings
    for smooth experience of old software on more recent OS and hardware.

    I started using Photodeluxe when it was packaged with one of my early scanners.
    I would guess circa 1998. It was version 2 at the time.
    Obviously designed for earlier versions of Windows. (I may have been using Win95 at the time)
    It has remained a workhorse for me, and I have upgraded it. (version 4)
    and I successfully migrated it, to each subsequent OS I have used.
    I have successfully used it on Win 98, WinME, Win2k, WinXP (all service packs),
    and now on Win7 - YES... successfully, on all.

    But today I have a problem... It is not starting.

    What is different from yesterday / last time used?

    Well, I added "Audacity" and EZVinyl, for recording (and manipulating the waveforms) of old LPs.
    Not sure how that should have affected anything though...
    as Audacity and Ezvinyl would affect sound more than graphics,
    (or so I would think. Someone here may know better.)

    What I have I tried, in the effort to resolve?
    • Delete/rename the existing program prefs file... Pd20.psp
    • Use TFC to cleanup old tmp files.
    I have also tried
    System->Advanced->Performance->Settings->Advanced-Virtual Memory -> Change
    changing my virtual memory settings as Photodeluxe does use significant space.
    • and as I recall, this program is quirky in requiring contiguous space!
    And I think this was what I adjusted initially in order to get in functioning ...
    and it was functioning quite well!
    Specific changes that I have tried...
    • increasing the custom paging file size to 10x as much (yes I have the room!)
    • using system managed size
    • using no paging file
    • setting max and min both to 64 meg (per advice found elsewhere)
    • automatically manage paging file size.
    • return to original settings...
    No joy with any of these. So... any thoughts?
    (Other than scrapping the program, and replacing with Elements, Gimp, etc)
    I reiterate. It was working... just grand!

    My System?
    • Dell Vostro 3550 (i3-2310m), 8gb mem. Win7 Home Premium (64bit),
    • Boot Drive is Samsung 830 class ssd (224gb, with 100gb free)
    • External USB3 Drive for data - Seagate goflex 1.5Tb, with about 3/4 free.
    • None of this has changed since it was last working.
    Program compatibility settings: Run this in compatibility mode for WinXp Svc Pack 2

    Using Other Additional Hardware:
    • two external monitors (one landscape hdmi, one portrait vga)
    • have used multiple scanners. Usual is a Mustek A3 usb scanner.
    • These have not changed!
    So... Any thoughts?

    My understanding that defragging an ssd is not recommended,
    but my only thought presently is that
    while I do have the disk/drive space it may not be contiguous.

    Tried further steps
    this evening, even though I doubted they would do a thing...
    • disable anti-virus
    • uninstall Audacity and EZVinyl
    • disconnect monitors and use only built in monitor.
    Again... I had no reason to believe any of this would have any effect,
    and it did not.
    • The program was running with the current AV solution.
    • The program was running with the current monitor set-up.
    • I saw no reason for the audio programs to affect this graphics program.
    Edit/Add, Next Day
    And, now to make it interesting...
    Just went to my "off site office", where I still have a dual monitor setup.
    One is connected through the HDMI port, the other through the VGA,
    just as at my main site.
    • Different Monitors, but I did try different monitor set-ups at the main site, to no avail.
    • Different keyboard and mouse. (Wired USB, vs Wireless)
    • These are the only differences. .
    BUT, Here... Started right up without a second of hesitation!
    Come to think of it... last time I used the program
    I may have been using wired mouse and keyboard at the main site...
    Why would that matter? What. Is. Going. On???

    Edit/Add, Later Next Day
    Well... looks like I solved my problem... more or less.
    It is the Logitech wireless tech that is causing problems with the program.
    I can leave the unifying receiver unplugged, until after starting the program.
    The program starts fine without it.
    Then the program runs well with built in keyboard/touchpad, or with wired keyboard and mouse.
    AND... while the program is running, I can unplug my wired kb and mouse, and plug in the unifying receiver, and now the program is running and editing graphics, with the the Logitech hardware that was preventing it from starting. But no matter what I try, I cannot get the program to start with the unifying receiver installed.

    Any idea why Logitech's unifying tech and this particular program don't know how to play nicely together?

    (Still wondering if there is a tweak, instead of this kludge solution).
    (probably no one cares but me. <lol>)
    Last edited: Nov 28, 2014

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...