ASUS P4P800-X BAD BIOS Checksum

By BARTamiroquai
Mar 4, 2006
  1. I have 2 Harddisks installed on Primary IDE. The AOpen CDwriter and ASUS DVD writer install on Seceondary IDE. The system worked perfectly.

    Recently I bought a WESTERN DIGITAL SATA2 250GB (WD2500) and had it install on the First SATA and I had already set the jumper to SATA1 mode at the back of the harddisk. When I checked the BIOS, the Harddisk name was visible at the First SATA then I saved and ReBOOTed. The System said
    Bad BIOS checksum. Starting BIOS Recovery...
    Checking for floppy...
    Floppy not found!
    (After several times I then put the ASUS CD that came with the M/B )
    Checking for CD-ROM
    CD-ROM found.
    Reading file "P4P800-X.ROM". Completed.
    Error! ROMID is not compatible with existing BIOS ROMID.

    I tried to reboot the system again and again and Removed the SATA2 Harddisk until the ASUS Logo appeared on the screen and i had to set the time and date of the system again in the BIOS menu.

    Using WinXP, I used the ASUSLiveupdate to copy the current BIOS from the Mainboard to a Floppy disk and rename the file to "P4P800-X.rom"

    Then I tried to reboot from the WindowsXP for 5 times (Without the SATA2 installed) No Problem!

    I then connected the SATA2 Harddisk and turn on the system and the same problem happened.
    With the ASUS BISOCrashFree2 function, I use the floppy disk containing the system P4P800-X.rom and it said i have to turn off and on the system.(After the flshing and programming) I did it and The same problem happened(Bad BIOS checksum)

    The Problem now is In many cases including with or without SATA2 HD installed and using the ASUS-CDROM or my floppy disk. The "Bad BIOS checksum" always appeared. I dont know what to do now. I'm so depressed Pls HELP :(

    SYSTEM Information:
    BIOS version 1009
    1.8 GHz Intel
    Winfast A170 Gforce4MX (AGP4X)
    1 GBs RAM (256,256,512)
    120GBs Seagate, 40 GBs Maxtor, ASUS DVD writer, AOpen CDWriter
    Juli@ Audio card
    and the recently bought WesternDigital 250GBs SATA2 HD (WD2500)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...