Asus P5P43TD PRO doesn't POST with new HyperX 1600 RAM


Jennifer Bates

I wanted to get more RAM for my older PC (CPU Q8400 on Asus P5P43TD PRO). The motherboards' specs say it works with 1600Mhz RAM so I bought 8GB of Kingston HyperX Blu (Kit 2x4GB), code KHX1600C9D3B1K2/8GX.

I already have the latest version of BIOS but it doesn't POST for the life of me (fans are working, black screen, no beeps). I tried inserting only one stick (tried all 4 slots). I tried both sticks in slots 1 and 3, both sticks in slots 2 and 4, still no luck.

When I put back my old RAM (2x2048 Kingston Value RAM) it works just fine. Everything in BIOS is set to AUTO. I tried increasing the RAM voltage to 1.65v as specified on the new sticks without success.

I'm sure the memory is fine but I just can't get it to work. Any suggestions are greatly appreciated!


Posts: 13,141   +6,438
You may need a BIOS update. CPU and Memory compatibility updates are common BIOS updates. Before you give up on the RAM modules, try updating your BIOS.

ASUS Support For P5P43TD PRO

Caution though, follow the instruction carefully. The updating can not be interrupted once started. It only takes a few minutes to complete, but any interruption can brick the motherboard if it is not equipped with a backup BIOS.

I just recently bought a motherboard I thought was completely dead (same symptoms as your board, no post). I never suspected the motherboard wouldn't recognize my i7 CPU. The tech guy had me use an i3 to flash the BIOS. Low and behold the BIOS update worked.

Jennifer Bates

I already have the latest BIOS version (read my post!). I updated it before buying the new RAM. It was pretty easy to update using the built-in BIOS updater and a USB thumb drive.

Jennifer Bates

Yes I did boost the voltage from Auto to 1.65v without any success. Every time I need to change something in BIOS I need to swap the old RAM so I can get it to POST and allow me to enter the BIOS. This is getting tedious.

I could return this new RAM, no problems with that but if I get new ones, possibly from different manufacturer how do I know I won't run into the same problem??


Posts: 296   +73
Just trying to help out here. Your motherboard has 4 ram slots, so why not leave the original ram in the 1 and 3 slots and add the new ram in the 2 and 4 slots? Then also, try leaving the Bios setting on Auto instead of increasing the voltage to 1.65v. Its not going to hurt anything to try and see if it will post.


Posts: 4,840   +1,270
It's either one of three possibilities:
1. The board doesn't have extensive support for 4GB modules. The Asus P5P43TD Pro QVL doesn't list any 4GB module support - see the PDF link under "Memory/Device Support". Note that Kingston's memory configurator doesn't list the modules as compatible with the board, so don't get your hopes up.
2. The modules are fried (unlikely if they're new)
3. The board isn't resetting the modules to JEDEC spec. Note that DDR3-1600 is considered an overclocked frequency for the P43 chipset, so if the board is setting the frequency via the RAM's embedded XMP profile then your settings are out of whack.This possibility is fairly easy to test for:
With the old modules inserted, dive into the BIOS and manually set the RAM profile for a fail safe JEDEC profile for your CPU. I assume that the E8400 is at stock frequency (3GHz with a bus speed of 333MHz/1333MHz FSB) ? If so, then manually set the major timings to DDR3-1333 at 9-9-9-27 (CAS- tRCD-tRP-tRAS) @ 1.65V. Set the command rate to 2T if not already set.
This CPU-RAM frequency uses the 1:1 memory divider/ratio ( 1333MHz for both the CPU and RAM) so it doesn't get any more stable than that.
Save your BIOS changes, shut it down, swap out the RAM (use a single stick to start with) and see of the board will POST. If it doesn't then return the RAM for a kit listed in the QVL. or visit some memory vendors sites and use their configurators. For example:

Some Asus boards do have issues with 4GB modules (and auto detecting unobtainable XMP profiles) even though technically the board supports the features.

Jennifer Bates

My old RAM is 2x2048 Kingston Value RAM at 1333Mhz. Looks like the mobo isn't accepting the new RAM in any configuration, not even mixed with the old RAM. Oh well, it seems I'll have to return them and try to find some old Value RAM instead, possibly only 2GB sticks to make sure they are compatible.
I think this might help, I had the same problem, but now I'm running with 4gig RAM in the Asus p5p43td pro. it doesn't support 8gig. I tried it, I installed two of 1gig's in first n second slots then 2gig in the third slot it worked. It's running fast.