ATI 9000 Pro 64mb - Graphical artifacting on certain games

By Arris ยท 10 replies
Apr 21, 2003
  1. Problem:

    On my friends computer a couple of titles are causing graphical artifacts on some graphics (transparent overlays and some menu items), not on the whole image. These titles are Battlefield:1942 and C&C:Generals. These are both EA games and I thought maybe it was a problem with shared graphical modules and ATI graphics cards. I haven't tried either of these games on my 9700Pro but will do this evening, and post results here. The other possibility I thought of was that the card or its memory was overheating, but the fact that Medal Of Honor and HL - Counterstrike run flawlessly kinda of disproves that...

    Also on occasion the system has rebooted, both running on win2k and winxp. Its a fairly decent power supply of 400w otherwise this would have been my first guess. His +12v line was sitting around 11.63v in the bios which I thought was a little low, but when other games run ok I can't see how the PSU would be the problem.

    Isn't BF:1942 using Q3 engine like MOHAA, if so then I don't understand why one runs fine and one has issues.
    I tested the game on my 1.7Ghz P4, GF4Go 32mb laptop and it ran more smoothly than my friends system, so definitely a problem here, other than the corruptions and reboots.

    The game has the latest patch applied and is using DirectX 9 with Cat3.2. I know that the card isn't directX9 compatible as such but my laptop ran it fine with DirectX9. This is partially why I think it might be an ATI issue, although I wouldn't think it could cause reboots...

    Anyway any insights and suggestions of fixs to this problem would be greatly appreciated...


    -Athlon 2100+ @ Stock
    -Coolermaster Aluminum silent heatsink (40C idle in BIOS)
    -AsRock K7S8X SiS746F
    -Powercolor 9000 Pro 64mb @ stock (DirectX9 and Cat3.2)
    -Generic 256mb PC2700 (I'll need to check on which chips this has) @ SPD settings
    -Onboard sound
    -Windows 2000 Professonal SP2
  2. StormBringer

    StormBringer TS Maniac Posts: 2,244

    11.63v is fine for the 12v rail. Some sources say 5% tolerence, some say 10%, either way, that is within tolerence. You might want to check the Amp rating on that rail and compare it to the load. Otherwise I think the PSU is ok.

    The reboots suggests maybe a driver problem. I've seen many times random reboots being linked to driver problems and people misdiagnosing it as a Power problem(seems every time a system reboots, people start changing the PSU) Might want to try a different set of drivers or try reinstalling those. Might also try removing DX9. I don't think it is the problem but it could be some way related, besides, if it is not supported, it really has no reason to be there.
  3. Arris

    Arris TS Evangelist Topic Starter Posts: 4,730   +379

    I've read a couple of posts that suggest it could be the Cat3.2s that are the problem thanks for the info :)
  4. Elros

    Elros TS Rookie Posts: 31

    As the afore mentioned "friend", I'd like to say thanks Arris for posting this. You beat me to it man. ;)

    Anyway, thought I'd add another wee spanner to the works.
    I decided to try Operation Flashpoint (I used to play it on my old machine, and I was itching for some helicopter action), and got a surprise when the graphics were fine, but the sound got corrupted. It started slowing down the output, then the sounds were all screwed up (not the sounds it should have been playing), like squeeks and scratchy sounds.

    Any ideas what could be causing this? Maybe I need to get a priest to exorcise it?

  5. Arris

    Arris TS Evangelist Topic Starter Posts: 4,730   +379

    I'd be tempted to disable the onboard sound and try your old SB sound card to see if you still get the same problem. All onboard sound prior to Nvidia Soundstorm has always, IMO, been a bit ropey.

    I suggest that I bring my "stable" *cough* machine over and we try your graphics card in it. (well its stable @ 13x133 :S )

    BF1942 ran fine on my PC at default clock speeds..

    Didn't quite get it stable at 2.3Ghz and 200fsb last night.
    Might put some more volts through the CPU since it was reporting a loaded temp of 55C, it should take a little more :)
  6. Elros

    Elros TS Rookie Posts: 31

    Sounds like a plan.

    I'll try the old sound card and see what happens. Shame though, since the onboard sound output can be Dolby/DTS. :(

    Oh, I tried the older Cat3.1 drivers last night, but the results were even worse than with 3.2. :(

    Trying out the Gfx card on your machine sounds like a good idea. Probably easier for me to take the card to the machine rather than the machine to the card though. :D
  7. Arris

    Arris TS Evangelist Topic Starter Posts: 4,730   +379

    Yeah... but you have adsl and I don't :D
  8. Elros

    Elros TS Rookie Posts: 31

    Aha, I forgot about that one. ;)
    Ok, we'll need to sort out when.

    Any other possible reasons for the problems I am experiencing?
  9. Arris

    Arris TS Evangelist Topic Starter Posts: 4,730   +379

    You've checked the IRQs for any resource conflicts, or any "apparently" non conflicting IRQ sharing?
  10. Elros

    Elros TS Rookie Posts: 31

    Erm.... nope. Blimey I didn't realise that could still cause a problem these days. I remember it was always the first thing to check in the old DOS days. *sigh* those were the days. ;)
  11. Elros

    Elros TS Rookie Posts: 31

    Ok, just a note about the sound problem with Operation Flashpoint. I found somewhere (possibly google groups) that other people were having problems with OF sound. It appears that you can get round it by disabling the EAX (hardware acceleration) in the sound control-panel in windows. It is something to do with OF not having hardware support for sound. :confused:

    Still have the graphics problem. Maybe it is a driver issue, since the Cat 3.2s are better than the 3.1s, so maybe I just hang in there for the next round of Cats (whenever that might be). :(
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...