Believe External HDD corrupt, Swissknife won't format

By RealDanMan
Mar 7, 2010
  1. Hey guys,

    I ran a full format on my external hard drive (in enclosure) using Swissknife but it popped up with a not responding message half way through. Now when I run 'My Computer' it lists the F: hard drive but says it must be formatted, however its a 250GB drive and I'd like it in FAT32.

    Is there any software out there that will be able to recognise the hard drive, format it and get it back operational... I'm not bothered about keeping files on it as I was trying to format it in the first place :)

    any help would be greatly appreciated, thanks

    EDIT: heres the log from Hard Drive Test Pilot -
    Hard Drive ScanDisk Pro v2.6 Report:

    Error was found in this drive [error: Read/Write Source Data]
    Error was found in this drive [error: Read Data]
    Error was found in this drive [error: Boot Write/Read]
    No errors were found in the file(s) of this drive.
  2. RealDanMan

    RealDanMan TS Rookie Topic Starter

    ok guys, I formatted using windows to NTFS, then used swissknife to attempt to format to FAT32 again, seems to have worked... the HDD is recognisable etc.

    I'm still curious though, does anyone know if the write errors I listed above will still be there just 'hidden'

    I ask before I backup my data and find the hdd still has hidden problems xD

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...