Belkin Utility Failure

By Gouge
Jan 23, 2010
  1. I bought a Belkin F5D9630-4A Wireless G+ MIMO Modem Router/USB Network Adaptor for my pc about a year ago. I had it installed professionally and all worked brilliantly. I also have a wireles link from my laptop to the router. Also great. The network has an encryption key for security.

    A few months ago, I kept getting error notices saying that the Belkin Utility had a problem and had to close. (The connection was then managed by the Windows XP utility.)

    I now find that the utility has completely failed.

    I can still access the internet via the F5D9050-4 wireless adaptor and the Windows XP "zero config" utility, but I keep losing connection. Occasionally I have to use the repair function to find the network.

    I have tried several times to uninstall (using Revo), reboot and re-install but the utility is still not recognised. Device manager says all ok with the adaptor. I tried to download and install a driver update, but that failed as it did not find the software installed. Tried driver rool-back, still not recognised. The Belkin Utility page just shows a "!" between the pc and router and the router and Internet. No networks are listed. Ping test shows all failures.

    The laptop can still connect to the router ok, so I don't think that it is a router problem.

    Any ideas, guys?

    Running XP Home SP2.
  2. Gouge

    Gouge TS Enthusiast Topic Starter Posts: 129

    For the record, I have since discovered that the Belkin Utility is, for want of a better word, useless!!! It is only one place ahead of Belkin Support in the "Useless" division.

    I uninstalled it and now use the Windows XP utility to manage the connection. Not brilliant, but it works most of the time. I'll carry on using it until I find a better utility (preferably free).
  3. tipstir

    tipstir TS Ambassador Posts: 2,472   +126

    It's best to use WZC, third-party utilities never seem to play nice when it comes to wireless under XP. Now under 7 it's a different story.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...