By captaincranky ยท 7 replies
Jan 2, 2008
  1. Bios.....schmios.......viros........?

    I attempted to update the BIOS of my Intel DG965WHMK motherboard using Intel's executable update file. This was the run from within Windows .exe file.
    The update utility ran "correctly" inside Windows. Things were proceeding nicely when at about line 7 of the command line display, a big "failed" appeared. Now all I get on boot is the BIOS splash screen, then a blank screen with "E7" in the lower right corner.

    Intel offers 4 ways (files) to update/recover a BIOS
    So far I have tried to recover the BIOS with an .ISO file CD. (burned with Nero as an image) and a BIOS file burned to CD with the BIOS recovery jumper removed. (again as per Intel's instructions). And yes, I certainly did try removing an replacing the CMOS battery.

    I have already removed all the HDDs, and the video card (7600GT) in an attempt to stimulate the BIOS auto configuration. This should have reset the board to onboard graphicss and "configure SATA as IDE. (It did, obviously since I can see the splash screen). With the video card installed the screen display was almost pure blue.

    I seem to have access to the BIOS configuration screen now, but to no avail.
    I realize that this "update" may have trashed the EPROM. Anyway post back if you have any ideas or if you believe, (as I do), that this was fairly rude on Intel's part, a fully destructive update!
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Bios update at user risk

    I would contact their support, they may swap the chip at a reduced cost
  3. captaincranky

    captaincranky TechSpot Addict Topic Starter Posts: 12,961   +2,516

    I'll give That a Shot......


    The Computer was working fine with a Celeron D 356. However, I ordered a new "Pentium Dual Core" E2200 (Newegg calls this an Allendale). It's brand new, and Intels site stated it would only work with BIOS revision(s) 1713 and above. This BIOS revision installed was (I think), 1687 give or take. I did this update from an .exe in Windows, and it worked fine. So, in anticipation-slash-honor of the CPU's tentative arrival by UPS tomorrow, I took a leap of faith.

    PS; I don't quite remember when I had the really bad feeling about this. Was it after the 1st click or before the second click, (on the .exe).
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    When the BIOS update "failed", did you try flashing again or suchlike? Why did you reboot?

    I doubt that it was the BIOS update that killed the EEPROM chip. It was probably bad to begin with.

    If the chip is removable, then you can easily order a new one with the correct BIOS (or write your own if you love hacking). If the EEPROM is soldered, then you are going to need a pretty skilled electronics guy to replace the thing.
  5. captaincranky

    captaincranky TechSpot Addict Topic Starter Posts: 12,961   +2,516

    I Think It Outsmarted Me.........!

    I actually ignored the "failed" report, and let the box run well past the time it would have needed to complete the update. There was no activity coming from the machine, when I powered it down. I did try to "reflash/recover with the .iso and .bios files (burned to CD) from Intel's website.

    You're probably exactly correct here. The BIOS never would raise the RPM of the CPU fan, or report any change of the Northbridge Temp. Intel reported this as a "fixed" issue on a prior BIOS update which went "successfully" for me. When I say "successful", that is a euphemism for "it didn't break anything. I certainly didn't fix anything".

    After I panicked I made a couple of other really stupid, possibly fatal mistakes. However, mistakes not withstanding, it did the same thing before I made them.

    The "E7" at the corner of the screen corresponds to a BIOS port code "waiting for user input". The board does put up progress codes at that location on the screen. So, I did the obvious, tried to type and clicked the mouse. It wasn't impressed in the least. Perhaps it's waiting for a more "assertive" user input, like from the 4 pound sledgehammer I'm fondling at the moment.

    As a further irony, I pulled the hard drive cage out of this box, and sat it on the desk next to my Emachines T-5026. Then I connected the cage to the Emachines cabinet via a jumper. (For the sake of a ground). I plugged one of the drives into one of the Intel 915GAG board's SATA ports, and fired it up!
    The HDD was detected immediately, at full capacity (250GB).
    Do you see all of the contradictions in that paragraph? Like: Emachines, Intel, full capacity, and last but not least, WORKED!
  6. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    The user input that BIOSes expect is usually F1 or ESC to confirm some error message or hardware change..

    But anyway, when the flash procedure "failed", then you probably ended up with some of the BIOS code missing from the chip or the old code still being in place. Either way, the only way is to replace the EEPROM.
  7. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    you were not able to update from MSDOS?
  8. captaincranky

    captaincranky TechSpot Addict Topic Starter Posts: 12,961   +2,516

    3 Out Of 4......? (ways of restoring the BIOS)

    I attempted "recovery" with a ".bios" file burned to a CD. With an Intel board you remove a jumper and then (allegedly) you can restore via a CD or floppy. The board was essentially unmoved by this process, since the drive continued to seek without initializing. Bottom line, I had a stagnant feeling of doom about this "update", from the beginning. I was on line buying the CPU thinking hmmm....."should I buy a floppy drive, well should I"? Anyway, the 3 things I did order from Newegg are coming from NJ, which is overnight delivery for me. I never know when I'm going "crap out" on an order and have to wait for parts to come from their CA warehouse. Of course, UPS had a 4 day weekend so you see how this is going. I was wondering if this particular board was an revision too early to take this update, or as Nodsu suggested the EPROM was bad to begin with.
    In any event this was a an OEM of copy XP Media Center, and the board cost about $120.00. I tried this on New Years Eve. Doesn't everybody gamble on New Years Eve? I'm too lazy to drive to Atlantic City. Such excitement though, about $115.00 a click.
    So, do you guys have a recommendation for a board (mainstream w/ graphics) to stuff the E2200 in when it comes?
    Thanks for your responses....!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...