Bizarre: RTX 3090 stuttering / hitching at lower resolutions but fine at higher resolutions

Blobfish

Posts: 6   +0
Hi everyone, I'd really appreciate some friendly advice on a stuttering / hitching issue with my gaming rig and found this forum.
Hoping one of you will be able to give me some pointers or things to try.

So... I had 2080 and I'm fortunate (/ silly enough) to have upgraded to a 3090.

I've noticed a very odd thing happening when playing nearly all games at high (144) fps: Shadow of Tomb Raider & Forza Horizon 4 to name a couple: The amount of stuttering which was noticeable with my 2080 has actually seemed to INCREASE, while playing at the same 1440p resolution with the same visual settings.
The framerate output I have capped at 140fps on my 144hz monitor via nvidia control panel - according to my framerate monitoring tools I'm getting a steady 140fps - but this isn't reflected ingame AT ALL - in fact - its a hell of a lot smoother if I set the framerate to 60fps fixed within the ingame settings.

Now for the BIZARRE thing, If I up the resolution to 2880p, the games run say at around 50 fps fluctuating up and down (with gsync turned on) and it still looks way smoother than it does at 1440p (supposedly running at 140fps).

Got me thinking that my 2080 wasn't hitting that 140fps cap all of the time which makes me think it could be something to do with the cpu or other components becoming the bottleneck at high FPS.

It would be easy to say "well just play at higher resolutions", but that's not the answer I'm looking for. At present I'm only playing on a 1440p monitor, so I want the benefits of high fps rather than rendering out at a needlessly large resolution.
So I really want to find out whether it's a setting or a hardware issue that could be causing this?

My first suspicion was that the CPU (9900k) is bottlenecking at higher FPS, and the frame hitches from the CPU, are for some reason not being smoothed out through Gsync.
However, using Afterburner to monitor my cpu, the temps and workload look fine and are never capping out. (peaking about 60 degrees and 67% workload respectively).

Any help or ideas, or links to some appropriate page will be helpful. But everywhere I look it talks about turning settings down rather than up to improve performance :p.

Thanks!
 

Blobfish

Posts: 6   +0
  • Thread Starter Thread Starter
  • #2
Hi I have some more information. I used CPUID HWMonitor to monitor all 16 threads while playing and none of the threads exceeded 89% utilization and was still experiencing stuttering.

Does that help with the diagnosis?

Please let me know if there's any more info that I can supply which will help track down the issue.
 

Blobfish

Posts: 6   +0
  • Thread Starter Thread Starter
  • #4
Very very few have the new cards to play with. You didn't mention what brand/model of monitor are you using to display all this with?
Hi thanks for the response.
I have strong suspicion that it’s nothing related to the gpu, as the stuttering seems to occur when the gpu isn’t being pushed and is able to reach high fps. At which point I think something else must be throttling the pc.

Asus maximus hero x
9900k
32gb ram
750w psu
Asus tuf oc 3090
Asus Pg279q 144hz.
 

Kshipper

Posts: 279   +49
TechSpot Elite
Ok..I have the monitor too and G Sync /on all the way for sure. When I first got GTAV I had some stuttering issues too and I fooled around with all the graphics settings and I could not get rid of it. In a flash of perspiration (Desperation) I installed GeForce Experience and it fixed it all for me and I have never looked back. GeForce Experience just picks the right setup for my RTX 2080 rig and I am good to go. Give that a try?
 

Blobfish

Posts: 6   +0
  • Thread Starter Thread Starter
  • #6
Yep tried that. I had that installed at the beginning, unfortunately it doesn’t detect many of my games via the epic store or Xbox pc pass.

If the gpu becomes the bottleneck it’s smooth as butter. But as soon as the gpu is firing out the frames then I get random frame drops.
 

Kshipper

Posts: 279   +49
TechSpot Elite
Hmm but G Sync should only send the exact frames that are being created to the monitor? No need to set the frame rate right? I gather there is a tearing on the screen like the frames don't match what the screen is running at?
 

Blobfish

Posts: 6   +0
  • Thread Starter Thread Starter
  • #9
Hmm but G Sync should only send the exact frames that are being created to the monitor? No need to set the frame rate right? I gather there is a tearing on the screen like the frames don't match what the screen is running at?
If I set the frame rate to unlimited then It would cap out at 144 and I’d get screen tearing as the gpu is producing too many frames. Which is one reason I’ve capped it to 140fps. I understood gsync is only useful when your gpu isn’t producing enough frames rather than too many? I’ve been trying to avoid v sync because of the input lag.
 

Blobfish

Posts: 6   +0
  • Thread Starter Thread Starter
  • #12
In summary I think the problem is setting the 140 frames..set it back to 144 is the way to go so that G Synch can do its job.
Yeah basically that was my understanding of gsync. I’ve switched v sync on in the Nvidia control panel and getting far less stutter now.
Seems like this was the big issue. Doesn’t noticeabley affect input lag.

thanks for your help.