1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Booting from XP CD: Flashing Cursor

By 5aq1b · 15 replies
Oct 15, 2009
  1. I was running 2 instances of XP (Dual Boot: One for general use, and one for music production). I have installed windows 7 over the General use instance of XP and it is running perfectly fine. I have also managed to get the menu to appear upon bootup where it gives me the option to boot to windows 7 or xp. When i choose xp, it just reboots itself an appears at the menu again. I am going to try and run bootfix (maybe fixboot?) but i cant seem to boot from the xp cd. All i get is a blank screen with a flashing curosr however to let you all know, i have no hardware issues whatsoever and the Hard Drives are fine as confirmed by HD Diagnostic scans. For some reason it wont boot from cd. any help?
  2. C0u64R

    C0u64R TS Rookie Posts: 22

    It may have to be configured for the boot order in bios, do you know what type of bios you have?
    You can find out by watching the upper left hand corner of your screen immediately after you power the pc up. Usually on that same screen it will say "to access bios press (some key)"... This message will appear near the bottom of the screen. Be very careful in bios you may mess up your entire computer.

    Most bios you must press a key at the very beginning of power up in order to reach the configuration menus. Basically you want to change your boot order from booting your hard drive first to booting to your cd rom drive first, to enable you to boot from the CD.

    If you post your bios type I can look up the vendor and tell you what key to press.

    ps. Its fixboot
  3. 5aq1b

    5aq1b TS Rookie Topic Starter Posts: 63

    forgot to add that mate. I've already went into boot priority options and selected Boot from CD as 1st priority and Hard drive as second priority. 3rd and 4th are disabled. I even disabled Hard drive as well leaving only the CD rom there but still no luck
  4. C0u64R

    C0u64R TS Rookie Posts: 22

    I have 3 wild guesses that need more information to tell what it could be.

    Have you recently opened up your case for any reason?

    Do you hear any beeps when you turn your system on? if so, how many and fast or slow?

    In your bios do you have it set to halt on all errors?
  5. 5aq1b

    5aq1b TS Rookie Topic Starter Posts: 63

    I've opened it to install an IDE to SATA converter for my DVD writer as it was having trouble writing CD/DVDs in Windows 7 but since then i've been able to watch and write DVD's and isntall programs from the Drive without any problem.
    Not sure if i hear any beeps, ill find that out when i Reboot next but i dont think I have it set to halt, i dont think I have that option to be honest.

    My mobo is an Asus m2n-e
  6. C0u64R

    C0u64R TS Rookie Posts: 22

    Ironically that is also my mobo model. Ha okay well let’s start with the basics, your sure you plugged the converter in firmly? Make sure that all the cables going to and from the drive are firmly plugged in.

    Put everything back together and turn it on but make sure to listen for beeps. A good boot will have 1 short beep verifying it has passed post. There are many types of beeps which indicate various errors so if you hear more than one, be sure to write it down.

    It may be deep in the bios settings where that configuration for halt on all errors property lives. Try poking around a bit but don’t save any changes.
  7. 5aq1b

    5aq1b TS Rookie Topic Starter Posts: 63

    Ok i'm just about to reboot....
  8. 5aq1b

    5aq1b TS Rookie Topic Starter Posts: 63

    I found the option in the BIOS and it's set to Halt on ALL ERRORS. Strangely though, i get no beeps at all.
  9. C0u64R

    C0u64R TS Rookie Posts: 22

    That’s a very odd phenomena you have going on there. Usually if a pc does not beep it will not turn unless your beep was turned off in bios for whatever reason.

    Do you know what brand your IDE to SATA converter is? Also need to know the brand of your DVD burner that the converter is connected to.

    I’m thinking this may have to do with that. We can test the theory by disconnecting your converter and plugging it in directly to the cd rom drive. If you are able to get the cd to boot then it is your converter. There may be a hardware conflict or the converter itself does not have the ability to run at boot level.

    ps. im getting off work now ill check back as soon as possible.
  10. 5aq1b

    5aq1b TS Rookie Topic Starter Posts: 63

    i think the beeps may be disalbed as "quick boot" is enabled. I'll also try disconnecting the converter and keep you posted. Thanks for the help...
  11. Savage1701

    Savage1701 TS Enthusiast Posts: 153

    This is a wild guess, and crosses over into SSD territory, but XP aligns on an offset of 63 whereas Win7 & Vista default to either 1024 or 2048 to align flash blocks to pages correctly (I think I have that sort of right). I think they align that way even if you have a mechanical drive installed since it prepares the OS for the future and is also actually really good for mechanical drives as well, but has never been stressed as important except in server-type circles. Believe me, you can tell a 64 alignment vs. 63 with even a SATA 1 laptop drive. LBA settings can be a culprit here as wll. I have had huge issues trying to get an SSD to align at 64, 512, 1024 or 2048 offests. This can be LBA setting and board-type dependent (My supermicro board has no issues in IDE Enhanced mode. My Asus ones are a pain with anything other than ICH RAID drivers). I have heard some success stories also with completely cold CMOS clears, removing any boot device, and turning off all onboard controllers except what you need for a hard drive and optical install drive when doing your initial install. That did not help me, however.

    Long story short - you can get that blank flashing cursor or "error loading operating system" because XP SHOULD, but is NOT, starting at the correct offset.

    I don't know how setting a partition as active or not applies in dual-boot scenarios.

    Also, Vista and Win7 align with Diskpart, and Diskpart rounds its offsets. You MUST align XP partitions with Diskpar only (part of the Server 2003 utilities and you can still find it to download pretty easily). I don't think there is any reason you can't align Win7 or Vista with Diskpar, it's just a little less polished than Diskpart. You can align by just hooking your system drive up to even a USB port with a SATA-USB adapter. I've prepped SSD's that way on a test bed and then installed them into the desktop CPU and got XP to boot on it just fine. If you prep your drive, it's probably best to align them in IDE compatible mode, make sure they are set active, etc.

    That's just a thought and FWIW.

    Unfortunately, I've not heard of any reliable way to "nudge" XP from, say, 63 to 64 offsets. You can check the OCZ Second Gen SSD forums if you want to try. Some claim Acronis will if you use a 2-part move or special type of copy. I have no idea how that would fold into your situation with multiple partitions. Some have also tried taking away all the space up to exactly the number needed for a 64 offset in XP, but others claim that may be specious. I think you can check with msinfo.exe to see where the starting offset is. There is a simple formula that you divide the block or whatever by, and if you get 64, 512,1024,2048 or such you are fine.

    Hope that helps. I suspect Win7 changed your starting offset and XP and/or the motherboard is not responding correctly.
  12. 5aq1b

    5aq1b TS Rookie Topic Starter Posts: 63

    Hey, i took the converter off and hey presto, i can now boot from CD and get into the Recovery Console. Now......

    Here is how my HD is partitioned when looking at it from My Computer in Windows 7:

    Hard Drive Partitioned into:
    C: Windows 7 OS
    D: Windows 7 Installs
    E: Windows XP Installs
    F: Windows XP OS

    When i boot into Recovery console, i am presented with 2 options:

    1: C:\windows
    2: K:\windows

    I selecte dnumber 2, tried fixboot F: and pressed Y and return. It said new MBR created but no luck.

    I cant get into option 1 as it asks for admin password and for some reason, its not accepting it. I only have one account and i also tried pressing enter (blank) but no luck.

    How do i run the fixboot command on the XP install?
  13. superty12

    superty12 TS Enthusiast Posts: 413


    Wait. It might take a while. If it boots into 7, change BIOS settings. Post if you need help getting into BIOS, if it boots into 7.
  14. 5aq1b

    5aq1b TS Rookie Topic Starter Posts: 63

    I used the MAP command to identify which drive i want to run the fixboot command on and it's the K drive. I ran the command HOWEVER this hasnt fixed the issue as it still reboots everytime i choose the XP partition. PLEASE HELP
  15. 5aq1b

    5aq1b TS Rookie Topic Starter Posts: 63

    can someone help please?
  16. C0u64R

    C0u64R TS Rookie Posts: 22

    sorry for the delay

    Sorry for the slow reply friend I have been very sick lately. Glad to hear you got the CD bootable! That's a good first step. Now your question currently is
    My belief is that your K partition in the recovery console is your XP drive and the C would be your windows 7 secure partition. So now I guess I need to find out if you have XP pro or XP home, and What disk your running windows recovery console from? the command your looking for is going to be "BOOTCFG /Rebuild" hopefully that would fix the issue.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...