Borked Hard Drive - won't format

By tehrootbeerman ยท 14 replies
Jan 21, 2009
  1. I have a little 40GB portable HD (2.5" laptop one) that's been with me for about 3 years. It's gone through a bit of wear and tear since I use it to share (totally legal) files with my friends. Basically my throw around drive.

    It's been through about 2 months of inactivity and I used it yesterday to transfer some photos. It finished copying fine but failed to safely remove. This has happened previously.
    I normally shut down the computer and then take out the drive.

    It didn't work this time. The computer (Vista) stayed on the "shutting down" screen while my hard drive suddenly began read/write operations again (judging by the little light on it). I didn't want to just yank it out so I left it there over night. In the morning it still wouldn't shut down so I eventually just yanked it out.

    As I suspected it would, the drive borked. It appears on my computer as Local Drive (G:) with a size of 0kb. Whenever it's plugged in it starts to do read/write operations again but safely removes as normal (but keeps doing read/write operations). I cannot format using Windows.

    Can anyone suggest a fix? I don't need the data, just the drive to be functional again.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    You should try removing the Partition
    There are a number of ways to do this

    ComputerManagement in Windows
    Windows Setup CD from bootup
    Gparted Live (free) BootCD

    I use a nifty little program call Delpart
    I've used it many times for stubborn partitions removal from a bootable floppy or CD
    Here's some info on it:

    Obviously once the Partition is removed, you will need to re-partition it (for that size drive, I'd go Fat32 as the format)
  3. tehrootbeerman

    tehrootbeerman TS Rookie Topic Starter

    RE: Kimsland

    Thanks for your advice.

    I tried using delparted but if failed to detect _any_ hard drives.
    The windows partition manager and the windows setup CD applet could not detect the broken drive.

    The drive appears on my 32bit installation of XP as G: but does not appear under 64bit XP or Vista.
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    I would mount it as the only drive in the computer that actually sees it (this may be same computer)
    Then run the bootable Delpart disk again (or any other CD ie Windows Setup disc or Gparted disc)
  5. tehrootbeerman

    tehrootbeerman TS Rookie Topic Starter

    Sorry for the delay in replying - I've been quite busy.
    The portable drive itself is a 2.5" laptop hard drive.
    I'll borrow my brother's laptop to do this but no guarantees on when that's gonna get here.
    I don't want to take apart my own laptop as it's still under warranty.

    Currently, none of my computers can detect the partition anymore.
    It _was_ a 0kb partition in RAW format.
    Any further help would be appreciated but I'm probably just going to buy a replacement as they're not expensive anymore. (I can pick up an 80GB WD drive for about 25USD).
  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Well you can purchase an adapter to plug it in as the Main drive on a Desktop computer, or just use the other laptop

    Also, does this laptop Harddrive have any jumpers on the end of the drive?
    If so, have you tried putting it in CS or Master configuration
  7. tehrootbeerman

    tehrootbeerman TS Rookie Topic Starter

    There are jumper pins but no jumper on them.
    According to the sticker on the drive, its current configuration leaves it as device0.
    Alternative configurations are device1 and cable select.

    I'll find a jumper and try this out (I've got a spare one... somewhere... :\).
    Thanks for your help.

    One more thing, my flash drive and two other hard drives show up on POST but this drive doesn't.
    I'm not sure whether it has done this in the past.
  8. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Dang! It's the jumper. I should have mentioned it earlier :/
  9. tehrootbeerman

    tehrootbeerman TS Rookie Topic Starter

    This drive has _never_ had a jumper in.
    What does changing the jumper do exactly?
  10. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    I'm not answering.
    Until you try booting with CS
    Then try booting with M

    Cable Select

    Waiting... (I understand this may take 5mins or a day to reply back)
  11. tehrootbeerman

    tehrootbeerman TS Rookie Topic Starter

    Friends rule.
    I managed to get a laptop.
    I pulled out its hard drive and replaced it with my portable one.
    I put in the xp install CD.
    It took a while (10-15min) to examine the drive and then it managed to find a partition on it that was marked "-: Partition1 [Unknown] 38154MB (38154MB free)"
    I tried to delete the partition but it could not.
    "The partition you selected cannot be deleted"
    "Setup cannot access this disk"
    "windows has been shut down to prevent damage etc"
    As soon as I find a CD I'll try with Delpart.
  12. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    If Delpart can't do it (and it should) Oh by the way, on my boot CD with Delpart. I installed a mouse driver too, you can download lots of free bootdisks from

    Anyway, if that doesn't work, Gparted live (free) BootCD, will
  13. tehrootbeerman

    tehrootbeerman TS Rookie Topic Starter

    Okay, partition has been deleted under gparted.
    Should I create a new partition as primary partition or extended partition?
  14. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    If you are going to Setup Windows on this drive, then do not create any Partition manually
    ie If you have already done it, remove it again

    Windows Setup will do this automatically
  15. tehrootbeerman

    tehrootbeerman TS Rookie Topic Starter

    Thanks for all your help.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...