Can share internet but can't share files

Status
Not open for further replies.
Hi, I have a simple network at home that consists of 2 PCs connected via a crossover cable. They are both running Windows XP Pro. I ran the network wizard on both machines and can share the internet connection fine. However neither computer can share files with the other or share the printer.

When I set folders to “share this folder on the network” the folder is not visible on the other computer. Both computers have IP addresses set, however neither computer is able to ping the other.

When Computer.A (host of the internet connection) goes to Start -> My Network Places -> ‘view workgroup computers’ all that shows up in the list is Computer.A.

However if I try to go to ‘view workgroup computers’ on Computer.B I get the following error message:

“Mshome is not accessible. You might not have permission to use this network resource. Contact the administrator etc.
The list of servers for this workgroup is not currently available”

I have searched the forums and found various steps that I have tried, but I still am not able to get this to work. Any help would be greatly appreciated!
 

SOcRatEs

Posts: 912   +1
Hello! Welcome to TechSpot!

The quickest fix is a router/hub rather than peer to peer cable.
Do you have file and print sharing turned on?
Try setting up network wizard to something other than "MSHOME"
You might have only internet sharing turned on.
Did you create the files for network or just "finish network setup",
in the wizard?

This has helped me by setting guest password.
spike said:
Protect your guest account - The guest account can be used by hackers and/or malware to gain greater access to your machine, even when turned off. The guest account can't be removed. However, you can disable it, but this can affect the functionality of your computer. Instead, what you can do, and what you probably should do, is put a strong password on it, and then leave it safely turned off. You do this by opening a command window (start -> run -> type "cmd" and press enter). at the command prompt, type net user guest <password> (where <password> is your chosen password, being something you can remember). After hitting the enter key, the guest account will be password protected. If your machine is networked and authenticating as guest, then you'll need this password to access network shares - if you tell it to remeber the password, it will only ask the once.
G'Luck
 

kirock

Posts: 1,212   +1
Socrates I got this.

Greeny: 1) Turn off Firewall on Comp2 !!!!!
2) Ensure TCP/IP on comp2 is set to "obtain IP automatically".
3) Ensure BOTH comps are same work group! As in "mshome"
4) the 2nd NIC card in comp1 (i.e. the local area net) must be set to IP address: 192.168.0.1, subnet mask 255.255.255.0

If you ran the Home Network wizard on both computers it should do all this for you! BUT......the stupid thing leaves the firewall on computer2! Thus disabling comp1 from see it! :hotouch:

I know I have ICS running at home now and had same prob.

Cheers. :grinthumb
 
  • Thread Starter Thread Starter
  • #4
Thanks for the suggestions, I have tried them though, and it still doesn't work. :(

I completely uninstalled my firewall on Computer B and I still get the exact same problem. Both computers have been set to the same work group but they don't seem to see each other. Computer B is unable to even view the list of computers on the work group.

Does anyone know of anything else that might be causing this problem? :dead:
 

kirock

Posts: 1,212   +1
One other thing I forgot I did was set the printer and folders manually to share. Right click on each item and set it in properties.
 

jobeard

Posts: 13,983   +1,782
wirewalls are GOOD, disabling is BAD!

To allow print/file shaing on windows, enable the following ports ONLY on your LAN ip address:
135-139,445
even a Mac and Linux will be able to participate in the Shares.

Using the default Windows Firewall, under the Exception Tab,
just click the File & Print Sharing square. If you have broadband and a router,
then DISABLE these same ports(in the router) to protect you from Internet worms et al.
 
I had a similar problem. Worked on it for two weeks. Was tearing my hair out. Finally fixed it. I'm not a computer whiz but this is what seems to have done the trick.

I had the computer without the router setting wrong ...
only one computer can have server setting enabled
on the computer without the router go to network places
view network connections
right click on the various connections go to advanced tab and make sure the computer/s without the router don't have
"allow other network users to connect throught this computer's internet connection" checked


Then I reset tcp/ip stack and winsock with the following command (go to start, run then enter the command). I did this on the computer with the router but I don't see why it would hurt anything to do it on the other computer/s if it doesn't fix the problem.


run command to enter for the winsock:
netsh winsock reset


run command to enter for the tcp stack:
netsh int ip reset c:\resetlog.txt


Now I can see each computer in the workgroup and share files and printers between them. Got all those error messages .... network path not found ... may not have permission etc. This fixed it all. Hopefully it will work as well for others.

I'm assuming that everyone else would have the basics done ... workgroup name the same and have shared some files on each computer as I had.
 

jobeard

Posts: 13,983   +1,782
ladyamom said:
view network connections
right click on the various connections go to advanced tab
make sure the computer/s without the router don't have
"allow other network users to connect throught this computer's internet connection" checked
VERY GOOD! That's used only for ICS.
Thanks for the feedback too :)
 
Status
Not open for further replies.