Cannot boot WinXP without bootdisk

By dementedmoose ยท 10 replies
Nov 6, 2005
  1. I have a problem with Windows XP. A few days ago, whenever I tried to use my PC it doesn't go as far as the Windows XP loading logo. I can go to the BIOS and everything but at the part when it's supposed to show the Windows loading logo, it only shows up as a blank screen.

    So what I did was put in my bootdisk and it loaded properly. Windows XP works fine but when I take the bootdisk out and restart, I get the same problem. What do you think causes this? I was thinking it has something to do with some boot configurations or something like that.

    Any help would be appreciated. Thanks. :)
  2. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Could be boot order

    you may have upset the boot order in the bios. Check that it has hard disk at the top of the list.

    At the moment the symptom you describe (starts with CD only) tends to show the boot order starts with CD. Without a CD in, it should however then boot from the next in the list, which would be HDD, but may not be, hence your problem.

    I assume you know how to get into the bios (typically at boot time delete key, F2, escape etc - usuually it tells you briefly at startup).

    The look for a page or section in the bios that talks about 'boot order'. Change the sequence as described to HD - CD - floppy or similar. Dont touch anything else in the bios if you dont know what its for!.
  3. dementedmoose

    dementedmoose TS Rookie Topic Starter

    Thanks for the reply gbhall :)

    I dont think the boot setting under BIOS is the problem. I set it up so that it will check the floppy first, then cd, then harddisk drive. If there are no media in the floppy/cd drives, it will not boot from the harddisk. Right after CMOS (I think that's the term regarding the process the computer does to check keyboard, monitor, etc during startup), it will just end up in a blank screen and not show the Windows logo and the loading status. But when I put in the boot diskette, it will be able to load Windows from the harddisk. Im thinking it has something to do with the boot configuration under windows (or the system.ini or something, just taking a big guess) or the MBR. Im not sure how I can edit the MBR but I don't want to edit it without making sure that that is my problem.
  4. Centurio

    Centurio TS Rookie Posts: 25

    Have you carried out any hardware changes at all in your system lately? Or changed any HDD jumper settings?

    I used to have the same problem a while ago. With me, it was an out-of-spec HDD data cable.

    Regards, Martin A
  5. kirock

    kirock TS Rookie Posts: 1,221

    The easiest way is to boot into Safe mode (usually F8 or F12) and select Last Known Good Configuration. If this doesn't work it's probably a corrupted MBR and yuo'll have to boot using your XP cd and enter the recovery Console at the command promyt type FIXBOOT.
  6. dementedmoose

    dementedmoose TS Rookie Topic Starter

    hey thanks for the reply Centurio! :)

    I dont recall adding or changing any hardwares before I encountered the problem.

    OK, here's what I did:

    * I have a 200Gb SATA hdd and nother 200Gb hdd that is not SATA... IDE drive i think it's called :p not sure now

    * I took out all of my cd drives and hdd and put in a spare hdd (the IDE one) that I have used on the same pc. It loaded perfectly. So I figured there must be something wrong with the boot configurations with the SATA hdd. And thought I should back up my data in case anything happens.

    * I got the IDE hdd as my master and from there I tried copying my files from the SATA drive to the other.

    * BUT, during the process it stopped. I cant remember now if it froze or if it restarted because I wasnt paying attention as it is going to take a while so I just left it doing it's thing.

    * Without changing anything, having the IDE as my boot drive, I got an error message booting from the IDE drive saying that there's something wrong and I have to press Ctrl+Alt+Del. I remember it even said "Ctrl+Alt+ el"... not showing the letter D. And another time with the same message but a different letter is not shwoing.

    * I even tried re-installing XP on the IDE drive, because it doesnt have any files anyway so I wont mind reformatting it and stuff but it hangs during the setup so I just skipped doing that.

    * Put back my SATA drive and checked if it will work but nope.

    * Tried to use a boot disk and it temporarily solved my problem. But I want to get rid of it and have everything back to normal.

    I know I have fan problems... my pc rebooted a few times because of it. So I open up my case and aim a fan straight to it (i got no aircondition :() and I dont get no problems. Maybe because of this "reboots" that happened caused the boot configuration to be corrupt or something? Cos I know if you dont shut down windows, you'll end up having boot problems. Maybe that's the reason. I also noticed that I have a lot of minidumps dated from June of this year and have like 5 - 7 of them each month since June. If I would be able to upload it I will. I read the "before you post minidumps read this" thread but I didn't really want to do all the guidelines. :p

    But I will try and check all my connections and see if that will make any difference. Come to think of it... it happened after I moved my pc from one corner of the room to another.
  7. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Fault on Sata drive

    The one thing that fits all your symptoms (as far as I can tell) is your SATA drive is faulty. Could be a power problem, or cable problem. Can you try the Sata drive on another power connector, with nothing else drawing power. Try it in another PC. Also Sata drives are rumoured to be iffy at times. Try search on this site for 'sata drive problem' and see what comes up. Lo! 500+ entries - you're not alone !
  8. Centurio

    Centurio TS Rookie Posts: 25

    I'm inclined to agree with gbhall on this one. Your predicament indeed smacks of a hardware problem. Missing letters in a screen display is something that just shouldn't happen. I don't have any direct experience with SATA disks, though, so I'm passing here.

    Another idea: could it be that your power supply is a bit weak? Or: you wrote you had probs with high system temps before. Might be that something gave when you tried to copy the content of an entire harddisk at once. System temps tend to go way up then.

    Just in case you'll want to try something else before you get the sledgehammer, look here. Maybe you'll find something you haven't tried yet. (It's a link to my first post on my own problem, and a shameless plug to boot.)

    Hope you succeed.

    Regards, Martin A
  9. dementedmoose

    dementedmoose TS Rookie Topic Starter

    Thanks for the reply kirock! :)

    Usually if there's a problem with the configuration it will automatically go to a screen where I can choose to start in Safe Mode and stuff, right? Since I was able to boot normally (with the help of the boot disk) then it never really came to mind. Will give it a go and see if it works. With the recovery though, I wanted to do it as a last resort because I would need to download the drivers for my SATA drive. I need to press F6 during the setup and I can't seem to find my drivers! :(

    I checked all cables. Everything seems ok. I cant remember my PSU wattage right now. It came with the case. At the time I built my pc, I was told I needed a higher PSU. But since it came with the case, I wasn't able to change it.
    If the SATA drive is faulty, why am I still able to use it then? I dont know anybody else where I can test my SATA drive. But I can still use the drive and it seems to work fine. I'll keep an open mind though, but knowing that there are 500+ people having problems with it doesn't make me feel any better. :p Also, I just dont want to try to fix something that doesn't seem to be broken.
    But the weird thing is, I was able to use it for more than a year using the same PSU and cables with no problem. I just experienced it recently for unkown reasons.

    The missing letters happened with the IDE drive though. It has 2 partitions, when I checked it the first partition has been wiped out!! Haha. It makes sense now why I got that message with the missing letters. That's because when it restarted in the middle of copying files on it, it probably messed up the first partition. It doesnt worry me much. But Im glad it did not happen to the SATA drive.
    Im thinking it's a cooling problem. But that would be easy to fix. When I notice an increase in temp, I just blow a fan right on it. Im more concerned on how to fix the boot disk problem... it's really annoying everytime I hear the noise the disk drive makes when reading the diskette. :D
    I checked your previous post. Thanks for that. But I did not get any "DISK BOOT FAILURE INSERT SYSTEM DISK AND PRESS ENTER." error messages. I just get a black screen with nothing. So yeah... Im pretty sure I just need to do that system recovery thing. Im just too lazy to download my SATA drivers. I guess I dont have any other options. Will try to do that and then let you know what happens. :)

    Thanks guys for the help! I appreciate it. After I fix it, I'll post up some minidumps. Maybe it shows in there what caused my problem. Cheers!
  10. patio

    patio TS Guru Posts: 482

    You need to get that fan issue resolved as soon as possible...otherwise you will continue to experience problems.
    You also run the risk of frying that CPU/and or MBoard.
    Which fan is bad ? ?

    patio. :cool:
  11. icantwinn

    icantwinn TS Rookie Posts: 26

    i had the same problem on my older pc all i had to do was open the case and tap on the hdd, and it worked fine. it was just stuck from when i moved the pc from anoother room into my pc room.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...