1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Cannot connect PC to network or internet

By mrtraver ยท 8 replies
Oct 23, 2013
Post New Reply
  1. I am stuck! Also I apologize in advance if this is not in the right forum.

    I am trying to work on a friend's Windows 7 desktop PC (Dell Inspiron) at my house, but I cannot connect to my home network or the internet to download malware scanners/removal tools, updates to MBAM, etc. First I was trying with a wireless adapter that it known to be good. The network sharing center would say it was connected to the network, but there was no internet connection. Then I tried plugging in an Ethernet cable. The network sharing center just kept saying "searching for network" but never would connect. I tried disabling then re-enabling the network adaptor, and I reinstalled the driver.

    Networking is not my strong suit, so is there some setting I may be overlooking?

    It appears the PC on which I am working is already part of a homegroup; do I need to leave that group then try to join my existing one set up through my own Win& PC? I don't care about sharing files across the network (in fact I prefer not to in case this thing really is infected); I just want internet access on this machine.

    Could some sort of malware be blocking access? I sort of doubt this since it was working fine at their home before they brought it to me.

    I could not find any router settings or firewall entries that appeared to be blocking access (ZyXEL PK5001Z DSL modem/router provided by CenturyLink). Do I need to call my ISP tomorrow?

    Thanks again; this community has always been helpful to me!
  2. St1ckM4n

    St1ckM4n TS Evangelist Posts: 2,887   +626

    Make sure the adaptor isn't set to 'share connection'.

    Try using a static IP.
  3. mrtraver

    mrtraver TS Evangelist Topic Starter Posts: 404   +110

    Thanks! Static IP didn't work, and the onboard Ethernet adapter is not set to share connection. I tried flushing the DNS cache, and I reset TCP/IP per http://support.microsoft.com/kb/299357. But the network and sharing center still just shows it as "identifying" when I plug in the Ethernet cable. the cable itself is fine; I am using the same on to connect he PC on which I am typing this.
  4. St1ckM4n

    St1ckM4n TS Evangelist Posts: 2,887   +626

    If it's identifying, this usually means it has the self-assigned IP of 169.254.xxx
  5. Mandiux

    Mandiux TS Rookie

    Have you tried the following on command prompt?


    can you see the default gateway? while using ipconfig?
  6. mrtraver

    mrtraver TS Evangelist Topic Starter Posts: 404   +110

    Thanks, I tried both of those commands. I cannot see the default gateway; it is blank.

    When I ran one of the network troubleshooters, I got this message: "Either the Peer Name Resolution Protocol service (PNRPsvc) or the Peer Networking Identity Manager service (p2pimsvc) is not running. The Peer Networking Grouping service (p2psvc) depends on both these services in order to function properly." Windows could not repair it automatically. I'm googling that message now; if I find a fix I'll post here.
  7. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +244

    Have you check in administrative tools to make sure these services were enabled? If not go into services in administrative tools and enable these services. This may very well get you up and running. They can be set at manual or auto. Hope this helps you out.
  8. mrtraver

    mrtraver TS Evangelist Topic Starter Posts: 404   +110

    I win!! here is how I fixed it: As suggested at http://www.sevenforums.com/network-sharing/29060-can-t-start-peer-name-resolution-protocol.html I deleted "C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking\idstore.sst". (the service was already stopped so I did not have to stop it manually). It still did not work after a restart, so I ran sfc /scannow from an elevated command prompt. Restarted, and voila! Internet access!!

    EDIT: I just saw the response above. I was not able to manually start the PNRPsvc using task manager or the admin tools. But thank you for the suggestion!
    St1ckM4n likes this.
  9. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +244

    Cool glad you got it up and running. Thanks for replying back and letting us no your fix.(y)

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...