Cannot Delete: Access Denied

By res0hncx ยท 34 replies
Sep 10, 2003
  1. I uninstalled Ultima Online and it left all these files on my computer that I can't delete because it says Access Denied. I can't copy/cut/delete/rename/or remove their read-only attributes. I have UO installed in a different directory now, but I can't play it because the client I use to join the free server I play want to use the old directory to launch the game. :( Please help
  2. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Try restarting the computer, they are probably still in use for some reason. If you can't delete them after you restart then post back and we'll give another solution.
  3. res0hncx

    res0hncx TS Rookie Topic Starter

    still can't delete... I'm thinkin Im gunna get the disk ack from my friend though so it all ok.
  4. ---agissi---

    ---agissi--- TechSpot Paladin Posts: 1,978   +15

    You could always boot into Safemode to delete the files. Just press F8 at the windows XP bootup screen.
  5. res0hncx

    res0hncx TS Rookie Topic Starter

    ah good idea! I reinstalled it but it wouldnt even let me reinstall it in the same directory because of those files. I'll try safe-mode, but how do i get out of safemode when I'm done?
  6. StormBringer

    StormBringer TS Maniac Posts: 2,244

    Just reboot, it should restart in normal mode.

    If deleting in safe mode doesn't work, you might wan tto try something like Norton's Wipe Info or a similar utility. I've had problems with files not letting me delete them but Wipe info seems to not care and will delete them anyway.
  7. Nic

    Nic TechSpot Paladin Posts: 1,549

    Sometimes the files can't be deleted because they don't actually exist, and are simply showing up due to having entries in the FAT saying they exist when they don't. You should be able to delete those entries (files) from the winxp recovery console when you boot from the winxp CD.
  8. res0hncx

    res0hncx TS Rookie Topic Starter

    I tried safe mode and it still wouldn't delete :(

    here is what the error message says
    The disk is HALF full and it's not in use.

    What is Norton Wipe Info and where can I get it?
  9. filthy_mcnasty

    filthy_mcnasty TS Rookie Posts: 78

    maybe they are actually in use (although if it wont work in safe mode then that's odd)?


    click on the startup tab and untick anything that looks like it's related to your game or those files, then reboot and try deleting.

    otherwise something's messed.
  10. Nic

    Nic TechSpot Paladin Posts: 1,549

    Read my post, it'll work:=).
  11. res0hncx

    res0hncx TS Rookie Topic Starter

    filthy_mcnasty: I have checked already and I know it is not running

    Nic: thanks for the idea, but I dont have my xp CD right now :(
  12. Nic

    Nic TechSpot Paladin Posts: 1,549

    Use this boot floppy to delete your files ...

    NTFS File Recovery Floppy Creator

    Edit: I'm not sure if you can delete files from that floppy, but its worth a go.
  13. res0hncx

    res0hncx TS Rookie Topic Starter

    well I have no A drive on the computer with the undeletable files...can I put the disk in my other computer and delete the files over a network? also how does this program work? where can i delete files?
  14. dunxd

    dunxd TS Rookie

    Try holding down the shift key while you delete - this bypasses the Recycle Bin, and in my experience allows you to delete files that otherwise give you an Access Denied message.

    This works for deleting using the Delete key on your keyboard, and also while doing a right click > delete.
  15. res0hncx

    res0hncx TS Rookie Topic Starter

    nope doesnt work :*(
  16. RipsaW

    RipsaW TS Rookie

    getting same problem, any ideas?

    tired all the above suggestions no luck.
  17. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Open command prompt, run "openfiles". This lists all open files on your computer and what process is having them open.
  18. RipsaW

    RipsaW TS Rookie

    openfiles flashed up for a second then closed, didnt have time to read it.

    I just found this thread:

    I get to the following steps:

    I am running xp sp1 same as he is, but there is no security tab or owner tab. :/
  19. RipsaW

    RipsaW TS Rookie

    sorted it now, read it too fast didn't see you only get the security tab in safe mode :)
  20. Charles Hammond

    Charles Hammond TS Rookie Posts: 59

    Change the directory names.
  21. Jameson653

    Jameson653 TS Rookie Posts: 23

    Sorry, Run->Msconfig doesn't work on Windows 2K or XP, they just don't have them, trust me I tried
  22. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6


    I guess I have been sold a Windows 98 disguised as XP since Run->msconfig sure works for me!
  23. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    2k does not have it, but you can toss it on. XP I assure you has it, both Home and Pro versions.
  24. PanicX

    PanicX TechSpot Ambassador Posts: 669

    I've come across this same issue several times, and this is my workaround.

    Open a command prompt : Start -> Run -> cmd [enter]

    navigate to the directory with the file you want to remove

    Open Task Manager : [right click] Taskbar -> Task Manager

    On the processes tab, select Explorer.exe, click end process

    Click OK

    In the command prompt, delete the files:
    del *.*
    rd [directory]

    Back to Task Manger, Click File -> New Task

    and you're done.
  25. Hodsocks

    Hodsocks TS Guru Posts: 382

    As daft as it may sound I have been able to delete such files by just renaming them, but I have to admit it doesn't always work.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...