Cannot hear dialogue in videos WMP or VLC?

By Legoflamb ยท 7 replies
Feb 6, 2011
Post New Reply
  1. Ok my dad has started getting a weird problem with videos on his computer ever since he downloaded an mkv of a well known recent release.

    He cannot hear dialogue, only background sounds and music.

    It makes no difference whether he's in windows media player or VLC and we have tried messing about with the audio properties and making sure it wasn't set to 5.1 etc (he only has stereo desktop speakers)

    It doesn't do it with streaming stuff online.

    He has a soundblaster and onboard realtek 97 sound and they both do the same thing.

    He's reinstalled VLC and updated drivers and we just cannot figure it out....

    it's win xp by the way.....

    Any ideas what this could be?
  2. gbhall

    gbhall TechSpot Chancellor Posts: 2,419   +77

    Possibly, there has been an 'unauthorised' change to the file associations for sound.

    open control panel and double-click folder options. There is a tab 'file types'. On there,check what is the application currently opening with all the various sound files and things such as movies.

    If this was caused by 'an mkv of a well-known release' then that is suspect. It could change the associations, or worse, could contain or install malware. Advise a thourough malware scan ASAP.
  3. mike1959

    mike1959 TS Evangelist Posts: 1,020   +55

    Did you mean only the 'recent download' is faulty in it's sound track, or now, all your sound has been changed on every windows program?
    If it's just the file you downloaded that has the faulty sound, then it is encoded like that, (ie it's faulty), and there's nothing you can do with it to 'fix' it.
  4. Legoflamb

    Legoflamb TS Booster Topic Starter Posts: 150

    Hey thanks for the replies - it was the same for all movies in any player and it seemed to coincide with viewing this film.

    He's sorted it now in a roundabout way. He turned off the left channel or something random that should make it sound terrible and it's all back to normal.......
  5. shailx4

    shailx4 TS Rookie

    I had the Same Problem..... with my VLC player.... what I did was, went to the VLC menubar
    Audio > Audio Device > it was set to 5.1 I corrected it to stereo... (as mine has stereo speakers I.e 2.0 )....
    and now it sOunds perFect... he he... :D
  6. learninmypc

    learninmypc TS Evangelist Posts: 8,122   +526

    I was curious so I followed your Audio > Audio Device >but no fly out??
  7. shailx4

    shailx4 TS Rookie

    according to me two things are quick cure for the mentioned problem......

    1st the thing I mentioned, about vlc.
    2nd the one mentioned in the question itself.......I.e.

    right-click on your volume icon in your sidebar.....
    go to Adjust audio properties...
    a window should open... above the 'Apply' / 'Cancel' buttons, you can see two 'Advanced ' buttons....

    1. from up click the 1st 'Advance' button it should open a window 'Playback Controls'...
    in that go to Options > Properties.... click on the radio button tht says 'Playback'...
    select all the checkboxes > set every volume button to high except microphone (set it to mute) > click 'OK'...

    2. click on the 2nd Advanced button check your 'Speaker setup' is set as per your PC speaker system for example: mine are stereo speakers, so I must set it to 'Desktop Stereo Speakers'....
    You can also go to the 'performance' tab and check if both the the volumes are set to high....

    3. click the 'Speaker Volume' button and check if both the the volumes are set to 'high'....

    I think this must solve the problem.....

    if still a problem persists, reinstall your sound drivers..... if still a problem persists, check your speakers..... ;)
  8. atik nadaf

    atik nadaf TS Rookie

    Hey bro I had the same problem .
    first of all I reset vlc media player settings by (ctrl+p)>reset.
    then in ur speaker controlls go to enhancment option and disable it .
    (right click on speaker icon and select playback devices>double click on speaker>u will get speaker properties>enhancment>disable all sound effect)
    hope this will help you

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...