1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Cannot initialize disk in disk manager

By abazaba ยท 9 replies
Mar 25, 2010
  1. I am currently trying to recover videos off of a JVC camcorder that died. It had a 30gb Hitachi 1.8" HDD, so I ordered an enclosure for it and set it up. When I plug it in, it makes the windows new hardware found noise and pops up in the bottom recognizing it as a mass storage device. The light on the enclosure comes on and I can hear/feel the hard drive spinning. It is visible in device manager, but not in my computer. In disk management it shows up as "Disk 1 Unknown Not Initialized" and when I right click it and hit initialize I get an error simply stating "The device is not ready" I also tried running testdisk on it, but testdisk does not even see it. All forums I have seen thus far say the only way around this is to re format it, but I'm really hoping someone has a better answer because I really want those videos! Thanks in advance.
  2. tipstir

    tipstir TS Ambassador Posts: 2,842   +193

    Tough one, but why don't you see if you can find used JVC model online that still works and transfer the data. JVC must be using some other sort of format that Windows can't detect. If you had XP or 98 SE box you could try to see if the setup you have can see the media.
  3. abazaba

    abazaba TS Rookie Topic Starter

    Isnt there a way that I can change it from whatever format it is to FAT32 or something? I seem to remember doing this some time before...
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    Either JVC used a filesystem that Windows doesn't recognize or it's also possible that the filesystem on the drive is corrupt so Windows may says it is "Uninitialized" or "Raw"

    Did you run TestDisk under Windows? or Linux or both? As if TestDisk can't see the drive under Windows, also try it under Linux. See [post=720766]this post[/post]
    => A couple "Try then Buy" commercial data recovery tools are listed below. I've never used either but
    > I've seen people often (not always) post good results after using the two commercial tools listed below
    > The tools will report (for free) the names of the files it can find. You'll need to buy it before it attempts to recover those files
    > Note: If the tools can report lost file names is a good start but still doesn't guarantee the results
  5. abazaba

    abazaba TS Rookie Topic Starter

    Thanks for the ideas, I'm downloading gparted now (at a painstaking 20kb\s). In the mean time let me ask this. The enclosure I bought came with 2 ZIF connectors, one for Hitachi and one for Toshiba, but neither will fit into the hard drive even though it is a Hitachi, which i thought was kind of strange. I am using the connector that was inside the camcorder for the time being, and I certainly hope that's not whats causing my problems all along. It seems to be working ok (lights up and powers on). Any thoughts?
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    Wow. 20kb/s is painfully slow. Not sure why the download is so slow but i guess that's a separate issue/question....(i tried this link for gparted-live iso and seems to run on 200kb/s

    Do you recall the model number of your JVC camera?
  7. abazaba

    abazaba TS Rookie Topic Starter

    Lol, the 20kb\s is ISP related... I dont remember the model of the camcorder, as it wasnt mine in the first place, but I think its one of only a couple that JVC has with a 30gbHDD. On a side note, I am now playing with it on XP just in case this can handle it any differently than vista was. Ive so far gotten it to read as disk 4 in device manager, but disk management only reads disk 0-3, so I've actually gotten less out of XP than I was getting with vista. I have pretty much resigned to the fact that JVC uses an unreadable (to windows) format but there has to be something that will read it. Once I get gparted burned I'll give that a shot.
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    Let us know if TestDisk on the gparted live cd can at least detect the device...

    Tho reflecting on your previous comments is odd the connectors that came with the enclosure don't fit the drive.

    > And when you say it "lights up and powers on" i assume you talk about the enclosure. Any sign that the drive itself actually spins up?

    If you continue to have problems also post the make/model of the enclosure and the Hitachi disk model number
  9. abazaba

    abazaba TS Rookie Topic Starter

    Arrrrrgh! I got nothing! Testdisk shows exactly the same drives in gparted live that it does in windows :( In response to your first question, yes the drive is spinning, I left the enclosure open to make sure of that. OK. the model number as written on the drive is: HTC368030H5CE00. It is a Hitachi 1.8" 30gb 3600rpm. The enclosure is Startech.com Infosafe 1.8"usb 2.0 CE IDE HDD Enclosure.

    Also found this amusing tidbit after googling the model number: "IBM(later Hitachi) is widely known in data recovery business for their line of DeskStar HDDs also known as DeathStars. These hard drives, mostly DTLA and AVER families, became infamous for their reportedly high failure rates."

  10. abazaba

    abazaba TS Rookie Topic Starter

    OK so funny story. ZIF = zero insertion force right?... total misnomer. The cable that came with the enclosure that "wouldnt fit" (yes, the little black clips were open) turned out to be the answer to it all. I crammed the hitachi cable in there real hard and bam! All of a sudden I have a readable, named hard drive. FAT32 by the way in case you were wondering. Now all I have to do is figure out how to convert these into watchable movies. Stupid answer to a crazy problem... thanks for playing along.
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...