Hardware Can't access BIOS, USB keyboard is not working and there is no PS/2 port

Hello, I tried looking everywhere for the solution but did not manage to find it online. So I'm hoping I can find some answers here.

I just updated an old PC from windows 7, 32bits to windows 10, 32bits. Now my plan is to upgrade it to 64bits. From my understanding I need to access the BIOS for that. I cannot access it via UEFI, I think because my motherboard does not support it (Legacy). Also, my USB keyboard is not working while booting the PC so I can't press F2. I read that a keyboard with a PS/2 port solves that issue but my PC does not have that port.
Also, I managed to reach the BIOS by changing the jumper setting in the motherboard, but still the same issue with the keyboard not working.
What options do I have, if any, to make it work? I can provide more info if needed.
 

bazz2004

Posts: 1,736   +290
I'd think carefully about moving to 64 bit on a really old PC. You will likely need to boost the ram too. An SSD can give a new lease of life to an older PC.
I've found that entering the BIOS varies and it may well be that you are trying the wrong key. F10, F2, F12, F1, F8 or DEL are all used by different manufacturers. I've wasted ages in the past pecking at the wrong key on start-up so try other keys and research your computer model.
There are usb to PS/2 adapters available but although they are cheap the chances of them working for you are not great.