Can't Delete A Desktop Icon Because "It Is Already In Use"

By HellsBells ยท 6 replies
Jun 11, 2005
  1. I attempted to download something but quickly found out that it was going to take too long to finish. I cancelled the download. I tried to delete the file (what was left of it, on my desktop) but it said the file was already in use. I closed Firefox and deleted all temp. internet files, etc. and then restarted my computer. Still no luck. I defragmented my computer and have deleted every internet file (history, download history...) and still no luck.

    I am running under Windows XP using Mozilla Firefox as my internet browser. Any help would be great.
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Couple of things you can try.

    Right click on the object and rename it, then try to delete it.

    Create a new folder on your desktop call it what you like. Drag and drop the offending object into the new folder, and try and delete the new folder.

    Boot into safe mode, and try to delete the object.

    Regards Howard :wave: :wave:
  3. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    This is classic. Well one easy way would be, if it works, to close the explorer process and delete the file from command line.

    Try these things in order:

    1. Can you rename the file? If you can rename it, can you delete it after rename?

    2. Click start-run and type "cmd" and enter. If you know how to use command line, browse to your desktop folder. Which would be like "c:\documents and settings\username\desktop". Then press ctrl-shift-esc and close the "explorer" process. Once all your icons and start bar dissapear, use the command window to del the file by typing, say "del filename.tmp" or whatever it is.
    If that works, then you can restart the explorer process by clicking file-new task and type "explorer" and enter.

    3. If those don't do it, you may use a program like killbox ( which will delete it on startup, I believe.

    4. If even those won't work. You could restart your computer in Safe Mode command prompt and use the command line to delete it like before.

    good luck
  4. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Sorry howard, didn't see you posted just before me.

    Something there should work for you.
  5. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    No problem mate. I`ve done it myself a few times lol.

    Regards Howard :haha:
  6. HellsBells

    HellsBells TS Rookie Topic Starter

    Hey, I had tried everything listed except for the program Killbox, which sorted the problem out. Thanks a lot for the help!
  7. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    wow, that's a surprise. I rarely get killbox to work, I have to use the other methods! Well glad it's gone anyway.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...