Can't enable Windows audio service on Windows 7

By Atham ยท 10 replies
Jun 4, 2011
Post New Reply
  1. When I try to start it this comes up:

    Any suggestions?
  2. Mark56

    Mark56 TechSpot Paladin Posts: 1,880

    Not sure about this one but try going into safe mode and sign in on the administrator account and try it again.

    Or try this sourced from another forum:

    The Windows Audio service is dependent on other services, which are running. So, go to Start and type services.msc in the Search box. Then press CTRL+SHIFT+ENTER to run as a Administrator. Once it opens, go to Windows Audio service and double-click on it. It will open Windows Audio Properties page. Click on Dependencies. It will show something like Multimedia Class Scheduler, Remote Procedure Call (RPC) and Windows Audio Endpoint Builder. These are the Services. Ensure that all these services are running by checking in the list.
  3. Atham

    Atham TS Enthusiast Topic Starter Posts: 454

    I did what you said and it worked. Thanks a lot. Thread can be locked
  4. Mark56

    Mark56 TechSpot Paladin Posts: 1,880

    Just for the record which method did the trick.
  5. Checking the dependancies and enabling one of the disabled ones : )
  6. Even though this is an old thread. Mate, you safed my life. This worked.
  8. I do what u say to do
    but but what to do after dependance ,how to run that in that window say no dependanceis
    plz inform me hurry
    this is vewry
    plz plz plz.
  9. reckonankit

    reckonankit TS Enthusiast Posts: 43


    WWCTTECH TS Rookie

    Thanks for the assistance as this still works. The fix was that "Multimedia Class Scheduler" was disabled.

  11. bartasbb

    bartasbb TS Rookie

    @Mark56 thank you! This help A LOT!

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...