Can't install Windows OS on new hard drive

By sleepydavid · 13 replies
Feb 2, 2011
Post New Reply
  1. hello

    I would be very grateful for any help or suggestions with the problem im having installing vista on a new HD.

    I got a sata hard drive for my Dell 131L laptop. Ive installed it and it is recognised in the bios. I have changed the boot order to boot from dvd/cd. However it doesnt work. i get the message.."bootmgr is missing". I have tried this with the genuine dell vista reinstallation disk and a dell copy xp installation disk.

    So i moved the disk to my inspiron 1525 to try it there but still no sucess. it is again recognised in the bios buti get the message "no bootable devices" and i think a code 5.

    I dont really know where to go from here. Is it because its a new HD there are no drivers for the dvd/cd drive?

    any help welcome

    thanks, david
  2. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    No. The BIOS contains a basic driver for the optical drive.

    Let's review the way you are trying to install Vista. After you change the boot order to boot from the optical drive, what exactly do you do?
  3. sleepydavid

    sleepydavid TS Rookie Topic Starter

    Hi mailpup

    hope life is good in LA

    When i change the boot order i save changes and exit. It then tries to boot and fails giving the errors as before. When i restart the laptop it again fals to boot from the dvd again giving the same errors. When i go back into the bios the changes to boot order have remained - dvd/cd first and not HD.

    It just doesnt seem to recognise either dvd or the drive. Both have been tested and are working . oh and Ubuntu live works when booted from usb.

    thanks for any advice.

  4. TomSEA

    TomSEA TechSpot Chancellor Posts: 2,718   +860

    Have you upgraded your laptop BIOS recently? Might want to give that a shot.
  5. sleepydavid

    sleepydavid TS Rookie Topic Starter

    Hi Tom

    no ive not updated. -never done that before but I'll give it a shot...but how do i do it if i cant get it to boot from cd/dvd. Am i right in thinking i go to dell update page and download onto a bootable cd?

    thanks, david
  6. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    This is copied from the Dell website for BIOS updates for the Latitude 131L:


    Description: This file format consists of a BIOS executable file. To use it, download the file and copy it to a DOS-bootable diskette. With the diskette in the floppy drive, reboot the system and run the program.


    Description: This file format consists of a BIOS executable file. The Universal (Windows/MS DOS) format can be used to install from Windows XP, Windows 2000, NT, Windows 9X, Windows ME or a MS DOS environment.

    Since you cannot get into Windows it appears you would need a floppy drive in order to update the BIOS. I don't suppose you have one?
  7. sleepydavid

    sleepydavid TS Rookie Topic Starter

    hi mailpup

    thanks for looking in to that for me. but of course i have no floppy drive. I really dont understand the technicalities here but could i download the file onto a bootable usb? otherwise i guess its no bios update.

    Also when i move the HD to another laptop - the one im using now - it still wont boot from the dvd/cd drive but with my normal HD iinstalled it does boot so im not sure its the bios.

    i managed to install ubuntu from usb - although not perfectly - just to check the HD was working so its not that...i think.

    i just keep getting "bootmgr is missing" when trying to install vista but its a genuine reinstallation disk and when i open the files of the disk, on this laptop, the file bootmgr is there...of course.

    As ubuntu booted from usb stick would a usb optical drive work for windows or would the problems persist? i could maybe try an pick one up cheap

    anyway thank you very much for all the suggestions for my wee problem
    greatly appreciated, david
  8. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    I don't know. Maybe but I doubt it. The thing is if you try it and it doesn't work, you could brick the motherboard.
  9. mattyswe

    mattyswe TS Rookie

    change your SATA mode?

    as per title, try changing to IDE or compatibility in your BIOS?
  10. boykov

    boykov TS Booster Posts: 74

    Hi mattyswe,

    As i understand it you can boot from USB...
    You can make a bootable Vista USB drive... but you will need access to a windows PC...

    1. Open a command prompt as administrator (Right click on Start > All Programs > Accessories > Command Prompt and select “Run as administrator”)

    2. Find the drive number of your USB Drive by typing the following in Command Prompt:
    list disk make note of which USB is the one you want to format "size of disk is a good indicator" will need disk number in next step

    3. Format the drive by typing the next instructions into the same window.
    select disk X (where X is the USB disk number)
    create partition primary
    select partition 1
    format fs=NTFS
    assign (check the letter which is assigned to the drive, will need it in step 4.)

    To make the drive bootable you will use the BOOTSECT utility on Vista/Win7 DVD

    4. Insert DVD in Drive
    in command prompt change directory to the DVD's directory (most cases d: and for now i will assume it is d:)
    cd boot
    bootsect.exe /nt60 X: (where x is the letter assigned to the USB drive in step 3.)

    5. Copy the content of the DVD to the USB drive

    Dont forget to set USB as first boot device in BIOS for USB to boot when needed!

    Have Fun
  11. greypigeon

    greypigeon TS Enthusiast Posts: 29

    for the
    format fs=ntfs i recommend to ad quick because it can take a time!
    format fs=ntfs quick
  12. sleepydavid

    sleepydavid TS Rookie Topic Starter

    hi boykov and greypigeon

    thanks very much for the detailed description. I'll give it a shot and let you know how i get on.

    best wishes, david
  13. robin_bga

    robin_bga TS Rookie Posts: 171

    Hello Sleepydavid, for the windows bios executable try download it from Laptop's website....
    However i personally think the hard disk is not enabled in bios, am not sure but the is a possibility that its disable... Just like u see in the dell Optiplex versions, u can disable a hard driver and it will be detected but not usable..
    If its a sata type, u could thing of changing from AHCI to RAID or vice versa..
    Hope that helps...
  14. sleepydavid

    sleepydavid TS Rookie Topic Starter


    update is that i managed to create the vista bootable usb. BUT....the dreaded "BOOTMGR is missing" again raised its ugly head. When i look on the files of the usb it is there. So thank you all for your help and suggestions and i'll try them all with another new HD just to see & if not i'll use ubuntu.

    thanks again everyone

    best wishes, david

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...