Tech Stocking Stuffers: 18 awesome gifts under $50

Can't search from address bar

By thewolfe ยท 32 replies
Apr 28, 2003
  1. Can't search from address bar

    I thought I was unable to search w/ google from my address bar but I am unable to search with any search engine.

    I have changed "Custom Search Settings from "Companion and have tried different Search Engines under "AutoSearch" but no go.

    Anytime I type a word in the address bar it adds a "www" & a ".com" at the end and sends me to that site.

    I originally thought it was only happening w/ Google, but it's all Search Engines.

    Any ideas?
  2. StormBringer

    StormBringer TS Maniac Posts: 2,244

    Try under Internet Options. Scroll down till you find the search settings and make sure they match the settings you set under Custom Search.

    BTW, next time, just edit your old post or reply to it with the new info rather than starting a new thread with the same problem.
  3. Tarkus

    Tarkus TechSpot Ambassador Posts: 621

  4. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Yea that is very helpful, but it seems he would have problems using that as well since all search engines don't work.
  5. thewolfe

    thewolfe TS Rookie Topic Starter Posts: 238

    Also, I can't see all of the graphics or advertisements on Yahoo or Hotmail but I can on other websites.
  6. TS | Thomas

    TS | Thomas TS Rookie Posts: 1,319

    In Internet Options, select the Advanced tab & adjust the option for "Searching from the Address bar - When searching".
  7. thewolfe

    thewolfe TS Rookie Topic Starter Posts: 238

    Found the problem

    I found the "Host" file, renamed it and all is well. Still not sure how the file got there or got changed. See below.


    Some of this could be due to your having a hosts file preventing you from downloading certain ads. The Action Cancelled and page cannot be displayed where ads might be is one of the results of that.

    Look in system32\drivers\etc fot a file named HOSTS

    No extension.

    Read here about HOSTS:
  8. Tim_Myth

    Tim_Myth TS Rookie

    Percent 20's when trying to search from Addy Bar

    I recently installed Windows XP on a brand new machine. The installation is less than a month old. When I try to search from my address bar, I get a "Page Cannot Be Displayed" error and the address bar displays a funky URL. For example, typing the following in the address bar:

    search from address bar

    results in the error page and the following in the address bar:


    I've downloaded adaware 6 and updated it. That didn't change anything. I've gone to classic internet search instead of the search companion, nothing changed. I checked my internet options, and searching from the address bar is enabled, but it still doesn't work. I've restored my system defaults. I've checked through my registry, but found nothing that looks obviously wrong. I've checked my Auto Search settings under advanced search settings, but to no avail.

    Is it normal for IE 6 and XP Pro to not search from the address bar?
  9. thewolfe

    thewolfe TS Rookie Topic Starter Posts: 238

    Click on Search in the Internet Exp tool bar or menu and click on "Custom"

    Check that out and then click on "Autosearch setting".

    See how she do.
  10. Tim_Myth

    Tim_Myth TS Rookie

    My newest course of action is to edit IE out of the registry and reinstall it.
  11. Slimphatdaddy

    Slimphatdaddy TS Rookie

    Re: Percent 20's when trying to search from Addy Bar

    When attempting to search from the address bar, this happens.

    "The page cannot be displayed" web page appears and "http:///?%20cats"

    Go to the location Look down to IE select wheather u want Google or Microsoft Default. It will update your registry to either.

    Set Search to Microsoft Default.

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
    "Use Search Asst"="yes"
    "Search Page"=""
    "Search Bar"=""

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchURL]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Search]

    Set Default search to Google

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
    "Use Search Asst"="no"
    "Search Page"=""
    "Search Bar"=""

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchURL]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Search]

    Then go to the following location in the registry [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\URLSearchHooks]
    and add a new string value with the name {CFBFAE00-17A6-11D0-99CB-00C04FD64497} including the blocks {} and leave the value empty/blank...

    the fix was to correct the Registry by adding the following...

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\URLSearchHooks]

    String Value: "{CFBFAE00-17A6-11D0-99CB-00C04FD64497}"

  12. Slimphatdaddy

    Slimphatdaddy TS Rookie

    Not sure what all the links are above I only added the one to google options.
  13. opchee

    opchee TS Rookie

    Thanks so much Slimphatdaddy!!!

    I too had the same problem, and Slimphatdaddy's fix is the only one that works. :grinthumb and here are a couple things i'd like to add to this helpful thread:

    1. my IE address bar search got screwed up by some browser hijack/spyware that somehow took over my IE (maybe i clicked a yes/no prompt too quick?) and Ad-aware and spybot got rid of the spyware, but leaves my IE address bar search crippled.

    2. i tried reinstalling IE, that doesnt fix the problem.

    3. i tried Slimphatdaddy's suggestions, but that still doesnt fix it, unless i do this crucial step. In [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\URLSearchHooks], in addition to adding {CFBFAE00-17A6-11D0-99CB-00C04FD64497}, i had to manually remove 2 other entries. they look like {alphabets and numbers}_
    both have an " _ " (underscore) and i finally got my IE address bar search function back when i deleted those 2 entries with underscores at the end.

    hope this helps anyone else who needs to get theirs fixed in the future.
  14. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    There's a number of spyware and viruses which will change your hosts file. Rather than rename it, you can open it with notepad and erase all of the entries.

    Then I recommend running SpyBot ( ) and using the "immunize" feature. This will block many blacklisted spyware/virus related websites.
  15. Goalie

    Goalie TS Booster Posts: 616

    Another thing that can greatly help, especially if you modify the hosts file manually like I do (stupid ______ing MS Exchange...), is after you modify hosts, set it to read only (write protect, whatever you want to call it.). This can help avoid many things writing to the hosts file.
  16. PeterAv

    PeterAv TS Rookie

    Just a follow up to opochee's comments (which I also found to
    be essential to restore the search capabilities).

    However, the important registry key I needed to delete did
    not end with an underscore but started with an underscore,

  17. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Thank you for a little more information that might help someone else out in the future.

    BTW :wave:Welcome to TechSpot:wave:
  18. thewolfe

    thewolfe TS Rookie Topic Starter Posts: 238

    Got it working. Tried numerous fixes yesterday w/ no help but today, All is well.
    Thought I had restarted after some registry tweaks so who knows.

    Thanks for the posts.
  19. garymarshall

    garymarshall TS Rookie

    You guys are great - I was having the same problem with a client machine and implemented the instructions from Slimphatdaddy and the subsequent msg to delete the _ line from the UrlSearchHooks. Restarted the browser and all went well... Thanks for your help
  20. mydemigod

    mydemigod TS Rookie


    You guys/girls are awesome. I was having this problem and I really think that this is the only fix on the net. Thanks so much for sharing this information.
  21. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    I"m glad we could be of service to you.
    Hope to see you come back to TechSpot for any other questions you might have :)
  22. Mulligan

    Mulligan TS Rookie

    Thank You Slimphatdaddy

    My computer was recently hijacked by some spyware and my address bar seaching functionalilty did not return after the removal of the spyware. I spent several hours trying to fix it and was unsuccessful until I found Slimphatdaddy's posting.

    I did have to also remove some strings preceded with "_" from [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\URLSearchHooks]. After that everything was great.

  23. EZ/PC

    EZ/PC TS Rookie

    Rockin Solution!!! Thanks Slimphatdaddy

    I too was struck by some obnoxious spyware. For days now could not search from my address bar. Slimphatdaddy, your solution is the bomb, work like a charm! Thanks so much.

  24. rbi99

    rbi99 TS Rookie

    Not working - still

    I did everything Slimphatdaddy and opchee suggested (in fact all the things they suggested were already in place), however, I still cannot search from the search bar when I use IE (everything is fine using Mozilla). In fact, all I really need IE for is window updates (which no longer works). Another weird thing happened the same time I lost the ability to search, when I go to Add/Remove Programs, the words id'ing the programs aren't visible, and when I go to Help in IE, and then About, I get an error message saying "an error has occured in this dialog" then kicks out. I redownloaded IE 6 and it apparently installed (after having these problems), but the one thing I see when I go to the About Interenet Explorer, is that it says I have 5.0, when I dl'd 6.0. I run Giant everynight, ad-remove, and spyboot - they show nothing. I use NOD32 and it says I have no viruses.
  25. Medue69

    Medue69 TS Rookie

    Cant search from the Address Bar

    I had an issue where for a few days I was unable to search to certain sites, so I thought it was my internet connection settings, I even installed a few other browsers, messed with my Anti Virus settings and no fix could be found. The strange thing is I had access to most of my favorites but would get "page cannot be displayed" for maybe 1 out of 4 sites. I finally asked around and found out that SP2, XP and Dell computers are having an incapability problem. So I contacted Dell after the few suggestions on here didnt work. I reset my settings by going to start, then run, and by typing "NETSH WINSOCK RESET CATALOG" Then I rebooted my computer and this issue was resolved. I hope that this may help some of you Dell users that are having the same problem.

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...