1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Can't see my NAS anymore

By RichH ยท 35 replies
Oct 28, 2018
Post New Reply
  1. Windows 8.1 PC stopped being able to see my NAS on my LAN a month ago. It simply does not appear in the Network. ethernet anymore. My LAN is eero and a TPLink 4 port switch. The PC is hardwired to a TPLink 4 ports witch which is wired to one of 2 eero ports. The other eero port is wired to the ATT router for WAN access. eero does my DHCP. NAS is ReadyNAS. My win7 laptop and 2 Sonos on the LAN can see the NAS.

    Currently NAS is assigned 192.168.7.23 and the PC is assigned 192.168.7. 31. eero DHCP subnet mask is 255.255.0.0

    My wife's Win7 laptop also can't see the NAS.
    Another Win10 computer on the LAN used to be able to see the NAS but now it can't.

    My Windows 7 laptop can still access the NAS just fine. The NAS, the LAN, and all the PCs have been rebooted several times since this started.

    Is it some kind of HomeGroup, or Workgroup type issue? I think this PC could access the NAS until I installed TunnelBear VPN on it and I might have messed something up during that time of messing around. The PC is a Roon music server, and because ATT throttles my Tidal streaming, I must use VPN to prevent the throttling. I have uninstalled TunnelBear but this didn't make the NAS visible. But it might have messed up something in Windows Networking.

    Any ideas? Thanks!!!
     
  2. jobeard

    jobeard TS Ambassador Posts: 12,368   +1,390

    Yes, I would suspect the VPN too.
     
    RichH likes this.
  3. RichH

    RichH TS Booster Topic Starter Posts: 144

    Thanks jobeard

    I neglected to mention that I used Revo Uninstaller to remove TunnelBear VPN and remove all traces from registry, then reboot, but that did not allow the PC to see the NAS.
     
  4. jobeard

    jobeard TS Ambassador Posts: 12,368   +1,390

    Login as admin, get a CMD prompt:

    • netsh winsock reset catalog
    • netsh int ipv4 reset reset.log
    reboot again
     
  5. RichH

    RichH TS Booster Topic Starter Posts: 144

    Thanks jobeard. I like your Mustang! I built a P51 model with that paint scheme 40 years ago. :)

    I successfully executed those commands as admin, rebooted, but still can't see NAS. Tunnelbear is still installed, but program exited before executing the commands.

    There's two other hosts besides NAS on the LAN that my Win7 laptop can see but the above Win8 PC can't see. I do have TunnelBear installed and running on the Win7 laptop and I can still see all the hosts on the LAN:

    net.
    Thanks
     
  6. jobeard

    jobeard TS Ambassador Posts: 12,368   +1,390

    WHY? IMO, your NAS is far more important than any benefits of a VPN
     
  7. RichH

    RichH TS Booster Topic Starter Posts: 144

    Good question jobeard

    I use VPN because I subscribe to Tidal for uncompressed music streaming and my ISP (ATT) is throttling Tidal, so it causes music to have delayed start, pause during playback, skipping tracks, etc. Encrypting my traffic with VPN prevents ATT from knowing I'm requesting Tidal data which fixes the problem.

    But my own stored music files are on my NAS, so I also need that available to the music PC.
    Thanks
     
  8. jobeard

    jobeard TS Ambassador Posts: 12,368   +1,390

    It is well known that a VPN messes with the Routing Table to exclude all access other than the VPN connection itself. IMO, as long as it is connected, I doubt you'll find a solution.

    Let's take a look at the Routing Table; connect the VPN and get a CMD prompt, then

    • route print >myRoutes.txt
    when complete, attach that file to your reply
     
  9. RichH

    RichH TS Booster Topic Starter Posts: 144

    Thanks jobeard

    myRoutes.txt attached
     

    Attached Files:

  10. RichH

    RichH TS Booster Topic Starter Posts: 144

    For kicks, attached is laptop_routes.txt which is from my Win7 laptop which has TunnelBear running and can still connect to other clients on the LAN.
    Thanks!
     

    Attached Files:

  11. jobeard

    jobeard TS Ambassador Posts: 12,368   +1,390

    Both systems are "interesting" with multiple adapters, using the 169.254.x.y address which is not intended and even a persistent route on it:
    Persistent Routes:(laptop win/7)
    Network Address Netmask Gateway Address Metric
    169.254.0.0 255.255.0.0 192.168.100.142 1

    Could you disable Tunnelbear on one system (tell me which) and rerun
    route print >routes_wo_tunnelbear.txt
     
  12. RichH

    RichH TS Booster Topic Starter Posts: 144

    It's from the Win7 laptop

    Thanks jobeard
     

    Attached Files:

  13. jobeard

    jobeard TS Ambassador Posts: 12,368   +1,390

    YES! the last route print is FAR more normal. The only "interesting" entry is the persistent route at the bottom.

    Let me guess; your NAS has an IP address like 169.254.x.y
     
  14. RichH

    RichH TS Booster Topic Starter Posts: 144

    The NAS is on LAN so my DHCP gives it 192.168.100.*

    The 169.284 must be the VPN network, with a one hole mask.
     
  15. jobeard

    jobeard TS Ambassador Posts: 12,368   +1,390

    The win/7 network is
    Code:
    0.0.0.0          0.0.0.0      192.168.7.1    192.168.7.206     20
    so this system did not use its DHCP to set an address like 192.168.100.*

    I suggest we get networking correct w/o tunnelbear and get all other system to access the
    192.168.100.*

    Please confirm that w/o tunnelbear running, all systems EXCEPT this win/7 have access to the NAS.
     
  16. jobeard

    jobeard TS Ambassador Posts: 12,368   +1,390

    Your router will hand out 192.168.7.* addresses,
    so where did the 192.168.100.* come from?

    Code:
    You apparently have wired:
    router--+--- system#1
            |
            +--- system#2 --- NAS
    
    
    when it should be wired:
    router--+- NAS
            |
            +--- system#1
            |
            +--- system#2
     
  17. RichH

    RichH TS Booster Topic Starter Posts: 144

    " The NAS is on LAN so my DHCP gives it 192.168.100.* "

    Sorry, the above statement is incorrect. I recently changed my LAN from ATT router to eero. The old ATT LAN was 192.168.100.* for years. But the new eero network is 192.168.7.* I was mistakenly thinking that the DHCP was still .100.*

    The ATT router now only serves as WAN host. It puts eero in DMZ. Eero has external IP address from ISP. eero does my DHCP. The old ATT router DHCP is as disabled as possible. All LAN clients connect to eero by DHCP. I have verified they are all on 192.168.7.*.

    The eero has two ethernet ports. One is connected to ATT router for WAN access. The other is connected to a 5 port TP-Link switch. The NAS and the PC that can't see the NAS are both wired into this switch. The Laptop normally uses eero wifi.

    When Win7 laptop is on WiFi it can browse and ping NAS. But if I move Win7 laptop to the wired ethernet switch then I cannot see the NAS anymore. They are both on the same switch, they already have DHCP IPs on the same network. I even swapped in a new TPLink switch but no change.

    When I ping NAS from my laptop (on WiFi) I get a normal IP address in response: 192.168.7.248.
    But when I ping the Dell computer from my laptop I get a different kind of response:
    fe80::90be:cbc7:90eb:a811%12:

    I don't see how I can simplify the network any further. Thanks for any other ideas
    Rich
     
  18. jobeard

    jobeard TS Ambassador Posts: 12,368   +1,390

    GOOD feedback :)

    Perhaps you know, fe80::90be:cbc7:90eb:a811%12 is an IPv6 address and it uses a different routing table!!!

    No home user NEEDS IPv6 and that allows tunneling to breach your security as well.

    IMO, I have long ago disabled IPv6 on my laptop -- recommend you do too.
    Disable IPv6

    right-click on Internet access icon in the tray

    go to Network and Sharing Center

    in the left pane, click on Change Adaptor Settings

    for both Local Area Connection AND Wireless Network Connection:

    right-click -> Properties​

    BTW: The NAS should have a fixed address, not dynamically changing. The easy way is to look into the router LAN settings, find the section Address Reservation and associate the NAS MAC address with the IP address of your choice.
    Save the settings.

    select Internet Protocol Version 6 (TCP/IPv6)
    clear the [x] check box in front of it

    click OK

    repeat for the next adapor

    when done, REBOOT​
     
    Last edited: Nov 6, 2018
  19. RichH

    RichH TS Booster Topic Starter Posts: 144

    Thanks jobeard!
    I thought that was IPv6 but I wasnt sure.
    IPv6 is now disabled on all adapters, all PCs.
    Reboot, but no change.

    I think it's weird that my win7 laptop sees everything on the network OK thru wifi but can't see Nas when it's plugged into ethernet and disconnected from wifi. At first I suspected the TPLink switch, but replacing it made no change.

    Seems like it should be something in the adapter settings that's causing behavior to change when physical connection changes.Maybe if I can figure that out for the laptop I can check the same settings on the Dell music server to resolve the original problem.
    Thanks!
     
  20. jobeard

    jobeard TS Ambassador Posts: 12,368   +1,390

    The NAS *MAY NOT* show up under the Computer Network as it does not need File Sharing to operate -- the key will be it to respond to PING -- test all systems form consistent response.
     
  21. jobeard

    jobeard TS Ambassador Posts: 12,368   +1,390

    BTW: I was going to comment on the Firewall, but if the failing system has access to other lan systems, that would indicate the firewall is ok.
     
  22. tipstir

    tipstir TS Ambassador Posts: 2,834   +192

    If you have this issue on Window 10 MS has disabled the SAMBA1 they say it's too easy to hack it. So you have to go into settings then the control panel where it say add and remove. Scroll down the list and check mark SAMBA1. By default Windows 10 is setup up for the more secured SAMBA2.
     
  23. jobeard

    jobeard TS Ambassador Posts: 12,368   +1,390

    You are spot-on, but not all devices support the updated SAMBA2 standard.
     
  24. jobeard

    jobeard TS Ambassador Posts: 12,368   +1,390

    Can you be more specific -- Control Panel "add & remove" what?
    I would like to check mine
     
  25. tipstir

    tipstir TS Ambassador Posts: 2,834   +192

    control panel
    uninstall or change a program
    turn off windows features on or off
    *SMB 1.0/CFS File Sharing (this one enable it)
     

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...