Spread the love! TechSpot Tech Gift Shortlist 2017

Catalyst install problem

By sol1109 ยท 4 replies
Oct 16, 2009
  1. Trying to install latest catalyst suite V 9.9 and I get as far as "ATI Parental Control & Encoder" and it seems to hang. Task manager says it is still running but it has been this way for over 1.5 hours. I have already canceled once and tried to install again. I recall in previous updates this would take some time like 5-10 minutes but never this long. I have searched AMD's web site and the INTERNET and find no similar reports. Video card is ATI HD4850 operating system is XP-PRO with SP3.
  2. almcneil

    almcneil TS Guru Posts: 1,277

    First, go into Add/Remove Programs (or Programs in Vista) and ensure that Catalyst is removed and any other video programs that may conflict with it are removed. Then try installing Catalyst again.

    Repost with results.

    -- Andy
  3. mailpup

    mailpup TS Special Forces Posts: 7,157   +459

    Do you have .NET Framework 2.0 installed from Windows Update? It's required for the Catalyst Control Center to install properly. If not or if you don't want to install .NET, try installing the driver only.
  4. sol1109

    sol1109 TS Member Topic Starter Posts: 43

    Thank you Almcneil, I have done that with both attempts, however unlike past times with my older card I was presented with two choices for removal. I choose the recommended level which was software but not chipset drivers. This next attempt I am doing after having selected the ALL option. Funny they do not mention the choice selection in the instructions.

    Mailpup, I have .NET 2.0 SP2 installed.
  5. sol1109

    sol1109 TS Member Topic Starter Posts: 43

    NO GO. Still hanging at the same point. I have also tried using msconfig to set a selective startup with system service only selected. I have allowed the install to sit at the "ATI Parental Control & Encoder" section overnight and it still was running in the morning with Task Manager still calling a running program. UPDATE>>>>Used the task manager to shut down the dialog box and after it closed another quick install pop-up came and went and then the installation complete notice appeared. Things seem to be running correctly now but I am not comfortable with what happened. I intend on submitting a service ticket with AMD to see what they say.<<<<
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...