CD Drive not working after Firmware update

By account73
May 9, 2009
  1. Hi,
    I really need some help.
    There's more than likely a easy soloution to this...atleast i really hope so, but im panicing a little so am asking for help already.
    On my dell studio xps 16 laptop i just recently installed windows 7. It was working great. All i had to do was download the display driver from ATI and install a few others that i have already.
    I decided to search Dell's website to check if there was any updated drivers for my machine. I noticed there was a firmware update for my CD drive.
    It's here

    I downloaded and ran it. It seemed to run succesfully, but no. Once my machine restarted the drive was no longer working. The eject button does not work, if i try to push a CD into it would not take it in. In both the bios and device manager it could not see the CD drive correctly. It was just showing it as mixed up random letters and symbols. I restarted my laptop a few times and removed the device from device manager a few times. I somehow managed to get the CD drive showing corretly again in bios and device manager, but it still doesnt work. If i try put a cd into it will not take it. Usualy you push it in to a certain spot and then it takes it, now it wont.
    Since this is a firmware update it seems i cant simply roll back the drive. There is no driver to roll back to anyway.
    How can i remove this firmware update? i really need help please.

    Here's some info that may help
  2. captaincranky

    captaincranky TechSpot Addict Posts: 13,036   +2,558

    If it's still available, you might try downloading the firmware version you had originally and reinstalling it. Or Dell support, if you're not at the point where you would have to pay for the call.

    Firmware updates are similar to BIOS updates in that they can render a device inoperable. A bad BIOS update will turn a motherboard into junk, with virtually no recourse. Recently, Seagate released a bad firmware update for it's High capacity SATA HDDs, which ruined a great many of them. In this case a warranty claim might be enforced. In your case, meh dunno.

    If it's not broken, don't try to fix it. If a burner operated correctly, it should be left alone. Burner firmware is sometimes updated to allow other brands of discs to be handled properly. Not what, I'm chicken. I'd just buy the brand it likes already.

    You might consider rethinking the constant search for updates. In most cases they're aren't really necessary since is most cases the machine shipped working.

    The exception to this rule is Windows Security Updates. Your system should be patched to avoid exploits. But here, I don't use auto updates, but rather set the system to notify me, then I download a my own convenience. >>After I set a restore point < ! (On certain updates, Windows will set one of it's own).

    BTW, IMHO TSST drives suck from the gitgo. You should buy an aftermarket one. They want to install software to constantly check for Firmware updates. And they don't really work that well.
  3. account73

    account73 TS Rookie Topic Starter Posts: 36

    phiew i fixed it :)
    Sorry i rushed into asking for help so fast. I paniced instead of searching for solution correctly.
    This firmware download had 2 folders, a windows folder and a dos folder. In each folder there is an application started and a .bin file.
    You lunch the application setup in the windows folder and then it asks for you to attach the file. Orginaly i attached the .bin file in the windows folder.
    I just tried again, but this time i attatched the .bin file in the dos folder. This displayed the correct details before it proceded and make my cd drive work again :)
    Silly mistake really. My own fault for rushing in to it.
  4. captaincranky

    captaincranky TechSpot Addict Posts: 13,036   +2,558

    Thanks for the update. Glad you got the durn thing workin'.

    Leave it to TSST to complicate the issue. I say that, but I just may be bitter.:(
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...