1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

CDRW and DVDRW do not recognize CDs but OK with DVDs

By pimpirulando
Jul 23, 2007
  1. Setup: WindowsXP/Pro; Master HD and DVDRW-Master, CDRW-Slave.

    These CD drives where working fine until I tried to burn a CD Image to a CD-R with the CDRW-Slave drive, which ended with an error (Roxio Creator - Poped-up automatically). I cancelled the recording, and kept working...

    Then I inserted a data CD or Music CDs and Windows said to please "Insert Drive" or "No disc on drive X"... but the disks are in!. I tried several CDs which work fine on my laptop, and so do my music CDs. Both CD and DVD drives read DVD ok, but not Data or music CDs. I checked through BIOS setup (I don't know why, I guess is like poping up your car hood and have no idea what you're looking for, but it feels like you're doing something...) but everything looks ok. Anyone has any idea?... Thanks in advance for any tips...
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,231   +234

    Get into Control Panel, Device Manager, IDE/ATAPI Controller, Primary and Secondary IDE channels, properties, advanced. Check to see what the DMA settings are. They should be set to DMA 5. If they are, remove the IDE Controllers in the Device Manager and restart your system. The IDE controllers will be automatically reinstalled after start up...

    It is not likely that both burners are bad at the same time.

    Good Luck :wave:
  3. pimpirulando

    pimpirulando TS Rookie Topic Starter

    Thanks TMagic650, but no luck...

    First Primary IDE: DMA 2
    Second Primary IDE: DMA 5
    First Secondary IDE: not applicable
    Second Secondary IDE: not applicable
    I removed them all, and rebooted machine, same problem. Removed them one at time, same problema...
    Then I tried the dreadfull "Restore System" to previous configuration to about 3 days ago. Same problem... I'll keep trying and researching about it, but if anyone has an idea I'll buy you a virtual drink...
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,231   +234

    Is your hard drive old? The first primary IDE (hard drive) should be DMA 5. The CD writers should be DMA 2 or better. You should have the first secondary IDE active DMA 2, but it is not active. Move both CD writers to the first and second secondary IDE channels, making the CDRW first secondary instead of the DVDRW drive...

    It looks like the secondary IDE channel is dead

    Have you recently added or changed any virtual drive software like Acronis or Daemon tools?
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...