1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Code 19 Error on USB connections

By redrover2359
Dec 2, 2010
Post New Reply
  1. PROBLEM: PC was unintentionally left unattended for hours while connected to "Lowes.com" Shopping Cart. When I returned to PC internet connection was lost & cold not reconnect to internet.

    Comcast modem was working fine (all lights green, also verified this with Comast).

    Running 64 Bit Vista on a Gateway GT5694 Desktop. Comcast Modem is connected directly to PC via Ethernet cable. No wireless routers are being used.

    Initial Solution/Diagonstics:

    Went to device manager – 3 line items under Network adapters:

    1) Ethernet Controller - which was working fine;
    2) Some item that had "Comcast" in the line item - this had the YELLOW EXCLAIMATION POINT saying that it was not working properly;
    3) Another item that I can't recall the specific name - this also had the YELLOW EXCLAIMATION POINT saying that it was not working properly

    I deleted the two items that were not working (I know this was a bad idea - should have uninstalled). As soon as I did this all seven of my Universal Serial Bus Controllers showed the YELLOW EXCLAIMATION POINT - saying "Windows cannot start this device because its configuration information is incomplete or damaged (Code 19)”

    Obviously no devices are working in any of the USB ports. The PC cannot find any networks.


    1. Reestablish Network Connection through Network and Sharing Center: Windows Network Diagonstics says “Marvel Yukon Ethernet Controller is experiencing driver or hardware issues. Ensure that Internet Protcol Version 4 and Verson 6 are selected for the network adapter ”Comcast Cable Connection” – Both versions are selected under the Ethernet Controller Properties.

    When double clicking the Local Area Connection (Marvel Yukon Controller) Icon under Network Connections, the following is noticed:

    IPv4 Connectivity: Not Connected
    IPv6 Connectivity: Not Connected

    When the Marvel Yukon Ethernet Controller is checked through Device Manager – it says the device is working properly and has the correct updated driver.

    Consultation with Gateway Service Tech said that deletion of the two “corrupt Network Adapters” caused the corruption of the USB’s, therefore attention was turned to getting the USB’s back to make hardware connections which would in turn allow the Ethernet Controller to find the Comcast Modem, recognize it and reinstall the network connection. Also note on this Gateway PC – the Ethernet and USB’s are built directly into the motherboard. There is no separate Network Card or USB card in the PCI slots.

    2. Tried to uninstall all USB devices in "Device Manager" and Scan for Hardware Changes. This reinstalled the USB's but they are still not working - Code 19.

    3. Tried to Update Driver for USB’s through Device Manager. The device manager says the most current driver is installed. – USB’s still not working - Code 19.

    4. Tried to do Windows System Restore - Got "Unspecified Error" no changes made to machine. Tried 4 other system restore points got same results.

    Consultation with Gateway Service Tech said I need to reinstall “Chipset” drivers for motherboard.

    5. Tried Gateway Recovery Center - Recover Hardware drivers and chipsets. The recovery center for "Communication Devices and System Components" there were 3 drivers available (Marvel LAN Driver, Realtek WLAN, Unibryce Modem). No motherboard chipsets were available. Tried reinstalling the 3 drivers above – did not improve USB situation.

    6. Tried Gateway web site to download drivers (entered by PC serial number to get appropriate drivers) but motherboard chipsets were not shown among the choices. Actually downloaded 2 different sets of drivers that might have been applicable to the motherboard chipset drivers but they turned out to only be video card drivers.

    Other aspects of the Computer are working properly: startup, keyboard & mouse (if plugged into PS2 connectors), DVD disk drives. I can run MS Office and other applications. Just can’t use any USB (and removable SDCard, Compact Flash Card slots etc) and can’t connect to any networks (and internet).


    Because the Windows System restore yields “Unspecified Error” – is this more a damaged hardware issue like some isolated aspect of the motherboard that is not impacting other operations. If this were a registry issue or a messed up driver setting wouldn’t the System Restore or the Recovery features work? – Should I look into replacing the motherboard?

    I did recently get a letter from Comcast expressing a concern that my modem backup battery might need to be replaced (apparently they monitor battery condition online). Is their any chance the CMOS battery on the PC motherboard could be impacting the USB and Network Adapters?

    Should I try reformatting the hard drive?

    Could this be a messed up registry setting? I read about “cleaning” the Upper and Lower filters within one of one the registry settings. (Type “regedit” under the Windows Start Menu “Run” option).

    Would installing a new and separate Network Card and a USB card into the PCI slots be a way around the problem to provide working USB ports and a new Ethernet plug connection.?

    Anyone have any other suggestions??
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    You may ultimately need to reinstall Windows.. but before getting to that point..

    You say no USB devices work?
    > Are you using a PS/2 Mouse and Keyboard?

    Re: reinstall your network drivers
    > First get the network drivers download files onto the computer. Once you do next step you'll have no network connection either
    > Look in Ctl Panel->Programs and Features. I'm going to guess you'll find an entry for your network card there. Uninstall from Programs and Features
    > Then reinstall the network drivers

    Then can you generate a copy of the Problem Device Report?
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    • On the other hand, if no devices are listed, tell me so

    Also see [post=766270]How to recover your folders/files when Windows won’t boot[/post] to both backup your data if you need reinstall PLUS you can see if your USB and network works under Knoppix (see if its a Windows specific issue or your motherboard)

    /* edit */
    Also, your problem doesn't have anything to do with upper/lower filters.
  3. redrover2359

    redrover2359 TS Rookie Topic Starter

    Thanks for the info/suggestions

    To answer your questions:

    I am using a PS2 keyboard and mouse to run PC now. Cannot run anyting off any of the USB's.

    After following your suggestions about uninstalling and reinstalling the drivers, I got the following Problem Device Report (I changed around the fomat to be less confusing - each 3 line group below refers to a single in the Problem Device Report

    Standard Enhanced PCI to USB Host Controller
    Failure using the VxD loader.

    Standard Enhanced PCI to USB Host Controller
    Failure using the VxD loader.

    Standard OpenHCD USB Host Controller
    PCI\VEN_1002&DEV_4397&SUBSYS_014E1025&REV_00\3&267A616A&0&90Failure using the VxD loader.

    Standard OpenHCD USB Host Controller
    PCI\VEN_1002&DEV_4398&SUBSYS_014E1025&REV_00\3&267A616A&0&91Failure using the VxD loader.

    Standard OpenHCD USB Host Controller
    PCI\VEN_1002&DEV_4397&SUBSYS_014E1025&REV_00\3&267A616A&0&98Failure using the VxD loader.

    Standard OpenHCD USB Host Controller
    PCI\VEN_1002&DEV_4398&SUBSYS_014E1025&REV_00\3&267A616A&0&99Failure using the VxD loader.

    Standard OpenHCD USB Host Controller
    PCI\VEN_1002&DEV_4399&SUBSYS_014E1025&REV_00\3&267A616A&0&A5Failure using the VxD loader.

    I really do not have a problem with reformatting the hard drive and reinstalling Windows Vista. I have installation CD's for my other applications. All my files are under "My Documents" of course except the email data file which I backed up with the Windows Backup Program as well as Norton 360.

    From my previous experience with an older computer - a reformat isn't a necessarily a bad thing - cleans things up, gets rid of extra junk etc

    I have the Windows Vista CD that came with the PC, as well as the Gateway Recovery Disks I made when I first started up the PC (for those non-Windows preinstalled applications). The way I look at it its really just a question of my time to refromat, reinstall, and redownload updates.

    I was just trying to convinve myself that a reformat would not result in a worse situation (entire computer locked up or unable to boot etc ... "just in little paranoia kicking in here")

    Its also been a long time since I've done a reformat. What is the best to go about a reformat - just insert the Windows Vista Operating System CD and let her rip? or should i get into the bios first and reformat from there?

    One other general question: when looking up the GT5694 system configuration on the Gateway website - it says I have an intergrated video, sound and network cards. I assume this means that the PC does not have separate video, sound and network cards in the PCI slots - they are all built into the motherboard. Correct?

    This is low buget PC, but has served my needs very well (not a gamer)

    PC specs are at support.gateway.com/s/PC/R/1015569R/1015569Rsp2.shtml

    Thanks for your input!!

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...