1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Comodo firewall programme access question

By Richtea1955 ยท 9 replies
Oct 27, 2007
  1. I started using comodo a while ago but am astounded at the number of alerts I get when logged onto the internet and then starting up and using other applications on my laptop.
    It almost seems every programme I open wants to connect to the internet and when i say 'deny' it stops the internet operating correctly (firefox). I then have to log out and back in again.

    As an example I'm using the internet to trace family history. I have open on my laptop the LDS family history software package. When and only when, I'm making an enquiry on a search within an internet website (eg FREEBMD) i get a pop-up saying that the LDS package wants to connect to the internet!!??

    With my previous package MacAfee I never had any pop-ups asking me to authorise a programmes access to the internet so seeing the number coming up using comodo is a bit of a worry - OR - should it be a worry?

    It seems as if comodo gives me more control over what logs onto the internet but it gives me more headaches into what the hell is going on.
    I'm a bit of a suspicious person! I think I'm becoming paranoid!
  2. samjohnson

    samjohnson TS Maniac Posts: 232

    Ya all the things asking if you want it to connect to the internet is kinda annoying. Two things you can do. Every time something asks to get on like your family history program then check the box that says remember my action, or something like that. It is to the left and down. Then after you check the box hit agree and comodo will remember it for next time you want to get online. Or when you are using the internet click on the comodo icon that is by your clock. In the lower left conner there is a little slider bar, put that to allow and everything will be able to connect and no more annoying popups. Just remember to put it back to the medium setting or the high setting when you are done.
  3. Rik

    Rik Banned Posts: 3,679

    You are supposed to allow access to programs that you know and rtrust.
  4. Richtea1955

    Richtea1955 TS Rookie Topic Starter

    Understand that rik but don't understand why the programme would want to access the internet in the first place?
    If a programme is set up to automatically look for updates then fine but i can normally check that in the preferences etc.

    When a programme wants to log on and I 'deny' it why does it screw up my internet access so that I have to log off and on again?
  5. Rik

    Rik Banned Posts: 3,679

    Iv'e not heard of a problem like that before. Perhaps it's to do with your isp?
  6. Richtea1955

    Richtea1955 TS Rookie Topic Starter

    I'm with AOL and use firefox through netgear wifi.

    Just to recap on the circumstances as I haven't been too detailed. When I'm using the internet and I open an application I sometimes get the sliding box from comodo saying that such and such programme wants to access the internet or modify my firefox access.
    When I 'deny' it then I am unable to use the internet any further as afterwards I get a standard firefox 'failure to access' window come up (can't remember the exact message now, but it's a general one !) Hope you understand what I'm on about.
  7. TimeParadoX

    TimeParadoX TS Rookie Posts: 2,224

    I used Comodo for awhile, It would screw up my CSS game because when I go to a new server it'll ask if a specific IP could connect to my computer and it would piss me off because it'll send me into windowed mode and slow my computer down.

    What you can do is this:

    Go to Comodo's options and go to Miscellaneous, then in the Alert slider thing, put to very low and it'll only ask 1 time each program you use, once you put the check mark and allow it'll never ask again for it.
  8. Richtea1955

    Richtea1955 TS Rookie Topic Starter

    Thanks, found that and set it to very low. I'll see how I get on with it now!
  9. Po`Girl

    Po`Girl TS Rookie Posts: 580

    It`s not the frequency of alerts that is the problem,

    it`s the nature of the alerts your clicking "deny" to.

    All browsers should be set to "allow" in the program control.

    Generic Host Processes for Windows (svchost.exe,services.exe and another one)

    should be set to allow.

    If you block those,you usually have to restart the computer to get them to reconnect.

    If you deny a browser,then you have to close/reopen the browser,to get it to work again.
  10. Richtea1955

    Richtea1955 TS Rookie Topic Starter

    Thanks for all your replies. I believe I now understand what is going on. Your replies helped & directed me to read the instructions!!

    As I now understand it, applications share common OS components and when I am logged onto the internet and then open an application comodo recognises that the application is sharing the component and asks me to accept that. The application is not necessarily using the internet connection. comodo is just checking that its a trusted application.
    I should really open up everything, get the learning phase over with and then set the Component Monitor from Learn to On.

    Paranoia took over me as I wondered why applications were 'logging on' .

    We're both sane again now!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...