Compaq v2000 series shuts down during windows XP setup

By HuBJuB ยท 24 replies
Apr 25, 2008
  1. Guys

    I recently bought a Compaq V2030US notebook. I bought it off ebay. WHen i bought it it had an issue with system booting from LAN and was giving PXE E51 error which i fixed easily by disabl it in BIOS and also change the boot order. but the issue that i am having now is weird.

    I am trying to install windows XP Professional service pack 2 on the hard drive. Now let me go back a little bit. I tested 2 hard drives (HDD 1 - Good, HDD 2 - Has a password block according to my DELL CPx). Now i tried to install XP on HDD 1 it starts of fine. Says Starting windows and then BAM!!! shuts down. same with HDD 2. starting windows from the disc and BAM!!! again...shuts down. I have a feelings that it could be the caddy connector. but i am not sure. again it could be a bad IDE borad|cable. Please advise guys. Before i start taking the system apart i want to know the easy ways. any help would be much appreciated. thanks

    M Kay
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    May be a faulty HardDrive partition

    Here is Delpart
    I've used it many times for stubborn partitions removal
    Here's some info on it:

    May be faulty Ram

    Here is Memtest ISO, to create a bootable Memtest CD.
    Run memtest at least 7 times for a thorough test.

    May be CPU

    A faulty internal processor, can cause this error.
    As many users tend to overclock CPU's (and Ram) Your first choice would be to load Bios defaults (or Optimized Defaults) in CMOS. But a hardware fault on your CPU means it will need to be replaced (this can be a little hard to explain presently.

    Can be devices attached to your computer

    Mainly USB and modem devices can cause issues with installing Windows
    Either unplug them (actually any not needed device) or disable them in CMOS

    It's a bit grey at this point. Without more info on error messages or anything else
    ie can be HardDrive or even the CD you're using !
    Just try the above first
  3. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Can also be a defective CPU fan, or plugged air channel.
    Unfortunately, the Compaq V2030US notebook has a high system board failure rate that requires a replacement.
  4. HuBJuB

    HuBJuB TS Rookie Topic Starter

    UPDATE: I put a vista DVD disc and was able to go get teh HDD work. But it shuts down itself again when it tried to install the UPDATES during installation. VISTA file expands|Install were successful with green check mark. So it tells me my HDD was working correctly at that time or may be, i m not sure. any idea what else could go wrong with it.

    After vista shuts off i put the XP disc and i was able to go past the screen where you push ENTER for windows setup. But again it shuts off during the NTFS quick format time. I am lost here.

    Is there like an ISO image for a DIAG tool or something so i can run some advance DIAG tests. Any help is much appreciated. thanks

    PS: I don't have a FLOPPY DRIVE.
  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    HardDrive Diagnostic Test CD can be made to test your HardDrive.

    But the above links in my post to you can all be bootable CD.

    You can even use Hirens BootCD or the Ultimate BootCD (there are a lot of choices.)
  6. HuBJuB

    HuBJuB TS Rookie Topic Starter

    thanks for your post kimsland..i am currently running UBCD. Processor/CPU test taking forever here. I will update you. Thanks for your support. Much appreciated. Weirdest issue i'v ever seen.!!
  7. HuBJuB

    HuBJuB TS Rookie Topic Starter

    UPDATE:: I tried to boot from UBCD and all the test passed (CPU|Memory|HDD Diag). But still having the same issue. I have tried 3 different HDD now so far and same results with all of them.



    At this point i dont know waht else to look for. Could it be cpu fan|heat sink? or the caddy connector or the IDE connector|cable on the board?

    Please advise me if you have seen this similar problem. Your help is much appreciated. Thanks

    attaching the screenshot:

  8. HuBJuB

    HuBJuB TS Rookie Topic Starter

    UPDATE:: I Opened the system and clean the air flow vent and other stuffs (dusts!!) and tried to setup XP PRO again. Still having the same issue. So we know its not the air vent either now. What are our next steps to check.



    Any help would be much appreciated. Thanks in advance
  9. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    I'd say CPU or Ram
    You may need to remount the CPU, with new thermal paste; and cleaning the CPU first with isoprophyl alcohol.
    Note: on a laptop this can be difficult. ie you will need some hardware experience first.

    Have a look at ArcticSilver Instructions
    Here's some of the compounds there.

    By the way, if you go to CMOS and just stay there for 10mins, does it also restart?
    If so, then it really does seem like a heat issue.

    Also have you tried with the battery out? The battery itself can cause heat issues too.
  10. HuBJuB

    HuBJuB TS Rookie Topic Starter

    kimsland.. i have re-mount the CPS | battery was out also. And i can run the diag tests with no problem. system stays on for hours when i am running the diags. it doesnt shut down or any other symptoms for fault during diag time.

    I was able to load Mandriva from disc and browse linux but as soon as i hit the firefox icon to get online in mandriva it shuts itself off. i dont know if that tells you anything!!

    thanks in advance.

    PS: thermal paste!!! is it expensive? i opened the CPU and notice that there werent any thermal around it. it looked dry to me. do you think wthat could be the reason. is there a bootable tool so i can check my tempareture of the system CPU | HDD etc.

  11. HuBJuB

    HuBJuB TS Rookie Topic Starter

    UPDATE:: i tried to RUN the program "The Troubleshooter - Self booting diagnostics" from hiren's boot disc and it seems to halt|frreze and it says detecting hardware and do nothing. Any idea?
  12. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    I should have mentioned, don't disconnect the heatsink, unless you are ready to apply the new thermal paste.

    Now that you have checked the paste (yes they do harden) it would be wise to go ahead and clean all the hardened paste off (isoprophyl alcohol) and then apply new paste. And then test the temperature after that. There was a thread on the best tools, but they all seem to vary in temp recordings! So the recommendation is to just do it (clean and paste)

    Mind you, the fault does not sound like CPU anymore anyway (well the new bit yes, but not the original fault) It really points to Ram (or even Video Ram)

    Go back to CMOS and load optimized defaults, also disable as many things as possible, after that (ie sound; modem; USB; Printer port, so forth)

    But the thermal paste (greece) is very important.
  13. HuBJuB

    HuBJuB TS Rookie Topic Starter

    i am going to disable pretty much everything from BIOS to see if something there casuing this issue. but as u know COMPAQ v2000 series BIOS doesnt let you customize it too much. its just basic BIOS. so i am gona use some BIOS mod tool from Hiren's boot CD and see what happens.

    PS:: oh by the way i forgot to mention that when the system tries to boot from HDD its giving me STOP 0X0000007B!!

    UPDATE:: while running the system board diag. PC DOCTOR result - PCMCIA and USB port External loop FAILED

    i dont have any pcmcia drive install on the system but i am not sure about the usb port external loop.
  14. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Yes that may have been important to mention !!
  15. HuBJuB

    HuBJuB TS Rookie Topic Starter

    well this what i did, i installed windows file using another computer in the HDD and then i thought compaq v2000 would just install the OS automatically. Probly tahts why its coming up with that error 0x0000007B, because OS files werent meant for this drive (HDD).

    It was giving me ntldr missing before there werent any file.
  16. HuBJuB

    HuBJuB TS Rookie Topic Starter

    SOLVED:: I tried disabeling ACPI by changing the computer-type to "standard PC i486" ... and now my system is copying all the OS files to the HDD and i can feel it working ..HAPPY !!!! this is how you do it :: when you first boot off the CD, look for the prompt to press F6 to install additional drivers & instead press F5 then select standard PC from the list.

    As i am speaking system is loading the files in to the harddrive !! ops did i mention it already!! lol..too happy..cant blame me..after 3 nights fight!!!

    attaching 2 pictures for further support.

    KIMSLAND .. respect !! it was a pleasure working with u!

  17. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    That's strange, why haven't I ever looked at this ACPI problem? (retorically speaking)
    I have learnt something new, it's incredible. Thank-you HuBJuB, next time I install Xp I'm going to check F5 out.

    More info here:

    The Role of the F5 Key and Shutdown Problems

    When XP is first installed it tries to determine what type of BIOS is available on the computer. Newer systems have what is known as Advanced Configuration and Power Interface (ACPI) capability. Unfortunately, XP doesn't always recognize a computer BIOS is ACPI capable and doesn't install the support for ACPI. Even more unfortunate is the fact that if ACPI support isn't determined at the initial install it's virtually impossible to correct this at a later time short of reinstalling XP over the top of the previous XP installation. To do so requires changing the Hardware Abstraction Layer (HAL). The chances of successfully changing a HAL after XP has been installed is pretty close to zilch.

    Once you drop the CD in the tray and fire up the computer to install XP, the first thing you'll see at the bottom of the screen is the option to press F6 if you need to install a SCSI or RAID controller. Don't press F6. Press F5 instead. This will take you to a separate menu of Hardware Abstraction Layer's where you can choose an appropriate HAL that supports ACPI. The choices will be:
    • ACPI Multiprocessor PC
    • ACPI Uniprocessor PC
    • Advanced Configuration and Power Interface (ACPI) PC
    • Compaq SystemPro Multiprocessor or 100% Compatible PC
    • MPS Uniprocessor PC
    • MPS Multiprocessor PC
    • Standard PC
    • Standard PC with C-Step i486
    • Other
    In the majority of installations the 'Advanced Configuration and Power Interface (ACPI) PC' HAL is the one you will want to use. A few cautions are also in order:
    • Obtain and install the latest BIOS for your motherboard before you begin the XP installation.
    • Equally as important as using the proper HAL on ACPI capable systems, is NOT using it on systems that are not ACPI compatible. The install may complete but the system will almost surely fail to start when it reboots.
    • There are situations where it is definitely not desirable to use an ACPI HAL even if it is supported by the BIOS. This predominately applies to servers, but to ensure that an ACPI HAL will not be used or automatically detected and used, press F7 instead of F5 as discussed previously.
    Considering the number of problems that users have with systems not shutting down completely I wonder why this feature is not prominently mentioned and documented. It could save many headaches, but now you know. A good piece of knowledge to have tucked away for your next XP install.

    As a final note, to determine if your computer was detected as being ACPI enabled:

    Right click My Computer then click Properties > Hardware > Device Manager.
    Expand the entry called Computer.

    If the entry is 'Advanced Configuration and Power Interface (ACPI) PC' you're all set. If it says 'Standard PC' the computer BIOS was not detected as being ACPI capable.
  18. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Bios Info: Compaq Presario V2000 CTO Notebook PC


    Release Date: 2005-02-05 Version: F.14
    -Fixes intermittent issue where the system shuts down automatically.

    Current Bios version
    Release Date: 2006-03-31 Version: F.23 A

    Is your bios updated to the current version?

    Also here are your Xp drivers (seeming Xp should be installed by now!)
  19. HuBJuB

    HuBJuB TS Rookie Topic Starter

    i havent checked that BIOS cause its windows based. i am still installing the new xp sp3 RTM. then first thing would be that BIOS updat for sure.!! thanks for the lnk by the way.
  20. raybay

    raybay TS Evangelist Posts: 7,241   +10

    If you have not installed SP3, do not do so.
    Use SP2 until you know everything else is working properly. Why add to troubles with something nobody has thorougly tested.
  21. HuBJuB

    HuBJuB TS Rookie Topic Starter

    RAYBAY..i been using SP3 with no issues at all.. i am trying out the newest soon to be released WINDOWS XP SERVICE PACK 3 RTM version. just wnat to see how it is. they say its got a lot features from vista but works with XP and faster.
  22. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Do you mean the install bios program?

    Anyway, a bios update should always (ideally) come before a Windows install.

    By the way, as per raybay, do NOT install Xp SP3 (it's not even released yet!)

    We're talking days until it is !
  23. HuBJuB

    HuBJuB TS Rookie Topic Starter

    KIMSLAND..guess what! i tried to flush BIOS and it came up with 0x7f..weird. I did played around with the BIOS earlier.! may be thats why..let me check
  24. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

  25. HuBJuB

    HuBJuB TS Rookie Topic Starter

    i am going to try a BIOS default ..if that doesnt work ima leave it for today. i been fighting with this issue since wednesday. but will definately update yall about the BIOS flushing.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...