Corrupt Partition/MBR?

By roxxas2 ยท 5 replies
Mar 17, 2010
  1. Hello everyone!

    A few days ago, on my Lenovo IBM T60 laptop with Windows 7 installed as an OS; most of the applications on my PC stopped responding(With a PC?!). So, I shut the laptop down. When I booted it back up, I didn't get the Windows 7 start up animation. Instead, I recieved a screen telling me that Windows had failed to start. So, I went to the recovery console.

    Once there, I went to the System Restore option. When I went to select an OS, it wasn't there! I also didn't have a recent back-up file on hand, so I whipped out my Ultimate Boot Disc, and ran a check-disk. It did find some bad blocks and repaired them. Although, when I restarted my PC and went back to the System Restore option in the recovery console, my OS was back! I also had a couple of restore points available. BUT, they were from 2009. Windows still won't start up either. I thought it was an MBR problem, but now, I think it's a partition problem. Anyway, I need to know the best implementation or program I can use to solve this problem.

    Thank you all!


    P.S. When I start it up, the file it says it's missing, is the tcpip.sys file.
  2. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,448   +145

    Probably because it is missing....if you have a disk, try to use the recovery console (I think you can still do that on windows7).
  3. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    ok, but does it get to the login and can you?

    the missing file is for the Internet or LAN access and the system should still be viable.
    if so, then we can recover tcpip.sys w/o system restore
  4. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    1) find your i386 dir as that is where tcpip.sy_ is located

    2) using an admin login, get a command prompt
    cd to the i386 location
    expand tcpip.sy_ \windows\system32\tcpip.sys
  5. roxxas2

    roxxas2 TS Enthusiast Topic Starter Posts: 65   +22


    Well, I've tried the disc. And I know that the file is missing. I've tried the recovery console on the DVD. It did not work.
  6. roxxas2

    roxxas2 TS Enthusiast Topic Starter Posts: 65   +22

    I cannot log into the system. I can only access files through the Ultimate Boot Disc shell.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...