Corsair M60 = dead USB ports?

By Dawn1113
Oct 25, 2012
Post New Reply
  1. I just bought a Corsair M60 gaming mouse. I installed both the updated firmware and the drivers for the mouse and played a few rounds of Medal of Honor: Warfigher on multiplayer. The mouse performed pretty good. I played for a good three hours without a problem. I then shut down to attend to something away from my PC.

    When I rebooted my PC two hours later, the USB 3.0 ports in the rear hub of my setup -- where the M60 was plugged -- were no longer working. The mouse was unresponsive. I did a hard shut down, plugged the mouse into a USB port in the front panel, then boot my PC into Windows. The mouse worked, but the ports in rear USB 3.0 hub remained unresponsive. So I did the "unplug the power cord, wait five minutes then reboot " band aid solution, which -- as expected -- worked. Windows installed its generic mouse drivers. I'm using those now.

    I've uninstalled the M60 driver for now, but have kept the firmware update intact. I would really like to be able to use the driver's features. But I'm worried that I might run into the same issue again and be forced into another hard reset.

    What could have caused the problem? I know it's a lot to ask, but I'd like to first hear your advice and inputs, and perhaps learn more about this issue, before I try re-installing the Corsair drivers.

    I've got an Asus P9X79 Pro motherboard. As mentioned, the M60 is plugged into a rear USB 3.0 port. Here are the specs for the mouse.

    As always, your help and advice will be greatly appreciated.
  2. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    Try rolling back that driver update
  3. Dawn1113

    Dawn1113 TS Booster Topic Starter Posts: 322   +65

    Thanks for taking the time to even read the post, jobeard. :)

    I'm going to try and roll back the update and see if the driver works then. I'm keeping my fingers crossed.

    Again, thanks.
  4. Dawn1113

    Dawn1113 TS Booster Topic Starter Posts: 322   +65

    Still a no go, I'm afraid. It worked for a while. I rolled back the firmware, re-installed the driver, and everything seemed fine. But on cold boot a few hours later, the ports in the hub where I had the mouse plugged were again unresponsive. I'm going to uninstall, run driver sweeper and re-install everything one more time.

    This is obviously a driver issue. I've checked the Corsair forums and it seems other M60 owners have encountered this same problem. The firmware update is supposedly the fix. I'm thinking I'm somehow mucking up the update process.

    I really wish these things were made easy and simple. The mouse did not come with troubleshooting tips. Not much in the manual except how to use the software.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...