By jaysg28 · 13 replies
May 25, 2005
  1. Having just bought (what I think is) a Barton XP 3200+, I noticed a lot of discussion about fake CPU's ( especially AMD Bartons ). One of the easiest ways to test a CPU was to run CPU-Z on it to see what CPU you have really got. Then I realised that I dont actually know what a readings an original Barton 3200+ should give out. All I know is that CPU-Z v1.28 is telling me that my CPU has a L2 cache of 64kb. Now, I know that my CPU should have an L1 cache of 128kb and L2 should be 512kb. So, have I got a fake processor or am I reading CPU-Z incorrectly ?
    Maybe we should get a thread going to publish the readings from CPU-Z for all the different processors out there. At least we'll have somewhere to go when you think an online store is ripping you off !!
    What do you think ?
  2. Justin

    Justin TS Rookie Posts: 942

    Are you sure you are looking at the L2 cache? Having only 64kb of l2 cache on a "barton" would be obviously incorrect. The only Socket A AMD cpus with 64kb of L2 are the Durons and the Applebred Durons. I would suggest looking in two places:

    1) Your system bios. It will tell you the CPU name and the amount of L2 cache. If it says 64kb for L2 there, you definately do not have a barton

    2) Another CPU program such as CPUID for Windows, or if you use linux, cat /proc/cpuinfo

    Make sure you have the latest version of CPU-Z as well, and that your system BIOS is up to date. It may be you have a board with an older bios that doesn't recognize bartons properly, but that is unlikely.
  3. jaysg28

    jaysg28 TS Rookie Topic Starter

    Hi there,

    I tried AMD CPUID as you suggested and yet again, it did not recognise my CPU ( unkown CPU ) and again reported L2 at 64k with associativity of 16... ( what does that mean ?? ). I think I have been sold a fake cpu or they have tried to palm me off with a lesser CPU. What do you think ?
    Many thanks for your help with this Soul, :)
  4. Justin

    Justin TS Rookie Posts: 942

    Are you using that computer to post? If not, do this:

    Take the cpu out of the socket and clean off the core. On the core and/or PCB (core for older athlons, PCB for newer) is the OPN code for the CPU. Write down exactly what is on the cpu, then relay it to us here. That will tell you for sure what processor you have.
  5. jaysg28

    jaysg28 TS Rookie Topic Starter

    Here is the CPU-Z version 1.28.6 report.... what do you think ?

    Number of CPUs 1
    Name AMD Athlon XP
    Code name Barton
    Specification Unknown CPU Type
    Family/Model/Stepping 6A0
    Extended Family/Model 7/A
    Package Socket A
    Technology 0.13µ
    Instructions Sets MMX, Extended MMX, 3DNow!, Extended 3DNow!, SSE
    Clock Speed 2204.9 MHz
    Clock multiplier x11.0
    Front Side Bus Frequency 200.4 MHz
    Bus Speed 400.9 MHz
    L1 Data Cache 64 KBytes, 2-way set associative, 64 Bytes line size
    L1 Instruction Cache 64 KBytes, 2-way set associative, 64 Bytes line size
    L2 Cache 64 KBytes, 16-way set associative, 64 Bytes line size
    L2 Speed 2204.9 MHz (Full)
    L2 Location On Chip
    L2 Data Prefetch Logic yes
    L2 Bus Width 64 bits
  6. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Maybe your board doesn't properly support that CPU.
  7. Justin

    Justin TS Rookie Posts: 942

    This is a possibility. What is your motherboard Make and Model, and, if you can get it, your BIOS revision?
  8. jaysg28

    jaysg28 TS Rookie Topic Starter

    Its an A7N8X-X with the latest BIOS rev 1010. Can the motherboard change the way that CPUID software reports ? I have now also tried AMD CPUID and WCPUID. All report the same L1=64kb + 64kb and L2=64kb. This surely cant be right.
    Many thanks
  9. Justin

    Justin TS Rookie Posts: 942

    That is very strange. I am sitting right now at a workstation with an A7N8X-X with AXP in it that reports 256kb L2 cache.

    I would try another CPU program. Look for CPUID.
  10. jaysg28

    jaysg28 TS Rookie Topic Starter

    I just tried AMD CPUID which again did not recognise my CPU and showed and L2=64kb
    A also tried WCPUID which did not recognise my CPU and showed L2=64kb
    There must be a problem with the CPU, do you agree, or am I being too simplistic about this :confused:
  11. Justin

    Justin TS Rookie Posts: 942

    Next step: benchmark the CPU

    In a minimal environment (have nothing running except explorer and the benchmark program), run a CPU test. I would suggest Sisoft Sandra. Run the cpu test several times and average them, then compare it to the listed result for the same CPU that sandra presents. Post your results here.
  12. jaysg28

    jaysg28 TS Rookie Topic Starter


    Hi Soul,


    I asked Sandra and she told me
    ALU DHRY = 9022
    FPU WHET = 3441
    Well below the comparitive figures for the same processor.

    I also used the Memory/Cache benchmark utility. It showed me that all is well until it started tests using more than 64kb, then the graph it produces illustrated a massive drop to almost zero. Well below what the comparitve graph showed. Its starting to look like a worst case scenario :suspiciou
  13. Justin

    Justin TS Rookie Posts: 942

    Get a return on your cpu
  14. jaysg28

    jaysg28 TS Rookie Topic Starter


    Thank you for your help and guidance. It was nice being able to "speak" to someone who actually knoiws stuff. I've posted on a lot of forums about this problem but, in the end, I used techspot. Friendly ( NOT PATRONISING ) people.

    Thanks again
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...