D link DFE-528TX not being initiated

By Chris93
Dec 22, 2007
  1. G'day,

    Chris here, I recently aquired an old computer (Running ME, an old HP Pavilion) from one of my mates, however it didn't have a network port so I purchased a D-link DFE-528TX PCI network card.

    I installed the hardware, plugged my computer into the router, and it was working fine. I straight away started downloading Zonealarm Free and AVG Free, however the internet cut out unexpectedly. I checked the hardware manager in my computer and it was there, working fine. I restarted my computer and the screen blacked out for about 30 seconds then loaded windows. Checking the manager again, i found that it said that windows had initiated Code 10 which means that it had tried to load the hardware but had encountered errors and so stopped loading it. So, no internet.

    My first thought was a virus or rootkit so I downloaded AVG on my own computer and Zonealarm v4 from Oldversion.com after reading that it worked better on ME then other versions. I ran AVG on the computer and nothing was detected. Zonealarm detected the computer's multimedia keyboard trying to access the internet which was really weird but other than that nothing.

    I then thought that the drivers were outdated so I downloaded the latest version (1.3) and put them on the computer. Trying to update the drivers caused the computer to crash, saying again that it had tried to initiate the device but had failed again.

    Many thanks for anyone that helps me fix this problem, another mate of mine recommended this forum to me.


    Note: I have a HijackThis log of the computer if you require it, I can also list all of the other hardware in the computer.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...