Tech Stocking Stuffers: 18 awesome gifts under $50

darn new radeon 9600 card

By chadjs ยท 21 replies
Dec 12, 2003
  1. i just purchased a ati radeon 9600 se card for my dell dimension 4100...trying to install the frickin' thing and i am having some problems...
    #1 do i need to update my intel processor to agp controller driver?

    #2 i believe i installed the card itself correctly, following ati's directions

    #3 now i am tryin gto install the catalyst software and i receive a "Severe" message stating that setup is unable to complete installation..with the suggestion that i try to setup my display adapter with standard VGA driver before running setup

    i went under my display adapters in the system and for some reason in have two display adapters listed...
    standard pci graphics adapter
    standard pci graphics adapter (vga)

    the radeon card i purchased fits into a agp port..

    i tried installation the software by both removing and disenabling the standard pci graphics adapter with no such!
  2. chadjs

    chadjs TS Rookie Topic Starter

    do i need to mainpulate my bios settings?

    thought it was going to be easier than this
  3. MoRulez

    MoRulez TS Rookie Posts: 65

    Did you remove the pre- radeon 9600se card's drivers BEFORE running the catalyst software?

    If not, you should do that, then restart your computer and your computer should start up with the "standard pci graphics adapter (vga)" drivers (you should check to make sure, but it should be obvious if your screen resolution is horrible). Then run the ATI software to install the drivers.
  4. chadjs

    chadjs TS Rookie Topic Starter

    i did remove my prior card prior to intalling my new card; however, when i run the software (catalyst), it fails to load--error message stating that i should try setting my display adapter with standard vga driver (which is already done, at least i think it is done)
  5. Krugger

    Krugger TS Rookie Posts: 173

    that's an error in a release of the catalysts. i had the same problem as did others. lemme find the fixed link, or you just go back one version of catalysts.
    go there, click on the appropriate O/S and download/install that package. it should work just fine. if not, there's a longer more drawn out manual process we can try. or if you'd rather, just go back to the Cat 3.8's. but try the link i posted first.
    good luck,
  6. MoRulez

    MoRulez TS Rookie Posts: 65

    What I meant was did you remove the drivers of the previous card you had BEFORE installing the ATI drivers.

    Try Krugger's tip and let us know how it works out.
  7. PreservedSwine

    PreservedSwine TS Rookie Posts: 325

    1) put your OLD card back in

    2) boot up, and UNINSTALL the driver via "add-remove programs"

    3) Turn off your computer, remove the old card, pop in the new one

    4) Turn on your computer, install new drivers

    5) re-boot

    That's it...

    Don't just put the new card in w/out uninstalling the OLD drivers, or you're asking for trouble:blackeye:
  8. chadjs

    chadjs TS Rookie Topic Starter

    krugger--you the man; frickin software that was sent with the card was the problem..
  9. Krugger

    Krugger TS Rookie Posts: 173

    yup, luckily i went through the same thing a few weeks back :)
    glad to hear its running, thats a nice card, enjoy it! (I know i would)
  10. Roman

    Roman TS Rookie

    I'll try 3.8

    Same prob with a 9600 in My ASUS K7V (Athlon 850). Damn thought I found my answer here finally. Tried Kreuger's link but it brought me to a Call of Duty issue. Seems like they reused the issue ID maybe. I'm going to try 3.8 as he suggested anything is better than this VGA sh#t right now.
  11. Hal

    Hal TS Rookie

    Changing video cards mid-flight can be a nightmare!! I had one that refused to set up properly, doing everything by-the-book. I either had windows protection error at startup, or BSOD at shutdown.
    Had to scrub the drive and start again with the new card installed.
    All was fine after that.
  12. MrGaribaldi

    MrGaribaldi TechSpot Ambassador Posts: 2,512

    I'm sorry, but what are you talking about :confused:
    Changing graphic cards midflight? Care to explain?

    Roman> Would you mind going into a bit more detail? Have you done everything suggested in this thread? What are the latest drivers you've tried? (Oh, and what is your system specs?)

    Aside from that
    :wave: Hello & Welcome to TechSpot :wave:
  13. Hal

    Hal TS Rookie

    I mean pulling the current video card and changing to another on an already setup system.
    Most of the time all will be fine, but I've had some that just would not play the game.
  14. MrGaribaldi

    MrGaribaldi TechSpot Ambassador Posts: 2,512

    Ah, yes that's quite true.

    But at least it's still better than changing motherboards in 2k/XP on the fly.... :D
  15. Hal

    Hal TS Rookie

    LOL!! I had a hard drive with xp on it, I was using it to test some motherboards. On about the 3rd motherboard the OS completely spat the dummy at me and refused to boot!! :)
  16. Roman

    Roman TS Rookie

    I'm at work on my lunch not a lot of time for too much detail but was installing the 9600 SE and was getting the same error may people were getting and is desc ribed in the post that began this thread. I tried what I read here and did everything right but it wasn't working in Win98. I finally got it to go in Win2K. I had trouble finding the patch Kruger mentioned I can't recall if I ever did find it and run it. I think it was a combination of finding it and changing memory resources in device manager I think the graphics card and PCI/AGP bridge were using same memory.

    I still need to go back into Win98 and get it to work there. Hope I can get it running there too. My sys config in a nutsheel is an ASUS k7V mobo. w/ VIA Chipset and 850 MHz Athlon.

    Thanks for the warm welcome. I hate to digress but had an interesting problem last night. I installed Roxio Easy CD Creator 5 in Win2k which I had done with no problems in Win 98. After doing so I noticed I was having some trouble though not sure if this was the cause.

    Now my Kenwood 72X ( Zen powered ) has stopped reading an install disk for an Atari game Temple of Elemental Evil. I hd some old Descent 3 disks laying around with drivers disks and tried to install them and they ran fine. However TOEE autodetects the disk asks if you want to install and then fails. This disk has done two previous installs within the past two weeks fine so I'm thinking the disk itself is ok though it was dark in the room at the time and I need to get a better look at the disk surface. I also noticed now that it changed my CD-ROM to D: instead of I: where in Win2K it used to skip right over the D: label and now I've forgotten why but it now has set the CD to D:. Anyway I tried some firmware flash I found but didn't seem to help and the website for the division of Kenwood that produced this drive has gone away and has some cheesy site in it's place ( I think the URL off the top of my head is ). I know that this drive ahs issues reading CD-Rs because of the ZEN technology it uses. It diffracts the laser into 7 distinct lasers to read multiple tracks at a time. CD-R media tends to run tracks closer together and then the diffracted laser beams alignment are all off. Store bought CD-ROMs have never given me trouble until now. This thing usually blazes through installs too. While the Descent install emcopoassing 2 discs seems to have succeeded it did seem slower than usual. On device manager it looks like it is using a default Microsoft driver though I thought Kenwood supplies one though I can't find anyware to download it ( besides the firmware flasher ). Anyone have any ideas on finding a driver or things I can try. Perhaps I should back out Roxio CD creator in case it caused the problem but if it did maybe the damage is done and irrepairable by just uninstalling.



    MrGaribaldi wrote:

    Roman> Would you mind going into a bit more detail? Have you done everything suggested in this thread? What are the latest drivers you've tried? (Oh, and what is your system specs?)

    Aside from that
    Hello & Welcome to TechSpot
  17. bkaa

    bkaa TS Rookie Posts: 36

    Ah, im having the same problem, i have a 9600XT, and the computer is like very slowwwwwwww. I dont know what to do, when i right click and go to properties on My computerrr... i look at my video card, and it says RADEON 9600 SERIES (is it suppose to say that?), i double click on it, and where it says Location, it says PCI bus1, Device0, function0, . I need help :( :(
  18. Roman

    Roman TS Rookie


    9600 series and what you describe for description of location is exactly what I have under device manager I also show a second display adapter 9600 SERIES - Secondary because I have enabled dual screen support for viewing on TV.

    In the device status window on this tab does it say the device is working properly I think this may be where I realized there was a conflict with the card's memory range and the PCI/AGP bridge. Check the resources tab too I know it showed it there as a conflict and make sure it is there.

    Make sure you are using the right drivers for the right model and OS you have. There may be updated drivers for your model. I found the site very finickey and if you didn't search for the exact right words it totally screwed errr skewed the results!

    Still haven't the time to get into 98 and get it working there.
  19. bkaa

    bkaa TS Rookie Posts: 36

    Yes, acutally i did see a conflict between the PCI to AGP bridge, only when i start my computer in safe mode. But when i start windows normally its okay. How could i be able to fix this problem? Oh by the way, i have all the right updated drivers for my video card, so i know that is not the problem, for the right operating system.
  20. wikiwooo

    wikiwooo TS Rookie

    i just got from the ati radeon 9600xt 256 mb turbo edition (with blue led) well i uninstall my nvidia drivers from my old card(nvidia geforcefx 5200 128mb) and try and install the new ati drivers, at first, it seems they are already installed, i can put my screen res at over 2xxx, 1xxx somtin like that, the max for the card, then i try and really install them, get some error, restart, and now just have basic resolution options. i have tried puttin in old card and stuff like that, downloading catalysts off of the ati site, nothing seems to work. im not sure how to use the device manager thing correctly, but im pretty sure its not even recognizing my card......any ideas?
  21. Pilrau

    Pilrau TS Rookie

    'm going through the same basic problem. Radeon 9600 Pro, "Try to setup a standard VGA driver before running setup." I've gone through the Add-Hardware wizard and device manager, and neither one even recognizes a display adapter at all. I'm on VGASave.

    I tried DNA-Drivers, New ATI-Drivers, DriverCleaner, Manual Install, Everything. When I went into safe-mode, however-the error message changed. Instead of just saying "Try to do this before you do this" it read,

    "INF Error - Video Driver Not Found."

    That same problem came up with the Catalyst-ATI driver setup and the DNA setup.

    What makes this problem so weird to me is that it just . . .sorta happened. Drivers were working fine, and I had some great FPS in Generals, but then one day--"No ATI card detected." It's not fried, otherwise there shouldn't be ANY functionality, right?

    Please help. I'm exhausted with this problem.
  22. wikiwooo

    wikiwooo TS Rookie

    i ended up just reformatting, it sucks, but at least my vid card works now, works very well....i love halo single player no lag at all
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...