Dell Inspiron 1420 Alps touchpad stopped working

By AJAces · 7 replies
Feb 10, 2011
Post New Reply
  1. For about two months now, the touchpad on my Dell Inspiron 1420 has not worked properly. The touchpad does not respond to touch (at all) nor do the buttons work. Additionally, the touchpad driver does not show up in “Device Manager” at all. The files do still exist under “Dell Drivers” though and the application can be found under “programs”.

    So far, I have:

    -uninstalled and re-installed the touchpad driver (many times). If I remove all files and re-install the drivers, and reboot as instructed by the prompts; the touchpad will usually work until I put the computer to sleep or restart it. Then, once again, no response at all. The icon in the bottom right of the desktop also disappears, as does the driver in “device manager”. The files still exist though in “dell drivers” and under “programs”.

    -started the computer in safe mode. The touchpad works fine anytime I am in safe mode.

    -disabled all programs (programs that had that option) that run on start up. I did this thinking that a start up program was controlling the touchpad since it starts fine in safe mode. The Alps driver (for the touchpad) that should appear under start up programs does not and I have never disabled it when it did show up. Stopping all programs that run at start up did nothing to fix the touchpad.

    -I run AVG anti-virus software every day and have run Ad-Aware antispyware multiple times but this seems to have no effect on the touchpad problem.

    At this point I am not sure what to do. I don’t know if it is a virus, malware, corrupt program or just a program that is controlling the touchpad for some reason.

    Any help on this very frustrating problem would be greatly appreciated. Any suggestions?

    Thanks in advance for any help!
  2. robin_bga

    robin_bga TS Rookie Posts: 171

    I am thinking that maybe that is a 64bit, if so then you are having a driver conflict, i suggest that you make sure you have the right drivers from the Dell website for your Laptop, or check you Even viewer logs to see what could be the cause of that problem.
    If that isn't the problem, then lets us know...
  3. AJAces

    AJAces TS Rookie Topic Starter

    Thank you so much for replying so quickly!

    My system is actually a 32-bit, at least that is what is displayed when I enter my service tag number at dells website.

    Is there another way to verify it is a 32-bit?

    The last time I downloaded the driver for the touchpad it was from the Dell site so I believe I have the correct driver installed.

    Is there another way to verify that my driver is the most current?

    I am not sure how to display my "event viewer logs" or how to read it. Can you please explain further.

    Thanks so much!
  4. robin_bga

    robin_bga TS Rookie Posts: 171

    Ok i will explain by giving you [​IMG] i hope that helps.
    In the last reply i included a website to get the drivers from, i hope you used the same.
  5. AJAces

    AJAces TS Rookie Topic Starter


    I checked my event log and didn't see anything that seems to be related to the touchpad. The only thing I saw that was related was all the times I have re-installed it.

    Any suggestions to what else it could be?

    Why does it work in safe mode? Could some program (that is not started in safe mode) be controlling it?

    Or a virus or malware?

    I am not sure what to do next?

    Any suggestions would be great!
  6. robin_bga

    robin_bga TS Rookie Posts: 171

    I personally think its a driver conflict some where that we dont know about, so may be look carefully at all you startup programs, you can uses tools like Starter or Autorun that can revile all hidden startup programs.
    I also think that maybe uninstall the alps software... so that Windows uses the generic drivers, that could help...
    Am out...Its Midnight here...
  7. AJAces

    AJAces TS Rookie Topic Starter

    I ran "Autorun" but I don't really know what I am looking for. It does give me an extensive list of programs that run at start up but I don't know which ones may be affecting the touchpad.

    Can you give me an idea of what I should be looking for?

    Thank you for all your help!
  8. AJAces

    AJAces TS Rookie Topic Starter

    Oh, and by the way I did not install the Alps driver for the touchpad. It is the one that came installed in the laptop.

    Is there a "generic" driver that I don't know about?

    Thanks again.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...