Dell Latitude CP won't boot without old 2gb drive

By G_Mez ยท 19 replies
Apr 8, 2008
  1. I am trying to replace the original 2Gb IBM drive with a 40Gb Toshiba. Everytime I put the 40 in the bios won't recognise it. So I've called Dell to see how large a drive Bios A13 will see. They won't help unless I use paid support due to the products age... I am able to boot up fine with 2Gb drive in it and can change boot order in Bios, set it to CD. I can boot from CD and have used several different boot disks all with no problem. Now I want to flash Bios to A16 - to see if it will recognise the larger drive. Only downside is I HAVE to have the original HDD in it when I do it. I have cloned it onto the 40 but I'm worried about something going wrong with the flash since I can only flash from HD, or CD. I definately do not want to risk disrupting the ONLY disk I know will run in this machine ! My last attempt was to pull the HD caddy out and on boot up I get a "Primary hard disk drive 0 not found No bootable device(s) selected strike F1 to retry boot, F2 for setup utility" This error occurs no matter what order I use in setup and no matter which boot cd I use. I can only boot from cd with the 2Gb drive in it.

    Any other methods I may have missed or Keystrokes ??
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Confirming your computer exactly from here:
    Continue with the bios update, which will not affect your system or data files.

    Be aware that no one gauratees bios updating, not even Dell
    It is therefore highly requested that you use the backup old Bios (using the same Bios utility) first.

    If it's any consolation I'd do it.
  3. G_Mez

    G_Mez TS Rookie Topic Starter

    Just to be sure

    That means putting in the original drive and flashing from a boot CD - I'm scared. I would like to have copy of current bios as fallback too. The Dell site only lists A12, a downgrade utility and A16 as the 3 downloadable options. Of course this one has to have A13 in it. From the little I've been able to gather A13 was supposed to fix a battery charging issue - I have no idea what A16 fixes... hopefully it just recognizes larger drives. I read somewhere that CP's are only supposed to handle 18gb max - I can't confirm it though.

    Oh and btw THANK you again for all the help you've given me and so many others, I truly appreciate it.
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    It may not be the best advice a support member should give.
    But if you have confirmed your system (usually via asset tag)
    I would go for it. Mind you I can't be held responsible (only the flasher can ! That's you)
    But I'd do it still.
    Actually download the other bios revisions too (old one) just in case the new one causes another issue.
    Put them all on CD, but flash with the latest first ofcourse
    (this is only for your system by the way)

    As for the limitations on size, actually I'm sure CP should be able to see more.

    Also (I was just about to submit the message!)
    Make sure you read all the guidelines to the proceedures to flash the Bios
    All USB out (including external mouse)
    Actually disconnect all externals except power
    Make sure your battery is fully charged (in case of power failure)
    That's about it.

    Oh and let me know the outcome
  5. G_Mez

    G_Mez TS Rookie Topic Starter

    Even the simplest of tasks now seems out of my grasp

    No joy, I have been unable to produce a clean bootable cd with the dell flash program accesable. I have wasted just about all the free time I can find. I've tried BCD, BFD, Cdrommi, and none of them can get to LCP_A16.exe - only once did I get to it - from a bcd creation but it hadn't been a clean boot so I got "cannot run inside windows environment" error.

    The other iso I got to run was the DSTCD , I used it to set the service tag back onto machine. a small victory but never the less a win.

    So now I'm going to copy the exe to root of c: run it back up current bios and then pull the trigger. wish me luck
  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Just to be clear in what you just wrote.

    You cannot flash your bios whilst Windows shell is running.
    Which means you just need a bootable CD
    There are so many (as you know) that I don't need to go over this.

    Create a bootable CD, with the new bios rom file and flash utility
    Confirm CMOS is set for CD as the first bootable drive
    Boot from CD to a Dos prompt
    Run the Bios utility
  7. G_Mez

    G_Mez TS Rookie Topic Starter

    I just haven't been able to get a bootable dos cd to work where I can run the flash utility from. If It finds the file it won't run it, or If I DO get a clean boot I can't seem to locate file on disk. Finally I copied the utility to HD during a "non-clean" boot and rebboted for clean and ran utility from hd. Good news , it ran and upgraded to A16 (woot) , bad news utility did not offer opportunity to save existing A13 rev (boooo). Oh well at least it's running, with new bios - on old drive. Now hopefully one last time I can swap in 40 and be of to the races !

    Thank you again for your moral support, oh yeah and the technical stuf too :)
  8. G_Mez

    G_Mez TS Rookie Topic Starter

    Snake eyes

    I was so confident I even put all the screws back in ! bot up same story no hdd present, look in setup "Primary Hard Drive - NONE"


    I think I'm all fun'd out
  9. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Wow you updated from Windows Dos, I wouldn't guessed it would work

    Anyway, hear back from you soon (or later)
    By the way, if this is a new drive you might want to partition first. which means delete any old partition (make sure your Windows harddrive is disconnected fully first)
  10. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Grrr is this by chance a faulty harddrive?


    also please use reply, instead of totally editing your post
  11. G_Mez

    G_Mez TS Rookie Topic Starter

    It was a dos boot disk

    not windows dos, it's just that the clean boot disks are image files, so I couldn't get the utility in them. so using a boot cd with the LCP_A16.exe file on it I copied it to hd the rebooted clean from cd. I could access the HD but not the area of cd with flash utility on it. So I ran it from HD but in clean boot environment- sry for the poor wording the belts are begining to slip in the 'ol brain.
  12. G_Mez

    G_Mez TS Rookie Topic Starter

    I only edited the smiley face once.... honest.

    The HD i'm installing ran fine in my old machine - it was just too small for me. I'm donating it to these people to help them out. It will be more than enough for an elementary and middle schooler to do homework on. This very hard drive was actually wiped , formatted and imaged on a usb adapter on this very same latitude. Of course it was running the UBCD4Win at the time.

    The good side of the A16 bios flash, the CD will now boot when the 40gb drive is in the caddy !! So I'm in the process of snooping around with the UBCD4Win disk to see if it can come up with the drive. The setup menus still all appear to be the same as A13. But at least I can boot with drive inside ! Maybe I won't have to pull it out ( good thing I put all those itty bitty screws back in )
  13. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

  14. G_Mez

    G_Mez TS Rookie Topic Starter

    No hard disks were found

    Can't find the disk with any of my programs either... gonna swap back to the 2gb in caddy and usb the 40 - fdisk the 40 and retry
  15. kimsland

    kimsland Ex-TechSpotter Posts: 14,523


    I would prefer you try delpart, once any bios actually sees it !
  16. G_Mez

    G_Mez TS Rookie Topic Starter

    I'm gonna start looking for a smaller drive

    I have some local computer repair places around that part out machines. I think I'll troll around tommorow and see if I can find something smaller to try. I'll keep you posted.
  17. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Have you checked your BIOS settings again?

    Thinking out loud......

    When you had the drive in, it worked fine and the boot order was correct.

    When you took the drive out, your laptop may have reset the boot order so that it no longer includes a bootable drive.

    When you installed your new drive, your laptop may have no automagically added the drive into your boot order list.

    When you install your old drive, the same issue is possible.

    So check your CMOS settings. :)
  18. G_Mez

    G_Mez TS Rookie Topic Starter

    The bios settings don't have option to auto scan

    The new (just flashed) A16 rev bios has the same number of options as the previous A13 one that was installed. No matter what boot oreder I choose the 40gb Toshiba drive isn't recognised by the bios. The only thing that has improved is that with the 40gb drive installed I can now boot from CD, which with old A13 rev it would not do. With either bios rev I could boot from CD and original 2gb drive. The goal here is to replace the old 2gb drive with a larger one so it can hold some programs. With W2K and MS Office 2K installed and not much else there is only ~200 mb of room left. And I haven't even run MS update or installed antivirus/anti malware yet... 10 lbs in a 2 lb bag.
  19. G_Mez

    G_Mez TS Rookie Topic Starter

    Muwahaha , The fossil is alive !! I got a 12gb drive from a Dell in the caddy ! Popped it in and bingo Bios found it no problem, nuked it and imaged the original 2gb on to it and it runs fine ! Back up and going - adding the extra proggy's as we speak.
  20. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    12Gig you say.

    Anyway thanks for the update :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...