1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

DNS problem on one laptop, other computers on network working

By Fe3C ยท 8 replies
Dec 11, 2011
Post New Reply
  1. [Resolved] DNS problem on one laptop, other computers on network working

    I returned home for the holidays with my laptop running Windows 7 Enterprise 64-bit. When I connect to the wireless network, my laptop reports that it is connected with internet access, but there is no browsing capability at all. P2P works, Steam works, but Chrome/Firefox/Steam browser give me the "This webpage is not available" page, telling me that the DNS lookup failed. All the other computers at home are working happily.

    My settings were to obtain an IP address and DNS server address automatically. nslookup said DNS request timed out. It didn't work with the wireless or the wired internet with an ethernet cable.

    I set up another network by using my iPhone as a hotspot to make sure it wasn't an issue with all connections, and my computer could browse just fine using the iPhone hotspot. But it didn't work with my home connection.

    The first thing I tried was to use openDNS's DNS addresses ( and with my home connection. It still failed, and nslookup gave the same "DNS request timed out."

    I reset the modem/router (it's combined, unfortunately) to factory settings and tried directly connecting with an ethernet cable again. It worked for half a second and I opened 2 webpages before it stopped and gave the DNS errors again. I tried the wireless internet and it still didn't work.

    I can connect to the modem/router. I made a guest network just to try it, and I got DNS errors again. When I reconnected to my primary network, it worked for half a second again, then stopped.

    My next attempt to fix it was going to the cmd prompt and typing ipconfig /release then ipconfig /renew. I restarted my computer and tried again, but I still received the same errors, with P2P working like before.

    I turned off my firewall and tried, but it still didn't work.

    Then I tried ipconfig /registerdns, restarted my computer and tried again. Still didn't work.

    At this point, IPv6 has been disabled, but it's still not working.

    I restarted the modem/router multiple times, but it does nothing to alleviate the problem.

    I have Microsoft Security Essentials, did a scan, nothing detected.

    Also tried System Restore to two days ago, got an error about how it failed.

    Using openDNS address.
    Turned off IPv6
    ipconfig /release ipconfig /renew
    ipconfig /registerdns
    no virus/trojan
    system restore failed

    None of the above worked. Other computers at home using the ISP's provided DNS server work. My computer works with other connections, but not my home network.

    Is there anything else I can try?

    Thanks in advance.
  2. jobeard

    jobeard TS Ambassador Posts: 12,550   +1,440

    Good work. The router is fine[1] so don't fuss with it anymore.

    Look for an updated driver for your WiFi adaptor.

    On any working system run IPCONFIG /ALL and compare it to the results on the failing system. Look for missing Gateway address or IP address like 169.x.y.z

    Some concern re failing system restore, but that's not a networking problem per se.

    Work on a wired network first and then move to wifi.
    Empty all manual settings on the LAN Connection (get properties, scroll to tcp/ip, click property button - - check ALL tabs; delete everything.

    You should be able to PING and then PING google-public-dns-a.google.com.
    This shows the LAN adaptor has connectivity and DNS resolution.

    Now do the very same sequence with your WiFi connection.
    Disconnection from the router and then reconnect.
    Inspect IPCONFIG /ALL again to look for valid IP addr, gateway addr and valid DNS settings. (not the OpenDNS you had before).

    ping ; if this doesn't work, then the WiFi settings are invalid even before DNS is an issue.
  3. Fe3C

    Fe3C TS Rookie Topic Starter

    Jobeard, thanks for the response.

    I actually figured out the problem, or at least I've fixed it.

    Turns out that when I quit uTorrent, the internet connection returned to complete normalcy. There's probably something involving a high number of connections, or maybe some kind of query that uTorrent is sending out that made my router block or interfere with the DNS.

    When I ran uTorrent again, within 20 seconds everything stopped working like before. When I quit it, within a minute things were back to functioning.

    So for now I'm just using a computer I own elsewhere to torrent, and when downloads finish I transfer the files over to mine.

    Regarding system restore failing, I know my hard drive has a bad sector; I ran into some problems about it before, and chkdsk fixed a lot, but not everything. Maybe that had something to do with it.

    But thanks again! I hope this thread can help others with a similar problem.
  4. jobeard

    jobeard TS Ambassador Posts: 12,550   +1,440

    Make a new System Restore Point before continuing below - - -

    boot into safe mode (F8)


    enter CHKDSK C: /R
    if this is a laptop, be sure you can run while
    connected to the A/C, as this puppy will take >1hr to complete.

    the normal CHKDSK /F runs three sections, /R runs FIVE sections and is very thorough.

    the /R should remap any bad sector(s) and attempts to recover data so remapped.
  5. Fe3C

    Fe3C TS Rookie Topic Starter

    Thanks. I'll be sure to give it a try sometime when I don't need the laptop for a while.

    The last time I used chkdsk, it took a frightening 10 hours, and it still said it had errors, so I ran it again and it went for 6 hours.

    If the main problem of this thread has been resolved, does the title get edited to say so?
  6. jobeard

    jobeard TS Ambassador Posts: 12,550   +1,440

    IMO, that would be a kindness on your part.
    Go to the original Post, click on Edit, Click GO ADVANCED, and insert [solved] as the first token of the subject
  7. Try clearing your Chrome DNS. Believe or not it has it's own.
  8. netnoobbeerpro

    netnoobbeerpro TS Rookie

    Thanks! That was the problem for me as well.

    I did a little bit more digging. I thought it was weird that utorrent would be the cause so I did a bit more digging and this seemed to provide an answer:

  9. jobeard

    jobeard TS Ambassador Posts: 12,550   +1,440

    It has a CACHE, not a dns per se. If it's in the cache, then the DNS request is bypassed.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...