Drivers Driver failure, unknown devices in USB controller

I have been racking my brains all day on this but this morning I was chatting via webcam and suddenly my computer's built-in webcam got stuck, what I mean is that the camera was on, even after I ended the call my webcam light is still shining and I could not do anything concerning the webcam. So I restarted my computer to see if it would resolve the issue, but when my computer reboots, suddenly neither my camera or my USB ports are working...

I opened up my computer's device manager to see if it was an issue with the drivers.. at first it looked like nothing was wrong but then I noticed that I had two unknown devices in my USB Controllers list, I clicked 'Update Driver' and it said 'driver updated and can now be used' but it was still listed as 'Unknown Device' and my USB ports/built in webcam still do not work..

I tried uninstalling all the drivers under 'USB Controllers' and restarting Windows, but all it did was re-install them as 'unknown' device... I re-installed the chipset from HP's Website (I'm using an HP G60) but still same issue.. it makes me want to beat my face into a wall.. repeatedly.

Another thing worth noting is that I have two USB ports on the side of my laptop, the top one is currently unresponsive whereas the bottom one responds to something connecting to it but it shows up as 'USB Device not recognized' no matter what I plug into it

I am using an HP G60 Notebook Computer with Windows Vista... using Intel Chipset ICH9m

If anyone could help me out with this issue, I would really appreciate it..
 

LookinAround

Posts: 6,430   +186
I've seen this trick work on only just a couple occasions but is easy so is also worth a try for your symptoms

Shut down computer. Unplug from the wall. Remove battery if its a laptop. Let it sit for an hour or two to discharge power. Then plug back in and try again.

Hope it may help <fingers crossed>
 
  • Thread Starter Thread Starter
  • #4
I've seen this trick work on only just a couple occasions but is easy so is also worth a try for your symptoms

Shut down computer. Unplug from the wall. Remove battery if its a laptop. Let it sit for an hour or two to discharge power. Then plug back in and try again.

Hope it may help <fingers crossed>
Surprisingly that worked o.o... I have to say I'm dumbfounded, it's probably not something I will understand but then again working with electronics that should have been the first thing I should have known to try... I'm always telling people to turn their equipment off for a little while then turn it back on... I've never understood why it fixes their problems but I know it does...

Anyway thanks for the help, I mean it