DSL works fine, but cable can't recieve

By UserX826 ยท 9 replies
Dec 8, 2005
  1. Sorry my first post is in the tech section.. but i've spent the past hour or so reading through here trying to find an answer and no luck.

    I've got a linksys NIC and an onboard NIC.. both are doing the same thing..

    It has no problem conneting to the internet through my DSL connection (which i'm on now), but when i plug in the cable connection (both through my linksys switch and directly from the modem), it won't recieve any packets but does send. My roommate's connection works fine when we're both hooked up to the switch.

    If you need more info please ask. Any help is greatly appreciated! thanks in advance
  2. PanicX

    PanicX TechSpot Ambassador Posts: 669


    So you have 2 network ports on your PC.
    You have 1 switch (linksys router maybe?)
    You have 2 ISP's
    When you connect one ISP (DSL) to the switch, you have internet access.
    When you connect the other ISP, you lose access. (Only when DSL is also connected?)
    You have both network ports on your PC connected to the switch?

    If you unplug both NIC's on your PC and connect only 1 of them directly to the Cable ISP modem, can you get any access? If not, you need to contact that ISP to troubleshoot the issue.
  3. UserX826

    UserX826 TS Rookie Topic Starter

    If i unplug the nic and use the onboard lan.. dsl works.. if i unplug the dsl and plug in the cable.. doesn't work

    right now i'm not even using the switch.. both connections are straight from the modems.. but the cable does work on my roommate's comp
  4. UserX826

    UserX826 TS Rookie Topic Starter

    oh.. same behavior if i disable the onboard and use the nic
  5. PanicX

    PanicX TechSpot Ambassador Posts: 669

    Do you have DHCP enabled on your NICs?

    When you plug in the cable modem, what output do you get from ipconfig.
    (Start Menu -> Run -> cmd <enter> -> ipconfig /all)

    When you connect the cable modem, does your NIC recognize that a cable is connected? (does it have a red "X" on the network icon in your taskbar?)

    Try using a the ipconfig /renew command after connecting the cable modem.
  6. jobeard

    jobeard TS Ambassador Posts: 11,160   +986

    if you have a true SWITCH, then you've got the worng equipment.
    Have you EVER been able to run all systems at the same time?
    IF yes, the you must have a ROUTER;
    if no, it's likely to be a hub or switch and you need a router
  7. rdbaron9

    rdbaron9 TS Rookie

    I am having a similar problem. I just configured a new system to be an exact clone of my other computer (exact same motherboard, hard drive, memory, graphics card processor). Everything works great but I can't get the internet to work. When I connect the cable from the modem to the onboard Lan it says it is connected but it won't receive packets - no internet. I've tried hooking up a linksys router and using my other computer to ping it but it fails. I noticed the working computer has a DHCP of 192.168.x.x, but the other computer that i'm having troubles with pulls a and says the address type is "automatic private address". I'm tried to set the IP and DNS instead of "obtaining it automatically" and changing the MAC address around in an attempt to allow me to ping it but i couldn't get it to work.
    If I got a network card would I have the same problems?
    I'm afraid the motherboard I picked up is bad, but it seems like it is a software issue of somekind.
    This is what I get for ipconfig/all
    Host Name.... erin
    Primary Dns Suffix .... (nothing) although I'm using Road Runner and I thought there should be something listed here
    Node type...unknown
    ip routing enabled....no
    wins proxy enable....no

    ethernet adapter local area connection:
    connection-specific DNS suffix :
    description: NVIDIA nForce Networking Controller
    Physical address: 00-15-f2-50-ee-7c
    dchp enabled : yes
    autoconfiguration enabled: yes
    autocnofiguration ip address:
    subnet mask:
    default gateway:
  8. rdbaron9

    rdbaron9 TS Rookie

    I realize I am a new member and this post is old but I'm just trying to find some help. I'm not turing up any answers on the Nvidia forums.
    Thanks in advance to anyone that can offer any support
  9. Ellgor

    Ellgor TS Rookie

    Hi, rdbaron9,

    After months of changing the IP, Mac address and whathaveyou all it took to get on line was to switch the modem off for 3mins, you can but try?

    Regards, Ellgor.
  10. rdbaron9

    rdbaron9 TS Rookie

    Hey thanks for the reply Ellgor, I'll try to leave it unplugged longer but I don't believe that is the problem - I've already tried resetting the modem a few times already.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...