DVD Burner stopped working

By MikeL ยท 11 replies
Aug 22, 2006
  1. I have a Sony DRU500A burner in my XP-based system, which has worked for over a year. Starting last week, any application capable of burning a CD or DVD issues the message: "No compatible Recordable or Rewritable devices could be found on your system". The drive can read CDs and DVDs just fine.
    I've swapped out the drive, but get the same message on the alternate burner. I've deleted the driver in Device Manager and rebooted. XP never acknowledged a new device. It just came back up in the same state as before.
    Anyone have any advice?
  2. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    So you uninstalled the device and XP didn't pick it up after a reboot?
    Search the net for the latest drivers and update it. That is providing you can see it in device manager.

    Do you have system restore enabled?
  3. MikeL

    MikeL TS Rookie Topic Starter

    To be more precise: First I uninstalled the driver (I think it was cdrom.sys) and when I rebooted I didn't get the usual "Found new hardware" pop-up, however the drive was back in Device Manager. I tried this with both a Sony and a Memorex burner. I then uninstalled and physically removed the IDE cable from both the burner and the reader which share a cable. After that reboot, I did get the found hardware message, but no change in the symptom whereby the system thinks that there's no burner attached.
    With regard to system restore. I'd never looked into it, but from what I can see, I have it enabled with restore points dating back to May 2006. Should I go back to an earlier time?
    And thanks, very much for taking the time to help.
  4. korrupt

    korrupt TS Rookie Posts: 716

    Could be your IDE driver.


  5. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    Roll back to a time you know it was working fine. System restore takes snapshots of your driver and registry settings. You may find it works after that.

    Be careful though, rolling back will uninstall programs you have installed recently.
  6. MikeL

    MikeL TS Rookie Topic Starter

    I tried rolling back to the various dates XP claims I could, but when it returns after the reboot, it always tells me that it couldn't do the System Restore. I'll try a few more tonight (takes a while to do each), but it doesn't look good.
    With respect to the IDE driver, do I just uninstall it and reboot?
    If all else fails I guess I'll go back to bare metal on the boot disk, but it takes several evenings to get back to current levels on XP, Internet Security and all the application installs so if anyone has other thoughts, I'd be grateful.
  7. iss

    iss TechSpot Chancellor Posts: 1,994

    Have you tried using a different IDE cable? The one you have may be bad.
  8. MikeL

    MikeL TS Rookie Topic Starter

    Yes, I did try a different IDE cable, again without success. Finally I took a deep breath and reburned my system. I installed a DVD burner application as soon as I was half-way back to normal and the problem had disappeared. I conclude it definitely was software and I'm likely never to know the cause. The drivers reported by Device Manager are the same ones as when I had the problem.

    Thanks for all the suggestions.
  9. MikeL

    MikeL TS Rookie Topic Starter

    Ok, it's about a month later and after re-burning my system, I've been happily burning CDs and DVDs. Then, you guessed it, the same dreaded message "No compatible Recordable, Rewritable, or Read Only devices were found on your system" appeared.

    So to summarize, I've swapped DVD Writers, IDE cables and without having installed anything, the problem comes back.

    Is it time to move to a Mac, or can anyone suggest something else? Thanks.
  10. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    I think this is a problem with the upper and lower filters in the registry. You should delete them. For information on how to manually do this, check this page at the Microsoft website.

    Edit: Roxio has a utility that deletes the filters. Although you might not have used a Roxio product, the utility works anyway. Click here for more info. I've used it successfully when my Easy CD creator software gave a message similar to the one in the first post in this thread.
  11. MikeL

    MikeL TS Rookie Topic Starter

    Thank you mailpup, you're a life-saver.
    I first tried to use the Roxio utility, but that didn't seem to help. When I checked the registry the upper and lower filters described in the MS website were still there. I then uninstalled both of my burner applications. Next I followed the microsoft instructions for deleting the upper and lower filter entries. Finally, I reinstalled the first burner application and it worked!!!
    I haven't tried to install the second app and suspect the problem may then return. Awkward, but at least I now know how to recover.
    Thanks again!
  12. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    Glad I was able to help some.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...