DVD-RW: DRU710A not reading disks

By NintyMat
Aug 26, 2011
Post New Reply
  1. I recently recieved a newish computer that seems to work fine except for the DVD player. When I put in DVDs and then click on the DVD drive, it says to put in a disk, even though I already have. I have a Sony DVD-RW: DRU710A as a DVD player. I have tried putting in DVD-R disks, which is a supported type by the DVD player, but it isn't working. I tried to download a firmware update "BYX5" from the Sony product page for this model, but when I try to run it, it says "Access denied! You must have administrative privileges to flash drives" even though I only have one account on this computer, and the control panel says it is an administrator (I even added a password for it). If someone can tell me how to get this DVD player working, I would be very thankful.
    P.S. I am running Windows 7 if that makes any difference.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Optical drives are not expensive any longer. Replace the drive

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...