DVD-RW Problem...

By Ziyonex · 18 replies
Dec 16, 2006
  1. Well, this is Ziyonex again with another optical drive problem.

    I have built my first computer and have everything working but this DVD drive. The weird thing is it was working about a month after I completed the computer. It just recently stopped.

    The problem is: Windows cannot initialize the device driver for this hardware. (Code 37)
    On instinct I tried to reinstall the driver from Samsung, but the program didn't detect the drive. The installation program requires detection of the drive in order to install.

    The drive is a Samsung SH-S182D DVD Drive. The problem started a day ago, it just stopped working. It won't show up in My Computer or anything, although it WILL show up in BIOS. I did no hardware tweaking before the drive stopped working.

    I noticed that my computer automatically updated itself (via Automatic Updates) before it happened. I have heard problems of some soft/hardware not working after some updates, so I uninstalled all the recent updates. No success. I also hooked up a newly bought PDA and MP3 player, and installed some software with those, but I don't know if that would affect anything. I also messed around in the BIOS, changing the boot priority and stuff, no luck. Also, just for fun, messed around with the IDE cord, unplugged it and plugged it back in, no luck.

    I swear, I have had a horrible time with my optical drives. If someone has any idea on what could have gone wrong, please let me know how to fix this.

    EDIT: DRIVE IS RECOGNIZED IN SAFE MODE. I started my computer in safe mode and it fully detected my drive, showed up in My Computer, read CD's and everything. I am thinking it might be a specific application that is making the drive not operate. I'll keep workin on it... uhg.

    EDIT 2: Sorry, I tried to make this an edit on the first post.
  2. iss

    iss TechSpot Chancellor Posts: 1,994

    Have you installed any emulation software? like daemon tools, alcohol 120? also what you could try is uninstalling the IDE channel the drive is on in device manager and reboot. windows should reinstall the IDE channel and the drive when windows restarts.
  3. Ziyonex

    Ziyonex TS Rookie Topic Starter

    Hey, sorry for late reply.

    I uninstalled the DVD drive itself and restarted, if that was what you meant by uninstalling the IDE channel, otherwise I don't know how to uninstall the IDE channel. It didn't work.

    I don't have any emulation software. But I do have Microsoft Active sync... it's not emulation, but it did install around the same time the drive stopped working. I'll give that a try and get back to you, thaniks.

    EDIT: Nope... It doesn't make sense to me why it wouldnt work in the normal Windows boot. It works in safe mode! That must mean that it is some sort of program blocking the driver software or something right?

    Surely someone else has had a similar problem.
  4. iss

    iss TechSpot Chancellor Posts: 1,994

    What I meant by uninstalling the IDe channel is uninstalling it in device manager. go to "IDE ATA|ATAPI CONTROLLERS" the drive SHOULD be on the secondary IDE channel( check under the advanced tab) uninstall it and reboot.
  5. Ziyonex

    Ziyonex TS Rookie Topic Starter

    Ahh, thanks, I'll give it a try and let you know. I didn't see that :p

    Can't I just uninstall all of them? I cant really figure out which channel my drive runs on.

    EDIT: Ok, well I uninstalled the Secondary ones, didn't do anything. Then uninstalled the primary ones, and restarted. It appears my primary ones are linked to my Hard Drives, which is weird because they run through SATA... w/e. That didn't work, but I will try it again just in case I didn't do it right.

    EDIT 2: There has to be some way to solve this... it works in safe mode, not in normal mode. Stopped working a while ago, was working fine. I'm sorta surprised this is still a problem, thought it was a bit of a small one, guess not. If anyone has any ideas please let me know.
  6. Ziyonex

    Ziyonex TS Rookie Topic Starter

    I think I need to post another in order to get any replies... I dunno. Just wondering if anyone has come up with any ideas for my problem. It honestly seems like a simple fix, I just tried everything I know.
  7. Ziyonex

    Ziyonex TS Rookie Topic Starter

    Ok, what the hell, I just bought a new CD Drive for my computer... the new one doesn't show up in normal mode either! It works perfectly in safe mode, as well as the first.

    That now confirms that the problem isn't with the drives themselves, but with some sort of software/hardware configuration.
  8. peepnklown

    peepnklown TS Rookie Posts: 126

    It might be a setting in BIOS…which board are you running?
  9. Ziyonex

    Ziyonex TS Rookie Topic Starter

    P5B Deluxe.

    I dunno that it is a setting in BIOS though, I was thinking more software. You probably know better than I do though.
  10. N3051M

    N3051M TS Evangelist Posts: 2,115

    If the drive works in safe mode and not in normal, then there must be a service or driver etc disrupting the normal function of it.

    In normal bootup go to start >run and type in msconfig
    Select Diagnostic startup and reboot your PC.
    If the drive works properly here, then go back to msconfig and enable one of the check boxes and reboot. Once you encounter the problem uncheck it and go to the corresponding tab and check each process one by one until you find the culprit. Repeat a couple of times (since there may be more than one) or until you can find the offending process/service/device or eliminated the problem.

    Note that this process of elimination will take a while and a lot of restarts but will be more or less accurate in finding what is causing your fault.
  11. Ziyonex

    Ziyonex TS Rookie Topic Starter

    And it was exactly that! It was a driver... that little son of a *****. It was a misc driver to go with one of my bay extensions. lol... well, thank you all for all your help. I really do appreciate it.

    So, I guess, for future reference to anyone who might have this same problem, always check your drivers! :D

    Thanks all
  12. N3051M

    N3051M TS Evangelist Posts: 2,115

    congratulations :)

    Have fun now :D
  13. Ziyonex

    Ziyonex TS Rookie Topic Starter

    Alright... well I somehow, I have no idea why, got the same problem, only this time they don't work in safe mode. They don't even work in the most simple boot mode in Diagnostic Boot. I am totally stumped now. I don't have any viruses or anything lol. Note: the drives ARE detected in BIOS.

    Ok, since it doesn't work in the most simple boot mode, it probably means the problem is within the system files, right? It would have to. After I unplug the drives, plug them back in again, and boot up to see if it will work, I am just going to reformat my C Drive and load windows on that. If that doesn't work I seriously think I might take a golf club to my monitor. (jk) But seriously, I have no idea why this is happening.

    EDIT: I just checked the device manager and this time the error is: Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39), instead of (Code 37) which is cannot initialize the device driver.

    So, in instinct, I downloaded the drivers and tried to install them. The only problem is the drivers didn't detect any optical drives to install to.

    Anyway, it doesn't matter, I am just going to format C:/ and get on with it.. lol. Seriously nobody has had problems like this before?
  14. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    What "drivers" are you installing? You should NOT be installing drivers for optical drives, they all run under a generic driver.

    And what do you mean by showing up in safe mode, or not working? I got confused reading all your posts.
  15. Ziyonex

    Ziyonex TS Rookie Topic Starter

    Sorry about that, this thread is composed of like 3 different problems lol. Anyway, I thought since the optical drives weren't working I might need to install a driver. I was going to the Samsung site and getting the drivers to see if it would work, nope, now I understand why.

    The drives didn't show up in My Computer in safe mode, which is weird, because in my first problem they did. I tried to diagnose the problem by run->msconfig but I couldn't get the drives to show up anywhere. (Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39) )... so I just reformat my C:/ and it works again. I'm going to be carefull what drivers I install.
  16. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Try to boot off a bootable cd. Its possible, but unlikely that your drive is bad. Is your ide ribbon any good? Try another one if possible.
  17. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    your computer install/download habits are bad. I have never seen a person have so many problems with optical drives and their proper operation. How are you with women? :confused:
  18. Ziyonex

    Ziyonex TS Rookie Topic Starter

    Hehehe... I'm not too bad. I think it's the certain hardware conflicting with many of my drivers. The software that came with my ASUS Mobo definitely was giving me some problems, and my front bay on my computer (shows temps, rpms, and has additional UBS ports, etc.) also had conflicting drivers, so I just wont install them :p

    Maybe it's just beginner's bad luck, first home-made computer. It's running fine now. Overclocked my E6300 to 3.05 GHz... highest I have ever seen anyone get an E6300. No more drivers for me :D

    Thanks guys

    EDIT: Tmagic, how do you like Montana? I live in Bozeman. I'm just curious, never really know anyone here who has the slightest interest in anything technological. I need to get out of here.
  19. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Hey Ziyonex,
    My fellow Montanian... Glad you got things sorted. I don't overcolck. Overcolcking stresses all the components in a system. I work on enough problem systems. I don't need overclocking problems too. Next time your in Billings, look me up. I sent you a PM
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...