Ethernet drivers?

By Gammio · 28 replies
Sep 8, 2012
Post New Reply
  1. I hooked up my computer via and ethernet cable to our router, with two 25 foot ethernet cables and a coupler in between them. The router does recognize that it's being plugged into (the little light for the port goes on, while the one next to it, which has an ethernet cable not plugged into another thing, so the end is just hanging free, does not light up), but when I try to troubleshoot problems on Windows, it says that I'm missing the proper "network drivers." So does my computer just not know hot to use it's in-built ethernet port?
  2. ImaBrokeDude

    ImaBrokeDude TS Enthusiast Posts: 34

    Hi Gammio,

    I recommend going to the manufacturer or your system's website (be it HP, Toshiba, Gateway, ASUS, eMachines, etc) and downlanding your Etherent (LAN) drivers from there.

    The drivers needed to operate the network interface on your system may be misconfigured. I recommend reinstalling those drivers using the information I posted above.

    Good Luck. :)
  3. Gammio

    Gammio TS Rookie Topic Starter Posts: 19

    I have a custom PC. Where should I go in that case? To the manufacturer of my case, or of my motherboard?
  4. ImaBrokeDude

    ImaBrokeDude TS Enthusiast Posts: 34

    If the network interface it integrated into the motherboard, look for the motherboard manufacturer's drivers. If it is an expansion card, look for the card manufacturer's drivers.

    Best Regards. :)
  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hi Gammio

    List any Problem devices
    • Make sure devices are connected and powered on
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    • On the other hand, if no devices are listed, tell me so
    Generate and attach a DirectX report
    • Click Start->Run, enter dxdiag and click OK
      ===> If you’re running 32 bit Windows, dxdiag will launch on its own
      ===> If you’re running 64 bit Windows, you’ll see 64-bit DxDiag. Click it to launch the 64-bit version of dxdiag
    • Notice progress in lower left window corner
    • When done, click Save Information button and save as a text file to your Desktop
    • Attach it to your next post by clicking the Upload a File button
  6. Gammio

    Gammio TS Rookie Topic Starter Posts: 19

    I'm still a bit confused, because even after downloading the Ethernet Diagnostic Utility drivers and the LAN Driver for the America region, and when I unplug my wi-fi card my network connection still won't even detect that I have a wired connection available. Could I need to download a different version of the drivers?

    Thank you for your help this far; I can be pretty inept at this stuff.

    I wasn't able to find the msinfo file in my computer for some reason. This makes me sad faic :(
    I was however able to run a dx diagnostic rep, so here's the file for that, thank you :D

    Attached Files:

  7. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 9,713   +3,691

    I assume the network controller is not disabled in the system BIOS?
  8. Gammio

    Gammio TS Rookie Topic Starter Posts: 19

    Onboard LAN Function is on as well as Onboard LAN ROM Boot, and my SMART LAN detects both ethernet cables (they're coupled together), so I'm not sure what the problem is :(

    I couldn't find anything specifically called Network Controller.
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Fyi... From your dxdiag ,
    > System Information section reports you're running Windows 7 64bit SP1. Your motherboard is a Gigabyte GA-880GM-USB3.
    > System Devices section includes
    Name: Ethernet Controller
    Device ID: PCI\VEN_10EC&DEV_8168&SUBSYS_E0001458&REV_06\4&7F0761B&0&0050
    This means your ethernet controller (which is synonymous w/network controller) is there and being detected by Windows. I believe the name implies you're computer is using the generic ethernet driver that comes from Microsoft. (fyi... When the hardware specific driver is installed, the name typically changes to a hardware specific name (such as the vendor and device model #)

    Look through Device Manager.
    1. Do you see anything listed with a yellow or red icon? (Especially look under System Device and Network Controller sections)
    2. Under Network section, is there a device name Ethernet controller? Right click Properties-
    > On the General tab is Device Status=This is working correctly? If not, report the error code
    3. Click the driver tab, is the Driver Provider Microsoft?
    cliffordcooley likes this.
  10. Gammio

    Gammio TS Rookie Topic Starter Posts: 19

    1. In device manager, the icon of my computer profile (GAMMIO_PC, so I guess that's my motherboard) has the yellow symbol on, and further delving into it reveals that the issues are with the Ethernet Controller and the USB Controller.

    2. It claims that there are no drivers installed for either device, thus they have no providor, number, or anything, which is very odd considering that I downloaded drivers for Windows 7 64bit, my system, earlier today from the Gigabyte website. The USB drives on the front of the computer case work fine, as to the ones on the motherboard, although the USB 3.0 ones, which are near the ethernet port, do not. (I'm not familier with what those do anyway Xp)
  11. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    The driver you should have downloaded and installed from the Gigabyte website is called the Realtek LAN Driver. Did you install all of the other drivers listed on your motherboard's driver page? If not, you should.
  12. Gammio

    Gammio TS Rookie Topic Starter Posts: 19

    I downloaded that one and a few others. Anything that seemed it could be related to performance or LAN.

    I'mma download the rest of those now then, I guess.
  13. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    Just a technicality but when you say you downloaded some of the drivers, you also installed them, correct? Just checking. I know it seems basic but occasionally someone forgets.
  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I just noticed Gigabyte provides a download tool where Gigabyte analyzes the motherboard and tells you what drivers to install. Note you need to use Internet Explorer when you use their tool.
  15. ImaBrokeDude

    ImaBrokeDude TS Enthusiast Posts: 34

    D: He beat me to it D:

    I commend you LookinAround :3
  16. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Oooops! No commendations. (n)

    Just occurred to me one needs a network connection before you can use the download tool! :oops:
    ImaBrokeDude and B00kWyrm like this.
  17. ImaBrokeDude

    ImaBrokeDude TS Enthusiast Posts: 34

    Oh... *looks around* right... *facepalm*
  18. Gammio

    Gammio TS Rookie Topic Starter Posts: 19

    I tried using the download tool, and my computer just refuses to use it. Whenever I hit "GO!!" it just has an error message that says "Please Wait for Download DL-Program", which is something that just never happens for me.

    Apparently my computer is very determined to maintain its cruddy, wi-fi connection :(
  19. ImaBrokeDude

    ImaBrokeDude TS Enthusiast Posts: 34

    I never ever thought to ask this but... when you look at your network adapters in the network and sharing center, does a LAN connection even exist? If so, is it disabled?
  20. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    From what I've seen, the network driver has to be installed and appear in DevManager before the network device appears as a logical device in Network Sharing.

    per the tool instrutions, when tried it were you using Internet Explorer as the browser. Also did you look in Programs and Features for all the MS updates installed. Note that one must be removed if there
  21. Gammio

    Gammio TS Rookie Topic Starter Posts: 19

    Where would I find and eradicate this update from? In my Programs tab on Control Bar, I can't find anything with that list number on there, or even in the whole computer when I search in the "All Progams" area.
  22. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +242

    Look in your control panel under Program and Features Icon Click on this. On the left hand side of the window you should see (view installed updates). Click on that, From their you should be able to uninstall the update. Hope this helps
  23. Gammio

    Gammio TS Rookie Topic Starter Posts: 19

    I'm pretty sure there's just nothing of that name anywhere in my updates. I've looked through the whole thing, and the only updates that even start with 9 are 982018, 976902, 971033. Pretty much everything else beings with a 2 and has 7 digits, and none of them start with a 29 either.

    I am very confused :(
  24. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Well, I thought their download tool would be the easiest solution! ARGHHH :mad:

    Let's try the old fashioned way next. Download, save then and double click to install these drivers (in order). Report if any errors. After both installed, look in Device Manager again and check if any yellow icons on the Ethernet Controller

    1. Install the AMD chipset drivers HERE

    2. Next, the Realtek LAN driver HERE

    Now report back
  25. Gammio

    Gammio TS Rookie Topic Starter Posts: 19

    Even after that, my computer just refuses to recognize the drivers. The same little yellow signals in device manager near Ethernet manager and USB manager tell me that they don't even now who the manufacturer is. :(

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...