Explorer.exe won't boot unless I start another high-mem process

By rsrwebs ยท 7 replies
Nov 28, 2009
  1. Hello,

    I've been having a strange problem lately, where explorer won't start up unless I start a high-memory using program (like Photoshop). I actually have two computers, that have almost identical hardware and software, and I used Advanced System Optimizer to fix startup/shutdown errors in explorer. It worked for one computer, but the other still has issues. I've repeated the error fixer process, but it still is the same.

    Also, explorer.exe will boot instantly when I log on from the welcome screen. The way I have it set up, is when I start up the computer, it automatically logs me in.

    I've tried ending explorer.exe's process, then restarting it, but when I do that all the programs that are supposed to start up, don't.

    I'm really at a loss and I would prefer not to reformat since I've already reformatted this computer a couple months ago. I have an up-to-date copy of ZoneAlarm Security Suite, and my last scan showed no viruses. I am continuing to look around on Google to try and find a solution, but so far I have not found anything.

    I have a few programs blocked from start-up with Advanced System Optimizer, I'm going to see what happens if I tell ZoneAlarm to not let it start up when I reboot and see if that solves my problem. I will update with the details on that.

    I really appreciate the help. :)

  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Try uninstalling ZoneAlarm fully
    ZoneAlarm has done stranger things in the past ;)
  3. rsrwebs

    rsrwebs TS Rookie Topic Starter

    Is there any thing else I could try? I really need ZoneAlarm to stay on the computer, because it's the only firewall and virus scan I have.

    Also, the other computer I mention that I managed to fix the problem with, has the same exact version of ZoneAlarm. Both computers have almost identical software and hardware.

    Another thing, ZoneAlarm can't and does not start up until explorer.exe is responsive.
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Really I have Windows Firewall running, all is well ;)

    ZoneAlarm is free (well, I think yours is free) I'd try uninstalling it
    Oh, I think free Comodo firewall is better anyway
  5. rsrwebs

    rsrwebs TS Rookie Topic Starter

    Okay, what if I uninstalled, then reinstalled it. Maybe that would work?

    And no, ZoneAlarm Security Suite is a $50 program. I'm really happy with it too, and I'd like to keep it.
  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,523


    just uninstall and leave uninstalled and then restart and then check (ideally report your likely no it didn't work, although its more likely it will)
    Then re-install, and restart again
  7. rsrwebs

    rsrwebs TS Rookie Topic Starter

    Alright, I'll try that. Thank you for replying. :)
  8. rsrwebs

    rsrwebs TS Rookie Topic Starter

    Arg. Turns out you were right. In fact, it's not just ZoneAlarm in general, its this specific upgrade version that's causing the hold up. I found out that the computer on which explorer.exe starts just fine, doesn't have the newest upgrade, which is most likely why it starts okay.

    I tried several things to workaround the problem, but to no avail. I tried having ZoneAlarm not start up when I reboot, but that didn't work. I set up another account on the computer, just so it would prompt me to log on, rather than logging on automatically, no luck (Did this because when I log off then back on after rebooting, explorer starts up instantly).

    I found that it wasn't my starting a high memory process that jump started explorer.exe, it starts up by itself after an amount of time. I timed how long it took from the moment the welcome screen disappeared to when explorer started, and came up with three different times, the only thing they had in common was that they were each over a minute. 1:11, 1:45, and 1:28, that's in order of the attempts.

    I'm going to write ZoneLabs, to at least let them know about the problem, so hopefully on the next release of an upgrade, they'll have fixed it. Again, thanks for the help, at least now I know what's causing it. :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...