External HD $Mft Currupted - HELP!!!

By salmansqadeer ยท 6 replies
Feb 8, 2007
  1. Hey everyone...

    okay so this problem has just come up randomly out of the blue -

    i have an external 80 GB WD harddrive connected to my laptop via a duel USB cable... i have been using this HD for the last year without any problems whatsoever.

    Yesterday while copying a significant amount of data onto it from another external - my computer crashed and i had to reboot. the drive was still accessable - i aborted the transfer and headed home...

    when i connected the external from home, i got a collection of errors - sometimes i could access the files sometimes i couldnt, chkdsk on the drive would return "cannot open volume for direct access"

    After installing partition magic i got the error msg "partition table is bad"

    It seems that my $Mft (i.e. the master file table for my external) has gone bad. So far this seems like bad news (i.e. loss of data, and a lot of pain in the ***)...

    The first most annoying thing is that nothing actually happened to cause this curruption - one moment the drive was working fine... after copying the files the drive cant be accessed anymore...

    There has to be a way to either restore the Master file table without loss of data or to create a new one that maintains all of my data. (preferably for free... but at the moment id even pay for something to do this).

    My external is partitioned into three partitions - each of the partitions is visible in my computer, each of the partitions OPEN to show all of the folders in that partition - but none of those folders will open.

    This last bit is perhaps the weirdest problem - it lets me access the drives just a little but wont let me copy, run, chkdsk, nothing.

    Please any help in this regard would be GREATLY appreciated.
  2. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    boot into SAFE MODE via run msconfig, set safemode and restart
    run sfc /now
    and then chkdsk /f
  3. salmansqadeer

    salmansqadeer TS Rookie Topic Starter

    still not working...

    Hey thanks for your reply...

    i tried what you said... but i couldnt get the external to be detected in safemode...

    i then tried plugging in the external HD and to my amazement it worked!

    i still wanted to run the checks... so i then ran the sfc while not in safemode... it ran and completed fine but during the process twice i got the write failure error and it said it was not able to save all of the data in $Mft.

    and now.. the HD wont work again!!!

    i tried running chkdsk but now it says:

    "cannot open volume for direct access"

    and though i can open up the drives and see a lot of folders... i still cant access any of those folders....

    please... help :(
  4. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    You've definitely got one of two problems here. Your drive is either failing (the hard drive inside is physically bad with bad sectors etc..) or the enclosure electronics are shot (not getting proper current from USB ports, a short or a flakey connection somewhere etc..).

    Hard drive warranties can last for many years, so you should contact Western Digital and get a replacement sent to you.
  5. salmansqadeer

    salmansqadeer TS Rookie Topic Starter

    EEK help!

    Okay - your not the first person to suggest it would be a hardware failure...

    considering the fact that im in EGYPT of all places at the moment, i was on my knees praying that it was just the problem with the enclosure...
    so i bought another enclosure - plugged it in.. .and walaaa! it started working - for about an hour that is...

    then the problems started again - write failure to $Mft, then all the problems stopped and the drive was perfectly accessable just REALLY REALLY slowly (approximately the speed of USB 1.0 - though its a 2.0 encasing etc). I checked the drivers to make sure everything was upto speed couldnt find any problems there...

    and NOW... out of the three partitions that my external is divided into - one of them is visible and accessable - and the other two are not accessable with the error msg:
    "the file or directory is currupted and unreadable"


    It was working in the middle - fine - without any problems!!! what happened!

    I have a feeling there isnt a physical problem with the HD - maybe a problem with the MFT or something... isnt there any way i can fix this without actually having to run data recovery? (its an 80 GB i dont have anywhere to store that much data - thats why i bought this HD!!!)

    Please please someone come up with something...

  6. salmansqadeer

    salmansqadeer TS Rookie Topic Starter

    Oh btw... i ran partition magic on the drives, and the error that i got on these two partitions is:

    Error #1507
    Bad file record signiture
  7. Bluemouse

    Bluemouse TS Rookie Posts: 195

    I had the exact same issue, but mine was with an internal WD sata Drive. Couldn't figure it out, because there were no bad sectors. My retailer insisted that it was working fine, so they wouldn't take it back. I decided to pay a 5% restocking fee rather than run back and forth 1000 times to argue with them. They just lost my business though, I can tell you that much.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...